LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 11-30-2012, 08:49 PM   #1
wenp
LQ Newbie
 
Registered: May 2011
Posts: 5

Rep: Reputation: 0
Stop GTK+ display of substitute fonts in editor?


In GTK+ text editors, glyphs missing from the default font will be drawn from some other installed font that has them. How do I prevent this so that just the "missing glyph" glyph is shown?
 
Old 12-02-2012, 03:22 PM   #2
John VV
Guru
 
Registered: Aug 2005
Posts: 12,913

Rep: Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715Reputation: 1715
???
ok, some unknown "text editor" is missing fonts on some unknown Operating system

set the default font in this editor to your system default

or
install the missing fonts
( see your package manager for that)
 
Old 12-15-2012, 08:44 PM   #3
wenp
LQ Newbie
 
Registered: May 2011
Posts: 5

Original Poster
Rep: Reputation: 0
There is no easy way to do this. Most editors built with GTK+ use GtkTextView, but there is no control over glyph substitution in that module. Within GTK+, it is Pango that handles this. You can't change the behavior with a config file, but you can use the fallback attribute to make a special build that doesn't take substitute glyphs.

At a lower level, font substitution for the whole system is managed by fontconfig, but there is no way to disable that feature in fontconfig.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
F15 gconf-editor Gtk-Message: Failed to load module "pk-gtk-module" syntax error Fedora 5 06-02-2011 02:10 PM
how to add fonts to kwrite editor FinalRebel Linux - Software 6 09-07-2009 04:50 PM
export display and Gtk-WARNING **: cannot open display: zimma Linux - Server 0 04-24-2009 02:51 AM
Nano editor just stop working FlashAsh99 Linux - Newbie 4 06-27-2005 05:54 PM
GTK+2, problems with applications that won't display fonts correctly Sm0k3 Slackware 2 09-12-2003 02:13 AM


All times are GMT -5. The time now is 01:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration