LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Stop GTK+ display of substitute fonts in editor? (http://www.linuxquestions.org/questions/linux-desktop-74/stop-gtk-display-of-substitute-fonts-in-editor-4175439522/)

wenp 11-30-2012 08:49 PM

Stop GTK+ display of substitute fonts in editor?
 
In GTK+ text editors, glyphs missing from the default font will be drawn from some other installed font that has them. How do I prevent this so that just the "missing glyph" glyph is shown?

John VV 12-02-2012 03:22 PM

???
ok, some unknown "text editor" is missing fonts on some unknown Operating system

set the default font in this editor to your system default

or
install the missing fonts
( see your package manager for that)

wenp 12-15-2012 08:44 PM

There is no easy way to do this. Most editors built with GTK+ use GtkTextView, but there is no control over glyph substitution in that module. Within GTK+, it is Pango that handles this. You can't change the behavior with a config file, but you can use the fallback attribute to make a special build that doesn't take substitute glyphs.

At a lower level, font substitution for the whole system is managed by fontconfig, but there is no way to disable that feature in fontconfig.


All times are GMT -5. The time now is 10:12 AM.