LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Stick is not a removable device (http://www.linuxquestions.org/questions/linux-desktop-74/stick-is-not-a-removable-device-4175461950/)

Zilvermeeuw 05-14-2013 01:20 PM

Stick is not a removable device
 
When I insert a known USB stick in my laptop, it does not show anymore in the "Device notifier" of KDE.
When I select show "All devices" or "non-removable devices only" it does show. But when I select "Removable devices only", it does not.

Previously, it did show.
I did not change anything, as far as i know.

I have an Acer Aspire v3-731, Fedora 18, KDE.

Any tips to solve this?

edorig 05-14-2013 02:13 PM

When you insert the USB stick in the computer, type dmesg in a Konsole window. Your stick should
produce messages "New USB devices...". Also, there should be messages [sdx] telling you that
the stick has the associated device file /dev/sdx[1-n]. /dev/sdx1 is the first partition (the whole
stick if you have not partitioned it). You should then check the /etc/fstab and /etc/mtab for lines
containing /dev/sdx1.
Normally, mount -t vfat /dev/sdx1 /mnt should mount the device, umount /mnt unmount it.
Are you using some kind of automounter daemon that mounts automatically the removable devices (I am not using
Fedora, so I have no idea of their default configuration) ?
Are you sure this daemon has not been updated recently (automatic security upgrade) ? Can you check that with rpm ?

Zilvermeeuw 05-14-2013 11:24 PM

dmesg says:

Code:

[ 8651.107289] usb 3-2: new high-speed USB device number 5 using xhci_hcd
[ 8651.119623] usb 3-2: New USB device found, idVendor=0781, idProduct=540e
[ 8651.119636] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 8651.119642] usb 3-2: Product: Cruzer Contour
[ 8651.119647] usb 3-2: Manufacturer: SanDisk Corporation
[ 8651.119652] usb 3-2: SerialNumber: 00001680D7730280
[ 8651.122013] scsi10 : usb-storage 3-2:1.0
[ 8652.126203] scsi 10:0:0:0: Direct-Access    SanDisk  Cruzer Contour  4.08 PQ: 0 ANSI: 2
[ 8652.127887] sd 10:0:0:0: Attached scsi generic sg2 type 0
[ 8652.128126] sd 10:0:0:0: [sdb] 16006797 512-byte logical blocks: (8.19 GB/7.63 GiB)
[ 8652.128310] sd 10:0:0:0: [sdb] Write Protect is off
[ 8652.128319] sd 10:0:0:0: [sdb] Mode Sense: 03 00 00 00
[ 8652.128490] sd 10:0:0:0: [sdb] No Caching mode page present
[ 8652.128496] sd 10:0:0:0: [sdb] Assuming drive cache: write through
[ 8652.129692] sd 10:0:0:0: [sdb] No Caching mode page present
[ 8652.129701] sd 10:0:0:0: [sdb] Assuming drive cache: write through
[ 8652.133448]  sdb: sdb1
[ 8652.134252] sd 10:0:0:0: [sdb] No Caching mode page present
[ 8652.134255] sd 10:0:0:0: [sdb] Assuming drive cache: write through
[ 8652.134258] sd 10:0:0:0: [sdb] Attached SCSI removable disk
[ 8652.220331] bio: create slab <bio-1> at 1
[ 8652.321374] bio: create slab <bio-2> at 2

I have the option "All Devices" checked. KDE asks for the root pw and the stick is mounted. But this is not the normal behaviour.

Now it gives all harddrive partitions and network shares in the list. Also I need to type the root pw to mount.

edorig 05-17-2013 01:14 PM

You must look at the file /etc/fstab. The fact that KDE asks for a root password for mounting a drive
indicates that mounts by a regular user are not permitted.
Normally, if mounts by regular users were permitted, you would see a line:

/dev/sdb1 /media/memory1 auto user,noauto 0 0

In that file. The first entry is the device file associated with your USB stick, the second entry is
the mount point, the third one ("auto") stands for filesystem autodetection, the fourth entry user,noauto
indicates user mounts are permitted, and mount should not be done at boot time. You can do man mount for
more details.
To mount without root password add that line (as root) to your /etc/fstab . You may also search
the forum for indicating devices by UUID or label in /etc/fstab.


All times are GMT -5. The time now is 02:07 AM.