LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 09-11-2006, 08:01 AM   #1
infraredgirl
Member
 
Registered: Feb 2006
Location: Belgrade, Serbia
Distribution: Slackware 11.0
Posts: 40

Rep: Reputation: 15
Start Freerock Gnome ?


I've downloaded and installed Freerock Gnome on my Slackware 10.2, but I can't figure out how to start it.

Help?
 
Old 09-11-2006, 09:42 AM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,780
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Try running xwmconfig in a console, select Gnome as your environment and then restart X. Basically, you need to get the proper Gnome start command in your ~/.xinitrc file, and xwmconfig will do that.
 
Old 09-11-2006, 05:58 PM   #3
infraredgirl
Member
 
Registered: Feb 2006
Location: Belgrade, Serbia
Distribution: Slackware 11.0
Posts: 40

Original Poster
Rep: Reputation: 15
I don't get Gnome listed when I run xwmconfig. All I get is: kde, xfce, blackbox, fluxbox, fvwm2 and twm.
Is there anything else I can do? Maybe edit ~/.xinitrc file by hand? Is there a command for starting Gnome like startkde (or kdm) is for KDE? Sorry about all these lame questions, but I've never used Gnome so I don't know; and Freerock's site is not very helpful...
 
Old 09-12-2006, 07:14 AM   #4
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,780
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Here is the startup command from my system. You can definitely just edit your .xinitrc by hand and add it as the last line. Just be sure to comment out the command for the existing GUI.

exec dbus-launch --exit-with-session gnome-session

Though I am a bit surprised that the Freerock install didn't add the package for xwmconfig. Are you positive you did a full install of Freerock?
 
Old 09-12-2006, 07:26 AM   #5
wmhrae
LQ Newbie
 
Registered: Sep 2006
Posts: 7

Rep: Reputation: 1
How to start Freerock Gnome

Open konsole and then type: pkgtool

choose: setup

scroll down on listing and hit spacebar when you are on : xwmconfig

now choose : xinitrc.Gnome

hit enter logout and the type startx

and off you go with gnome or if it is to complicated then do this as root :

past the command into your konsole as is :

rm /root/.xinitrc
cp /usr/lib/X11/xinit/xinitrc.gnome /root/.xinitrc

this will startx with gnome !!!

rm /root/.xinitrc
cp /usr/lib/X11/xinit/xinitrc.gnome-no-dbus /root/.xinitrc

this is the without dbus option

and to go back to kde :

rm /root/.xinitrc
cp /usr/lib/X11/xinit/xinitrc.kde /root/.xinitrc

Hope this help you
 
Old 09-12-2006, 06:55 PM   #6
infraredgirl
Member
 
Registered: Feb 2006
Location: Belgrade, Serbia
Distribution: Slackware 11.0
Posts: 40

Original Poster
Rep: Reputation: 15
I don't have /usr/lib/X11/xinit/xinitrc.gnome file. It's not there. I installed Freerock the way they recommend it on their site (http://gsb.freerock.org/installation/#net): by doing lynx --source http://gsb.freerock.org/net-install | sh
When I try to execute gnome-session, it says "command not found".
I can't tell what's wrong, it seems that it didn't install ok at all, but when I try to run the installer again, it just says that everything is already installed.
I'll try that alternative installation method.

Thanks for your help, anyway.

Last edited by infraredgirl; 09-12-2006 at 06:57 PM.
 
Old 09-13-2006, 07:19 AM   #7
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,780
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
From what you've posted, it sounds like the installation went haywire. I downloaded the .iso, mounted it, and then installed from that. Of course that means you need to have enough disk space to hold the .iso.

One thing to do would be to check your /var/log/packages directory and see if there are a bunch of packages with frg in the name (ls /var/log/packages/ | grep frg). If there aren't, then the install definitely went bad.

Last edited by Hangdog42; 09-13-2006 at 07:20 AM.
 
Old 10-01-2006, 03:36 AM   #8
Arun2610
LQ Newbie
 
Registered: Sep 2006
Posts: 3

Rep: Reputation: 0
@Hangdog42
Even I have the same problem with freerock Gnome. And I have tried checking for the packages as u suggested.
Here is a list of the packages that have been installed...
abiword-2.4.5-i486-2frg
atk-1.12.1-i486-1frg
audiofile-0.2.6-i486-2frg
avahi-0.6.12-i486-1frg
cairo-1.0.4-i486-1frg
dbus-0.62-i486-2frg
desktop-file-utils-0.11-i486-1frg
eel-2.14.3-i486-1frg
enchant-1.2.0-i486-1frg
esound-0.2.36-i486-3frg
fribidi-0.10.7-i486-1frg
gail-1.8.11-i486-1frg
gaim-1.5.0-i486-3frg
gamin-0.1.7-i486-1frg
gconf-2.14.0-i486-1frg
gftp-2.0.18-i486-3frg
gimp-2.2.12-i486-2frg
glib2-2.10.3-i486-1frg
glitz-0.4.4-i486-1frg
gnome-desktop-2.14.3-i486-1frg
gnome-icon-theme-2.14.2-i486-1frg
gnome-keyring-0.4.9-i486-1frg
gnome-menus-2.14.3-i486-2frg
gnome-mime-data-2.4.2-i486-3frg
gnome-vfs-2.14.2-i486-1frg
goffice-0.2.1-i486-1frg
gtk+2-2.8.20-i486-1frg
gtkspell-2.0.11-i486-1frg
gucharmap-1.6.0-i486-1frg
hicolor-icon-theme-0.9-i486-1frg
intltool-0.34.2-noarch-1frg
libart_lgpl-2.3.17-i486-2frg
libbonobo-2.14.0-i486-1frg
libbonoboui-2.14.0-i486-1frg
libcap-1.10-i486-2frg
libcroco-0.6.1-i486-1frg
libdaemon-0.10-i486-1frg
libgcrypt-1.2.2-i486-1frg
libglade-2.6.0-i486-1frg
libgnome-2.14.1-i486-3frg
libgnomecanvas-2.14.0-i486-1frg
libgnomecups-0.2.2-i486-1frg
libgnomeprint-2.12.1-i486-1frg
libgnomeprintui-2.12.1-i486-1frg
libgnomeui-2.14.1-i486-1frg
libgpg-error-1.1-i486-1frg
libgsf-1.14.1-i486-1frg
libgtkhtml-2.11.0-i486-1frg
libidl-0.8.7-i486-1frg
librsvg-2.14.4-i486-1frg
libwmf-0.2.8.4-i486-1frg
libwpd-0.8.4-i486-1frg
libxml2-2.6.26-i486-1frg
libxslt-1.1.17-i486-1frg
nautilus-2.14.3-i486-1frg
orbit2-2.14.2-i486-1frg
pango-1.12.3-i486-1frg
planner-0.14-i486-1frg
pygtk-2.8.6-i486-1frg
scrollkeeper-0.3.14-i486-3frg
shared-mime-info-0.18-i486-1frg
slapt-get-0.9.11e-i486-1frg
startup-notification-0.8-i486-2frg
xchat-2.6.6-i486-1frg
xscreensaver-5.00-i486-1frg

Even my /etc/X11/xinit directory does not contain xinitrc.gnome...
Please help
 
Old 10-01-2006, 07:50 AM   #9
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,780
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Well, since this seems to be a problem in Freerock, here is my xinitrc.gnome:

Code:
#!/bin/sh
# $XConsortium: xinitrc.cpp,v 1.4 91/08/22 11:41:34 rws Exp $

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/usr/X11R6/lib/X11/xinit/.Xresources
sysmodmap=/usr/X11R6/lib/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then
    xrdb -merge $sysresources
fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f $userresources ]; then
    xrdb -merge $userresources
fi

if [ -f $usermodmap ]; then
    xmodmap $usermodmap
fi

# This nag screen isn't going to save anybody.
export NAUTILUS_OK_TO_RUN_AS_ROOT=1

# Start the window manager:
exec dbus-launch --exit-with-session gnome-session
Add that to your /etc/X11/xinit, have it owned by root and give it 755 permissions. Then (hopefully) it will show up in xwmconfig.
 
Old 10-01-2006, 09:11 AM   #10
Arun2610
LQ Newbie
 
Registered: Sep 2006
Posts: 3

Rep: Reputation: 0
Hey thanks Hangdog42 for ur prompt reply...
I tried adding this script to xinit. It worked. an option for gnome appeared. However after making gnome my default desktop environment (using xwmconfig) and restarting the system I got an error message saying(dont remember the exact message) the files for Gnome environment were missing. So i guess the installation was screwed up in some way. Here is what i did to install frg.
I first updated my system using Swaret.
Then I tried using the net install method to install freerock. I tried to post the netinstall command but it seems that I have to post atleast three threads to be able to put a link in my posts. Anyways that command is available at freerock website. Its a one step installation method(they call it that way). And the version of freerock gnome that i tried to install is 2.14.3 stable.

After this I got a message that 26 files have to be installed and 35 to be upgraded.
Need to get 69Mb of archives and an additional space of 90 Mb will be required.
And then it downloaded and installed those packages. This is how freerock was installed on my system. After that the problems of xinitrc.gnome showed up. Now u know the rest of the story.
By the way I tried hard searching for freerock documentation. Fruitless effort.
Do u by any chance know where i can obtain its documentation. Their site is not that helpful.
Thanx again....
 
Old 10-01-2006, 10:05 AM   #11
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,780
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Quote:
I first updated my system using Swaret.
What did you upgrade your system to? Is it stock 10.2 or are you updating to current? The reason I'm asking is that I don't think Freerock (or Dropline for that matter) function on a -current system. You need to be 10.2.

As for the net install, all I can say is I have no experience doing it. I downloaded the .iso, mounted it, and installed off of that.

As for documentation, I've only used what is on the Freerock site. Check out the FAQs and support pages.

Finally, you probably need to pay attention to the error message you're getting at startup. That may be a clue as to what is going wrong and if you've had a bad install.
 
Old 10-01-2006, 11:32 PM   #12
Arun2610
LQ Newbie
 
Registered: Sep 2006
Posts: 3

Rep: Reputation: 0
I set the version to 10.2 in swaret.conf file. I am again unable to post the file here to get ur opinion. How do u upgrade ur system? Do u use swaret? If so could u post the
swaret.conf file?

And this is the error that I got while starting GNOME.
Quote:
Could not init fiont path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
Could not exec gnome-session:No such file or directory.
 
Old 10-02-2006, 06:39 AM   #13
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,780
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
If you're using swaret to keep 10.2 up to date, it should be fine. I use slackpkg to do it, but really the only problem with swaret is if people try to use it to keep up with current. There are things in current that will break your system if you don't install them properly, and since swaret just does things blindly, using it with current will break your system sooner or later.


From the error you've posted, I'm guessing that the net install didn't install everything. Not being able to find gnome-session is pretty bad since that is the command that starts gnome. Since there is no way that Freerock is going to leave out a command like that, I'm left assuming the install didn't work out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE to Freerock Gnome Spamdrew Linux - Newbie 2 07-17-2006 08:33 PM
Freerock Gnome, Slackware 10.2 hitest Slackware 2 05-21-2006 10:05 PM
rc scripts freerock gnome brokenflea Slackware 7 11-29-2005 05:40 PM
More Freerock Gnome 2.10 questions LinuxLuvr Slackware 2 09-08-2005 11:58 AM
Freerock Gnome 2.10 questions noxious Slackware 5 04-13-2005 09:15 PM


All times are GMT -5. The time now is 11:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration