LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Sound Problem with Adobe Flash Player on Debian Lenny (http://www.linuxquestions.org/questions/linux-desktop-74/sound-problem-with-adobe-flash-player-on-debian-lenny-852077/)

koosha 12-23-2010 01:21 PM

Sound Problem with Adobe Flash Player on Debian Lenny
 
Hi all
----------

I've got a problem with my flash player on Iceweasel (Debian's Firefox). It's mute and it plays all movies without sound. I've changed my sound driver to PulseAudio and other different drivers but couldn't fix it.

Any idea about what I have to do?


I'm running Debian Lenny AMD64.

frankbell 12-23-2010 08:58 PM

What are the contents of /usr/lib/mozilla/plugins?

I can play youtubes okay in Iceweasel and Opera and this is what I have.

Code:

flash-mozilla.so                      libtotem-gmp-plugin.xpt
flashplugin-alternative.so              libtotem-mully-plugin.so
librhythmbox-itms-detection-plugin.so  libtotem-mully-plugin.xpt
libtotem-basic-plugin.so              libtotem-narrowspace-plugin.so
libtotem-basic-plugin.xpt              libtotem-narrowspace-plugin.xpt
libtotem-complex-plugin.so              nphelix.so
libtotem-complex-plugin.xpt              nphelix.xpt
libtotem-gmp-plugin.so


koosha 12-24-2010 03:59 AM

Here is the contents of that directory:

flash-mozilla.so libtotem-complex-plugin.xpt
libflashplayer.so libtotem-gmp-plugin.so
libnpgoogletalk64.so libtotem-gmp-plugin.xpt
libnpgtpo3dautoplugin.so libtotem-mully-plugin.so
librhythmbox-itms-detection-plugin.so libtotem-mully-plugin.xpt
libtotem-basic-plugin.so libtotem-narrowspace-plugin.so
libtotem-basic-plugin.xpt libtotem-narrowspace-plugin.xpt
libtotem-complex-plugin.so

koosha 12-24-2010 03:59 AM

Here is the contents of that directory:

flash-mozilla.so libtotem-complex-plugin.xpt
libflashplayer.so libtotem-gmp-plugin.so
libnpgoogletalk64.so libtotem-gmp-plugin.xpt
libnpgtpo3dautoplugin.so libtotem-mully-plugin.so
librhythmbox-itms-detection-plugin.so libtotem-mully-plugin.xpt
libtotem-basic-plugin.so libtotem-narrowspace-plugin.so
libtotem-basic-plugin.xpt libtotem-narrowspace-plugin.xpt
libtotem-complex-plugin.so

frankbell 12-24-2010 08:27 PM

No answers, but some possible trouble-shooting questions that might move us ahead.

You do have libflashplayer.so in the plugins directory. That's the name of the official Adobe flash player plugin.

CD to the plugins directory and run ls -l and check the permissions. Not that I suspect that to reveal much, but there's no such thing as too little information.

Also, in Iceweasel, go to Tools-->Addons-->Plugins and verify that it's showing a flash plugin as installed.

If you have another browser, such as Epiphany or Sea Monkey, you might also test a YouTube in that to see what happens.


All times are GMT -5. The time now is 04:30 AM.