Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Desktop
User Name
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.


LinkBack Search this Thread
Old 09-26-2006, 08:41 PM   #1
LQ Newbie
Registered: Jul 2006
Posts: 4

Rep: Reputation: 0
slackware x in asus laptop

I just purchased this new ASUS A6U laptop and installed slackware 10.2 on it as a full install. This is my 4th try but everytime when i go to X-win (kde) and log out or while i am in kde if i try getting to other terminals with Cntrl + Alt + f3 etc the screen just goes blank and I can't see or do anything even in the terminal where the xwin was intally started (suspect it is 7).

But if i login to root from terminal 6 (this is still all blank so I am typing without seeing anything on the screen) and issue shutdown -r now it works. That means the system is still running in the background and its just the screens on all terminals including xwin one are blank.

Any suggestions in fixing this? I would imagine if the Sis Graphic card was incompatible it wouldn't start the xwin in the first place...

kernel version is 2.6 and modules 2.6 installed with gcc for that version of kernel as well. (initally used test26.a from slackware cd as a kernel image and installed modules from disk 2 and the gcc etc from "testing" folder in disk 3 of installation disks)

thanks in advance....
Old 09-27-2006, 12:18 AM   #2
Registered: Aug 2006
Posts: 147

Rep: Reputation: 16
I don't know much about what X does when you switch modes. Have you tried CTRL-ALT-[+] and CTRL-ALT-[-] combinations X uses to change screen resolution? Maybe it's going into a mode the laptop screen can't "see". You can also plug it into an external monitor and maybe see the screen again. Then you can pay with modelines or try commenting out the horizontal and vertical refresh and letting it auto detect.
Old 09-27-2006, 08:40 PM   #3
LQ Newbie
Registered: Jul 2006
Posts: 4

Original Poster
Rep: Reputation: 0
didn't work

Thanks for the suggestion. I tried that but didn't work. I changed the lilo setting to mode "normal" and others really low level ones as well but made no difference.

If anyone has any other suggestions, let me know.
Old 09-28-2006, 12:17 PM   #4
Registered: Aug 2006
Posts: 147

Rep: Reputation: 16
Most laptops have a VGA plug in the back where you can plug them in to an external monitor. This is a quick way to narrow down whether we are dealing with a simple mode change or something more video card related.
Old 09-30-2006, 03:45 AM   #5
Registered: Oct 2003
Location: Greece
Distribution: Debian sid
Posts: 248

Rep: Reputation: 30
This might be an incompatibility between the X graphics driver and the vesafb driver. I think that if you remove the vga=xxxx option in lilo, vesafb will be disabled (at least that happens in suse). Try it.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Asus laptop s8600 cayzar Linux - Laptop and Netbook 0 05-17-2006 08:37 AM
What is best Laptop for student use? Maybe ASUS? whited Linux - Hardware 3 05-03-2006 01:27 PM
WLan with ASUS laptop yannoweb Fedora 3 08-27-2005 03:18 PM
Asus M6Bna laptop luma Linux - Wireless Networking 1 02-24-2005 04:22 AM
ACPI and asus laptop.... Skyblaze Debian 2 01-23-2005 07:45 AM

All times are GMT -5. The time now is 08:05 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration