LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Screen refresh, image distorted if moving (http://www.linuxquestions.org/questions/linux-desktop-74/screen-refresh-image-distorted-if-moving-827638/)

bucovaina78 08-21-2010 10:50 AM

Screen refresh, image distorted if moving
 
2 Attachment(s)
Hi everyone,

I'm having some problems with playing movies and the "eye-candy" from Ubuntu 10.04.

My screen refreshes not in one time but in multiple times. First a horizontal bar of +/-5cm heighth than one down of 5cm than again... To explain a bit I've attached 2 print screens while playing a movie. That'll explain better

Graphics are going "smooth", so there is no delay, I don't have the feeling that my graphics card is chocking (Nvidia 9600 GSO with proprietary drivers installed and working well)

Anyone familiar with this problem?


Attachment 4366
Attachment 4367

amani 08-21-2010 11:10 AM

Your graphics card driver seems to require some options.

Anyway check without any desktop effects enabled

bucovaina78 08-21-2010 11:41 AM

can you explain: "require some options" ?

MrCode 08-22-2010 06:35 AM

This looks like tearing to me..."tearing" is when the GPU (or CPU, depending on which is doing the rendering) updates the display buffer at a higher rate than the screen refresh. So it'll draw one frame, and before the screen is done updating, it'll already be done drawing the next frame, but it sends the new image to the screen buffer anyway, causing "partial" images to show, since the rendering process is "getting ahead of itself", as it were. ;)

Try looking for a "vsync" or "double-buffered page flipping"*option in your settings. If you're using desktop effects (Compiz), you can go into CompizConfig Settings Manager, and under General Options, in the "Display Settings" tab, check "Sync to VBlank". This will synchronize buffer updates with screen updates (as best as it can; it's not perfect).

EDIT: Since you're using an NVIDIA GPU (w/ the closed-source driver), you can use their configuration tool to enable vsync system-wide. It should be under "X Server XVideo Settings" and "OpenGL Settings". I have them both enabled on this system, and everything's smooth as butter and tear-free. :)

bucovaina78 08-23-2010 06:22 AM

@MrCode:

I'm quite sure your post provides the answer/solution to my question. As soon as I get home I'm going to try it. Your explanation is so logical it HAS to be that :-). I looked "tearing" up on wikipedia and found a picture showing exactly what I have at home... .

Didn't know this phenomenon had a name (tearing). It has been annoying me for almost two years (really) ... I even bought a faster graphics card some time ago. I thought it wasn't fast enough but that was not the problem apparently.e

Anyway I know what I'm going to do this evening, enjoy a good (action)movie w/o artefacts in the screen Haha!

bucovaina78 08-31-2010 01:25 PM

Sorry for the late response, it did solve the issue, you've been thanked :)

layr 02-07-2012 05:23 AM

Digging up this old thread.
Are there any new or better solutions? I've tried Ubuntu and Debian. Both had massive screen tearing, which was solved only (!) by Compiz vsync and screen refresh settings. Nvidia vsync made very little to no changes whatsoever.

amani 02-10-2012 12:09 PM

Things are different now... kernel mode settings etc.
Start a new thread with your graphic card details and lspci -v.


All times are GMT -5. The time now is 01:51 AM.