LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices



Reply
 
Search this Thread
Old 04-03-2009, 06:44 PM   #1
zomane
Member
 
Registered: Sep 2005
Location: Bulgaria
Distribution: Debian, CentOS
Posts: 46

Rep: Reputation: 16
rxvt-unicode fonts proper setup


Hello,
I trying to setup my rxvt-unicode fonts to be bigger than default, but result is unsatisfactory.
Before I started my rxvt-unicode via fluxbox menu with opts, something like that :
rxvt-unicode -fg AntiqueWhite -bg Black -fn "xft:fonts_here" actually syntax was a little different, but I lost my old menu file when I migrate from gentoo to debian . Now I'm trying to setup it again.
I read rxvt-unicode FAQ and when I change font on the fly with :

PHP Code:
printf '\33]50;%s\007' "9x15,xft:Terminal" 
as described in FAQ I like the result (you can see it in attachment good_result.png)
But when I try to setup it in fluxbox menu like this :
PHP Code:
[exec] (Rxvt-unicode bozakey+u) {rxvt-unicode -fg AntiqueWhite -bg Black -fn "xft:Terminal:9x15"
result is different(another attachment bad_result.png) - symbols are bigger with big spaces between them .
where is my mistake ? I want fonts to be like when I change it with
PHP Code:
 printf '\33]50;%s\007' "9x15,xft:Terminal" 
.
I love rxvt, when I switched to Linux years ago I start using it because it simple and light and I want continue using it, but this fonts problems makes me crazy .

Distro is Debian Lenny.
Thanks.
Attached Images
File Type: jpg bad_result.jpg (104.3 KB, 15 views)
File Type: jpg good_result.jpg (103.6 KB, 15 views)

Last edited by zomane; 04-03-2009 at 06:46 PM.
 
Old 04-12-2009, 06:02 PM   #2
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
I'd say set the font and other properties in your ~/.Xdefaults file and don't mess with overly complex options to start urxvt - with everything in your ~/.Xdefaults you'll get the same options every time you start it.

Also, are you trying to specify two fonts? "xft:Terminal" would be a Truetype font but 9x15 is a pixel font. Try using just one of them instead, something like this (in ~/.Xdefaults):

Code:
URxvt*fg: AntiqueWhite
URxvt*bg: Black
URxvt*font: 9x15
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing fonts in rxvt and mc matthew1181 Slackware 12 03-11-2010 08:00 PM
problem with rxvt-unicode corbis_demon Linux - Software 0 11-27-2007 11:55 AM
Making rxvt-unicode change window title when using ssh tkarkkainen Linux - Software 1 10-15-2007 04:07 PM
System-wide urxvt (rxvt-unicode) X-resource control colo Linux - Software 2 07-17-2006 09:17 AM
fonts in rxvt tincat2 Linux - General 0 01-28-2004 05:35 AM


All times are GMT -5. The time now is 01:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration