LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   rxvt-unicode fonts proper setup (http://www.linuxquestions.org/questions/linux-desktop-74/rxvt-unicode-fonts-proper-setup-716675/)

zomane 04-03-2009 06:44 PM

rxvt-unicode fonts proper setup
 
2 Attachment(s)
Hello,
I trying to setup my rxvt-unicode fonts to be bigger than default, but result is unsatisfactory.
Before I started my rxvt-unicode via fluxbox menu with opts, something like that :
rxvt-unicode -fg AntiqueWhite -bg Black -fn "xft:fonts_here" actually syntax was a little different, but I lost my old menu file when I migrate from gentoo to debian . Now I'm trying to setup it again.
I read rxvt-unicode FAQ and when I change font on the fly with :

PHP Code:

printf '\33]50;%s\007' "9x15,xft:Terminal" 

as described in FAQ I like the result (you can see it in attachment good_result.png)
But when I try to setup it in fluxbox menu like this :
PHP Code:

[exec] (Rxvt-unicode bozakey+u) {rxvt-unicode -fg AntiqueWhite -bg Black -fn "xft:Terminal:9x15"

result is different(another attachment bad_result.png) - symbols are bigger with big spaces between them .
where is my mistake ? I want fonts to be like when I change it with
PHP Code:

 printf '\33]50;%s\007' "9x15,xft:Terminal" 

.
I love rxvt, when I switched to Linux years ago I start using it because it simple and light and I want continue using it, but this fonts problems makes me crazy .

Distro is Debian Lenny.
Thanks.

hw-tph 04-12-2009 06:02 PM

I'd say set the font and other properties in your ~/.Xdefaults file and don't mess with overly complex options to start urxvt - with everything in your ~/.Xdefaults you'll get the same options every time you start it.

Also, are you trying to specify two fonts? "xft:Terminal" would be a Truetype font but 9x15 is a pixel font. Try using just one of them instead, something like this (in ~/.Xdefaults):

Code:

URxvt*fg: AntiqueWhite
URxvt*bg: Black
URxvt*font: 9x15



All times are GMT -5. The time now is 08:55 PM.