LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 08-01-2008, 02:58 AM   #1
De-code
LQ Newbie
 
Registered: Aug 2008
Posts: 6

Rep: Reputation: 0
Resolution problem!


I know that you get this question a lot on the forum. I am running Ubuntu 8.04 with KDE. I can't change my screen res. at all when I go through the display setup, when I pick my resolution it won't let me apply it.
When I change it to 1024 x 768 from the desktop I get a SIGABRT error message, and it reverts back to 800 x 600.

I tried to go through the xorg config file but it wont let me change anything. It says I don't have the permission.

I have tried the XFCE environment and it works fine in 1024 x 768.

Thank you in advance for the help.
 
Old 08-01-2008, 05:01 AM   #2
pandanuma
Member
 
Registered: May 2005
Location: greatwhitenorth
Distribution: mint 17
Posts: 59
Blog Entries: 7

Rep: Reputation: 19
set screen resolution

using ubuntu 7.10, I click on System/Administration/Screens and Graphics
and a password request pops up. from there I can change my screen resolution.
8.04 should not be much different...
 
Old 08-01-2008, 01:17 PM   #3
De-code
LQ Newbie
 
Registered: Aug 2008
Posts: 6

Original Poster
Rep: Reputation: 0
I tried to do it that way but it will not let me apply the changes.
 
Old 08-02-2008, 04:18 AM   #4
pandanuma
Member
 
Registered: May 2005
Location: greatwhitenorth
Distribution: mint 17
Posts: 59
Blog Entries: 7

Rep: Reputation: 19
a little more searching and I found this...


For you to have permission to alter a system file, you have to open it as root.

Run
Code:
gksu gedit /etc/X11/xorg.conf
in order to be able to save.

just copy that line of code and past it into a terminal, make your changes and you should be able to save it...
 
Old 08-02-2008, 01:48 PM   #5
De-code
LQ Newbie
 
Registered: Aug 2008
Posts: 6

Original Poster
Rep: Reputation: 0
This is what I have in my xorg file:

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Should it look like that if not what do I add.
 
Old 08-02-2008, 06:19 PM   #6
pandanuma
Member
 
Registered: May 2005
Location: greatwhitenorth
Distribution: mint 17
Posts: 59
Blog Entries: 7

Rep: Reputation: 19
Angry

hope that is not your complete xorg file...

here is mine...
Code:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
	Fontpath	"/usr/share/fonts/X11/misc"
	Fontpath	"/usr/share/fonts/X11/cyrillic"
	Fontpath	"/usr/share/fonts/X11/100dpi/:unscaled"
	Fontpath	"/usr/share/fonts/X11/75dpi/:unscaled"
	Fontpath	"/usr/share/fonts/X11/Type1"
	Fontpath	"/usr/share/fonts/X11/100dpi"
	Fontpath	"/usr/share/fonts/X11/75dpi"
	# path to defoma fonts
	Fontpath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load		"i2c"
	Load		"bitmap"
	Load		"ddc"
	Load		"extmod"
	Load		"freetype"
	Load		"glx"
	Load		"int10"
	Load		"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"	"/dev/input/mice"
	Option		"Protocol"	"ImPS/2"
	Option		"ZAxisMapping"	"4 5"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"stylus"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"stylus"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"eraser"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"eraser"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"cursor"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"cursor"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
	Identifier	"nVidia Corporation C51 [GeForce 6150 LE]"
	Driver		"nvidia"
	Busid		"PCI:0:5:0"
	Option		"AddARGBVisuals"	"True"
	Option		"AddARGBGLXVisuals"	"True"
	Option		"NoLogo"	"True"
EndSection

Section "Monitor"
	Identifier	"HP w19b/w19e"
	Option		"DPMS"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"nVidia Corporation C51 [GeForce 6150 LE]"
	Monitor		"HP w19b/w19e"
	Defaultdepth	24
	SubSection "Display"
		Depth	1
		Modes		"1440x1440"	"1280x1024"	"1280x960"	"1152x864"	"1024x768"	"832x624"	"800x600"	"720x400"	"640x480"
	EndSubSection
	SubSection "Display"
		Depth	4
		Modes		"1440x1440"	"1280x1024"	"1280x960"	"1152x864"	"1024x768"	"832x624"	"800x600"	"720x400"	"640x480"
	EndSubSection
	SubSection "Display"
		Depth	8
		Modes		"1440x1440"	"1280x1024"	"1280x960"	"1152x864"	"1024x768"	"832x624"	"800x600"	"720x400"	"640x480"
	EndSubSection
	SubSection "Display"
		Depth	15
		Modes		"1440x1440"	"1280x1024"	"1280x960"	"1152x864"	"1024x768"	"832x624"	"800x600"	"720x400"	"640x480"
	EndSubSection
	SubSection "Display"
		Depth	16
		Modes		"1440x1440"	"1280x1024"	"1280x960"	"1152x864"	"1024x768"	"832x624"	"800x600"	"720x400"	"640x480"
	EndSubSection
	SubSection "Display"
		Depth	24
		Modes		"1440x1440"	"1280x1024"	"1280x960"	"1152x864"	"1024x768"	"832x624"	"800x600"	"720x400"	"640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
  screen "Default Screen"
	Inputdevice	"Generic Keyboard"
	Inputdevice	"Configured Mouse"
	Inputdevice	"stylus"	"SendCoreEvents"
	Inputdevice	"cursor"	"SendCoreEvents"
	Inputdevice	"eraser"	"SendCoreEvents"
EndSection

Section "DRI"
	Mode	0666
EndSection

I will not be much help for you trying to modify this file
will check back in a few days to see if anyone else can help...
good luck
 
Old 08-02-2008, 09:06 PM   #7
De-code
LQ Newbie
 
Registered: Aug 2008
Posts: 6

Original Poster
Rep: Reputation: 0
That was just a part of the xorg file pertaining to the display settings.

Is there a program I can run that will recognize what hardware I have?
I think that is where the problem is.
 
Old 08-02-2008, 11:10 PM   #8
jerril
Member
 
Registered: Nov 2005
Location: Ontario, Canada
Distribution: Ubuntu
Posts: 114

Rep: Reputation: 15
Things are definitely different in the xorg.conf for 8.04, there is definitely a driver issue here. KDE starts up like a charm, I hadn't used it, yet -- nice. I found out I could rotate my monitor if I want (cool).

What is your video card?

At the terminal, type:
Code:
sudo lshw
You should have a bunch of lines that looks like this:
Code:
        *-display UNCLAIMED
             description: VGA compatible controller
             product: 82945G/GZ Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 02
             width: 32 bits
             clock: 33MHz
             capabilities: msi pm vga_controller bus_master cap_list
             configuration: latency=0

This is a fishing trip, still checking things out here.

jer
 
Old 08-02-2008, 11:27 PM   #9
De-code
LQ Newbie
 
Registered: Aug 2008
Posts: 6

Original Poster
Rep: Reputation: 0
Hey Jer, when I typed that I got this:

*-display UNCLAIMED
description: VGA compatible controller
product: 82865G Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 02
width: 32 bits
clock: 33MHz
capabilities: pm vga_controller bus_master cap_list
configuration: latency=0
 
Old 08-02-2008, 11:29 PM   #10
De-code
LQ Newbie
 
Registered: Aug 2008
Posts: 6

Original Poster
Rep: Reputation: 0
I could bring up the program that lets me rotate as well as change my res. but after I change my res I get the sigabrt error message in KWIN.
 
Old 08-03-2008, 03:56 PM   #11
jerril
Member
 
Registered: Nov 2005
Location: Ontario, Canada
Distribution: Ubuntu
Posts: 114

Rep: Reputation: 15
De-code;

I got a suggestion to try this from Ubuntu forums, I have no idea what it is, but person looking for a solution said it worked for that card:

Code:
XORG_SYNC_RANGES=yes sudo dpkg-reconfigure -phigh xserver-xorg
Here is the page I got this suggestion from.

jer
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
yet another resolution problem pafrica Linux - Hardware 2 02-14-2006 05:11 AM
Resolution problem XaXo-BG Linux - Software 10 01-22-2005 11:47 AM
Resolution problem! 01doublehelix10 Linux - Hardware 2 11-14-2004 01:15 AM
resolution problem? binny959 Mandriva 1 10-02-2004 08:40 AM
name resolution problem mdwstmusik Linux - Networking 5 02-27-2003 10:53 PM


All times are GMT -5. The time now is 02:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration