LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 01-28-2014, 12:45 PM   #1
SaintDanBert
Senior Member
 
Registered: Jan 2009
Location: Austin, TX
Distribution: Mint-15 with Cinnamon & KDE
Posts: 1,350
Blog Entries: 3

Rep: Reputation: 86
python error in HPLIP commands


Can someone help me sort out what is going on with the utility suite for HP printers? I've started getting errors when I do anything with HPLIP tools:

Here is one example running hp-doctor:
Code:
prompt $ hp-doctor

Traceback (most recent call last):
  File "/usr/bin/hp-doctor", line 37, in <module>
    from base import utils, tui, module,queues, os_utils, services, smart_install
  File "/usr/share/hplip/base/module.py", line 30, in <module>
    import tui, utils, device
  File "/usr/share/hplip/base/device.py", line 42, in <module>
    import status
  File "/usr/share/hplip/base/status.py", line 59, in <module>
    import hpmudext
ImportError: /usr/lib/python2.7/dist-packages/hpmudext.so: undefined symbol: hpmud_make_par_uri
Here is another example running hp-setup:
Code:
prompt $ hp-setup

Traceback (most recent call last):
  File "/usr/bin/hp-setup", line 45, in <module>
    from base import device, utils, tui, models, module, services, os_utils
  File "/usr/share/hplip/base/device.py", line 42, in <module>
    import status
  File "/usr/share/hplip/base/status.py", line 59, in <module>
    import hpmudext
ImportError: /usr/lib/python2.7/dist-packages/hpmudext.so: undefined symbol: hpmud_make_par_uri
On inspection, every hplip related package reports v3.13.3.

The library hpmudext.so exists in the folder named in the error messages, but I cannot determine if the requested symbol is present. (I tried using 'ldd')

The workstation is Linux Mint-15 with all current patches.

NOTE -- This likely belongs in one of the HPLIP or related HP sites. I've tried them in the past and it took ages to get a reply if I got one at all. Sooooo, I came to my LQ friends.

~~~ 0;-Dan
 
Old 01-28-2014, 01:28 PM   #2
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,564
Blog Entries: 1

Rep: Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024Reputation: 1024
Hi,

See if that thread can help you:
http://www.linuxquestions.org/questi...-error-882033/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] hplip source make error Adol Linux - Newbie 4 02-02-2014 03:06 PM
HPlip woes on --current ; Sharing printer gets broken if the hplip gui is launched Old_Fogie Slackware 2 10-28-2010 10:23 AM
[SOLVED] libtool error during compilation of hplip sycamorex Slackware 1 06-10-2010 04:26 PM
hplip installation error radar.dude Linux - Software 3 10-06-2007 02:32 PM
make: [all-recursive] Error 1 HPLIP kevinens Linux - Software 1 05-11-2006 01:39 PM


All times are GMT -5. The time now is 11:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration