LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 06-18-2008, 01:23 AM   #1
brianmcgee
Member
 
Registered: Jun 2007
Location: Munich, Germany
Distribution: RHEL, CentOS, Fedora, SLES (...)
Posts: 399

Rep: Reputation: 38
Prohibit window focus stealing in KDE


During KDE start lots of programs are loading but usually I begin to work in the konsole rightaway. However as it starts I need to enter commands to start applications, enter passwords for KDE Wallet and so on.

Other programs that start up steal the focus of the window I currently work with. That is extremely annoying to me as I have to enter passwords multiple times because I don't know where I was interrupted by typing it.

Does anyone know how to disable focus stealing in KDE at all?
 
Old 06-18-2008, 04:17 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,622

Rep: Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527
The easy way, like I prefer it : "Start with an empty session" :
'kcontrol' > KDE Components > Session Manager >> "Start with an empty session"
and take care that 'HOME//.kde/Autostart' is empty.

Or if you want to have things not used currently to start, change focus :
'kcontrol' > Desktop > Window-Specific Settings >> "..Disable focus stealing.."
> > "New" or "Modify" ...

Rgds
 
Old 06-19-2008, 01:59 AM   #3
brianmcgee
Member
 
Registered: Jun 2007
Location: Munich, Germany
Distribution: RHEL, CentOS, Fedora, SLES (...)
Posts: 399

Original Poster
Rep: Reputation: 38
I tried to set rules here and I also set "Disable Focus Stealing" to extreme. According the manual this should disable focus stealing at all and the user must select windows manually. However this seems to have no effect. kwallet pops up, did not get the focus but the application (for example konsole) I used before loses the focus and when I was typing at the moment the new window popped up, some typing gets lost. Same happens when you start an application that takes quite some time to load and you want to work in the background with another app. As soon as the first application is loaded, it is put to front. And don't to speak of the annoying progress bar windows of kontact when it fetches mails every now and then. I don't want to get bugged by this. But I don't find any entry in KDE how to prevent this.

I liked the olden days where there was only a shell...
 
Old 06-20-2008, 10:24 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,622

Rep: Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527
"I liked the olden days where there was only a shell..."

So why in the first place have anything to start at all ???
Then "Start with an empty session" and no "Autostart" would
be like "the shell days"

Rgds
 
Old 06-21-2008, 06:45 AM   #5
brianmcgee
Member
 
Registered: Jun 2007
Location: Munich, Germany
Distribution: RHEL, CentOS, Fedora, SLES (...)
Posts: 399

Original Poster
Rep: Reputation: 38
If I want to use shell only, I simply run my machine in runlevel 3. However one has to run corporate software, want to browse the web in a fancy way, want to read pdfs and so on. So usually everyone has multiple applications open when working with the pc. Thats the reason why there are such things as multitasking.
 
Old 06-22-2008, 01:47 AM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,622

Rep: Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527
I have multible applications open most of the time too, and
so using 6 desktops in KDE. It will sometimes happen that a
pop up message from e.g desktop 4 will appear on my workplace
at desktop 2. But that is more dependent of the running
application itself and not the window manager.
There could be ways in the applications to avoid it.

Rgds
 
Old 07-27-2008, 11:25 PM   #7
bkorb
GNU Contributor
 
Registered: Sep 2006
Posts: 59

Rep: Reputation: 16
Vote for this bug:
http://bugs.kde.org/show_bug.cgi?id=80897#c4
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse Over Focus Stealing HOW TO TURN OFF Brad.Scalio@noaa.gov Linux - Desktop 3 07-16-2007 02:28 PM
Focus Stealing Across Desktops - Firefox/Thunderbird vtel57 Linux - General 0 05-18-2007 02:06 PM
Focus Stealing Across Desktops - Firefox/T-bird vtel57 Linux - Desktop 0 05-15-2007 12:24 PM
How to stop gaim stealing focus? chrism01 Linux - Software 4 05-26-2006 12:40 AM
Gnome stealing focus, only able to navigate with tab and enter stalefries Ubuntu 2 07-05-2005 02:50 PM


All times are GMT -5. The time now is 05:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration