LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Prohibit window focus stealing in KDE (http://www.linuxquestions.org/questions/linux-desktop-74/prohibit-window-focus-stealing-in-kde-650051/)

brianmcgee 06-18-2008 01:23 AM

Prohibit window focus stealing in KDE
 
During KDE start lots of programs are loading but usually I begin to work in the konsole rightaway. However as it starts I need to enter commands to start applications, enter passwords for KDE Wallet and so on.

Other programs that start up steal the focus of the window I currently work with. That is extremely annoying to me as I have to enter passwords multiple times because I don't know where I was interrupted by typing it.

Does anyone know how to disable focus stealing in KDE at all?

knudfl 06-18-2008 04:17 AM

The easy way, like I prefer it : "Start with an empty session" :
'kcontrol' > KDE Components > Session Manager >> "Start with an empty session"
and take care that 'HOME//.kde/Autostart' is empty.

Or if you want to have things not used currently to start, change focus :
'kcontrol' > Desktop > Window-Specific Settings >> "..Disable focus stealing.."
> > "New" or "Modify" ...

Rgds

brianmcgee 06-19-2008 01:59 AM

I tried to set rules here and I also set "Disable Focus Stealing" to extreme. According the manual this should disable focus stealing at all and the user must select windows manually. However this seems to have no effect. kwallet pops up, did not get the focus but the application (for example konsole) I used before loses the focus and when I was typing at the moment the new window popped up, some typing gets lost. Same happens when you start an application that takes quite some time to load and you want to work in the background with another app. As soon as the first application is loaded, it is put to front. And don't to speak of the annoying progress bar windows of kontact when it fetches mails every now and then. I don't want to get bugged by this. But I don't find any entry in KDE how to prevent this.

I liked the olden days where there was only a shell...

knudfl 06-20-2008 10:24 AM

"I liked the olden days where there was only a shell..."

So why in the first place have anything to start at all ???
Then "Start with an empty session" and no "Autostart" would
be like "the shell days"

Rgds

brianmcgee 06-21-2008 06:45 AM

If I want to use shell only, I simply run my machine in runlevel 3. However one has to run corporate software, want to browse the web in a fancy way, want to read pdfs and so on. So usually everyone has multiple applications open when working with the pc. Thats the reason why there are such things as multitasking.

knudfl 06-22-2008 01:47 AM

I have multible applications open most of the time too, and
so using 6 desktops in KDE. It will sometimes happen that a
pop up message from e.g desktop 4 will appear on my workplace
at desktop 2. But that is more dependent of the running
application itself and not the window manager.
There could be ways in the applications to avoid it.

Rgds

bkorb 07-27-2008 11:25 PM

Vote for this bug:
http://bugs.kde.org/show_bug.cgi?id=80897#c4


All times are GMT -5. The time now is 07:18 PM.