LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 07-22-2007, 04:09 PM   #1
TommyB
LQ Newbie
 
Registered: May 2004
Location: Austria
Distribution: Mandriva 2010.1
Posts: 18

Rep: Reputation: 1
Problems installing NVIDIA driver


Hi,
I have just upgraded from Mandriva 2006 to 2007.1 and wanted to install the NVIDIA drivers with the packages
dkms-nvidia97xx-100.14.11-1plf2007.1
nvidia97xx-100.14.11-1plf2007.1

In xorg.conf I set Driver "nvidia".

When doing startx the Xorg.0.log has the following lines:
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "AddARGBGLXVisuals"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "ramdac"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found


Dmesg gives the following output:
ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 17
NVRM: request_mem_region failed for 0M @ 0xf7f3a100. This can
NVRM: occur when a driver such as rivatv is loaded and claims
NVRM: ownership of the device's registers.
nvidia: probe of 0000:01:00.0 failed with error -1
NVRM: The NVIDIA probe routine failed for 1 device(s).
NVRM: None of the NVIDIA graphics adapters were initialized!
ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 17
NVRM: request_mem_region failed for 0M @ 0xf7f3a100. This can
NVRM: occur when a driver such as rivatv is loaded and claims
NVRM: ownership of the device's registers.
nvidia: probe of 0000:01:00.0 failed with error -1
NVRM: The NVIDIA probe routine failed for 1 device(s).
NVRM: None of the NVIDIA graphics adapters were initialized!

I checked several forums but somehow I did not figure out how I can fix the problem.
Can anybody out there give me a hint?

Thanks
 
Old 07-22-2007, 07:10 PM   #2
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 4
Posts: 4,297

Rep: Reputation: 205Reputation: 205Reputation: 205
You would get better joy downloading and installing the driver from the Nvidia website. Just make sure you have the kernel-source package for your current running kernel (type uname -a in a konsole to see what your kernel version is) already added to your system, the driver will take care of the rest. If you need instructions on how to install the driver, let me know and I will post the info here.
 
Old 07-27-2007, 06:22 PM   #3
TommyB
LQ Newbie
 
Registered: May 2004
Location: Austria
Distribution: Mandriva 2010.1
Posts: 18

Original Poster
Rep: Reputation: 1
Cool

I succeeded with the drivers from the NVIDIA web site after I installed the whole kernel source.

Thanks a lot
Thomas
 
Old 07-27-2007, 06:30 PM   #4
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 4
Posts: 4,297

Rep: Reputation: 205Reputation: 205Reputation: 205
Quote:
Originally Posted by TommyB
I succeeded with the drivers from the NVIDIA web site after I installed the whole kernel source.

Thanks a lot
Thomas
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems installing NVIDIA driver kenito Linux - Hardware 0 12-17-2004 07:59 AM
problems installing NVIDIA graphics driver and SMP littleneutral1 Debian 0 11-24-2004 12:24 PM
problems installing nvidia driver on 9.2 RuFI0 Mandriva 2 07-25-2004 10:48 AM
Problems installing Nvidia driver buckwheat12 Mandriva 13 02-18-2004 11:35 AM
Problems after installing nvidia driver GhostInDarkness *BSD 17 12-03-2003 05:12 PM


All times are GMT -5. The time now is 02:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration