LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 09-08-2010, 08:47 AM   #1
michaelinux
Member
 
Registered: Apr 2009
Location: El Salvador
Distribution: Slackware -current
Posts: 166

Rep: Reputation: 17
problems installing kde3 "trinity" on lucid lynx?


i've already asked this in other forum but i haven't got any answers

i tried to install kde3 trinity on lucid lynx, and everything went perfect except this error:
E: /var/cache/apt/archives/kdelibs-data-kde3_4%3a3.5.12-0ubuntu6+r1152788_all.deb: trying to overwrite '/etc/kde3/ksslcalist', which is also in package kdelibs-data 4


also in synaptic i have these broken packages:
kdelibs4c2a-kde3 and k3b-kde3
I've tried to re-install them and i get the same error above.
what can i do ??

also i've noticed that there are some broken links on my applications and some loading animations from kde appear in gnome, what can i do to make the other DE not to mess up with the other one?
like in slackware, it has multiple DEs and all of them work perfectly together without touching each other files, which is one of the many things a love about it.

please help!
 
Old 09-10-2010, 01:58 AM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948
Well, first of all, Trinity is a relatively new and complex project, so there's bound to be a few bugs in the system. Your best response is to report the conflict directly to them.

The first error message you're getting is a conflict between two packages trying to install the same file. A quick-and-dirty solution that I've used before is to simply move/remove the existing version of the conflicting file (in this case /etc/kde3/ksslcalist), so that the second package can go ahead and complete its mission. There are also ways to force apt-get to overwrite. This can be risky though; unless the files in both packages are binary equals, there's a chance that whichever version you end up using may break something or other. In this case, however, ksslcalist appears to simply hold the kde ssl security certificates, so it probably wouldn't have too much of an effect.

Do you perhaps have some kde stuff already installed from your regular distribution? If so, I'd guess that there are some conflicts between the two versions. k3b is only a single application, but kdelibs is at the very heart of the desktop, so my impression is that it's trying to overwrite an existing kde4 version of the core library with its own kde3 one.

It seems to me that your best bet would be to simply uninstall everything related to kde already on your system, then reinstall from scratch. I think it would also be better to reinstall it a few packages at a time, rather than through one single meta-package. Install the base system first, then you can add other packages as you need them.


By the way, not getting an answer with one post isn't really a good justification for creating a duplicate thread. Lack of response usually just means that nobody who read it knows how to answer it, possibly because you didn't define the question clearly enough or give enough detail for them to understand the problem.

The best thing to do in such situations is to post a follow-up entry and add whatever new or clarifying information you can to the original. And if you think you've posted to the wrong forum, use the report button to ask the moderators to move your original thread, rather than creating a new one. We prefer to keep all responses in one place, after all.

For reference, here's a link back to the first thread.
http://www.linuxquestions.org/questi...8/#post4090849

Last edited by David the H.; 09-10-2010 at 02:07 AM. Reason: clarified some wording
 
  


Reply

Tags
error, install, kde, lucid, lynx, trinity, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problems installing kde3 "trinity" on lucid lynx? michaelinux Linux - Software 2 09-13-2010 10:20 PM
LXer: How to Install VLC 1.1.1 in Ubuntu 10.04 "Lucid Lynx" LXer Syndicated Linux News 1 07-24-2010 12:26 PM
LXer: Install or Upgrade to KDE SC 4.5 RC 2 in Ubuntu 10.04 "Lucid Lynx" LXer Syndicated Linux News 0 07-09-2010 12:00 AM
LXer: Install Google Earth in Ubuntu 10.04 "Lucid Lynx" LXer Syndicated Linux News 0 06-11-2010 01:30 PM
LXer: Is the Release of Ubuntu 10.04 LTS "Lucid Lynx" Delayed? LXer Syndicated Linux News 0 04-29-2010 09:30 PM


All times are GMT -5. The time now is 03:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration