LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 03-12-2013, 01:49 PM   #1
Tony_photoplus
Member
 
Registered: Aug 2008
Location: Engand
Distribution: None at present
Posts: 55

Rep: Reputation: 15
Problem with dual boot - lost windows


I have had to reinstall Linux mint several times using this method http://forums.linuxmint.com/viewtopic.php?f=42&t=122276.
After I had gone into windows and deleted the partitions I made, I went back into LM and rebuilt them using the same method. I had the first ext4 as / @ 30gb. I then used 28gb as home. Then the remaining few GB's as swap (Using total 67GB). But then I reboot the comp and I can see that Linux works fine, then I reboot to see if I can gain access to Window7 and nothing. I tried both sda1 and sda2 to access Windows but can't. Is there another way I can ensure Windows works on dual boot. I can't allow LM to be alongside Windows as there is not enough space on the C drive. I did try the same method with Ubuntu and it did the same. As I have stated, I have tried to reinstall LM several times and it is always the same outcome. Any ideas on how to resolve this?
 
Old 03-12-2013, 07:48 PM   #2
yancek
Senior Member
 
Registered: Apr 2008
Distribution: PCLinux, Ubuntu, Slackware
Posts: 4,828

Rep: Reputation: 748Reputation: 748Reputation: 748Reputation: 748Reputation: 748Reputation: 748Reputation: 748
Quote:
I can't allow LM to be alongside Windows as there is not enough space on the C drive.
Do you already have windows 7 installed? If you created these partitions for Mint, where is windows? Can you see the windows files from Mint? If you can boot Mint, check the /boot/grub/grub.cfg file to see if there is an entry for windows. If not, run: sudo update-grub in a terminal.

You should probably post drive/partition information as the information you have posted isn't enough for anyone to do more than guess. Open a terminal in Mint and enter this command: sudo fdisk -l (Lower case Letter L in the command) and post the output.
 
Old 03-13-2013, 03:19 AM   #3
Tony_photoplus
Member
 
Registered: Aug 2008
Location: Engand
Distribution: None at present
Posts: 55

Original Poster
Rep: Reputation: 15
Quote:
Do you already have windows 7 installed?
Thank you for replying. I definitely have Win7, although I can't see why you would question that? But hey I am grateful for assistance. The LM is no longer installed so can't post anything now. I have 3 drives, of which one is partitioned and that is 1 terabyte. That is split in half, of which one is C drive, on the other is backup of all my photographs (keen amateur photographer, of which I would never use Linux to work with my photography or my games (but maybe one day I can)). When the LM was running it showed on the boot all the Linux boots and two windows, sda1 and sda2. Neither of these windows would boot up so I kept reloading the LM with no luck. Wasn't sure what to do so deleted LM after I regained my Windows back.
 
Old 03-13-2013, 04:36 AM   #4
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
If you have installed Linux mint in a correct way than you will find the option : Windows 7 ( loader on dev sda1) on you're Grub menu .
By default windows is on sda1
Shotwell is the programm I use for showing photos in linux

Last edited by ronlau9; 03-13-2013 at 04:39 AM.
 
Old 03-13-2013, 04:39 AM   #5
Tony_photoplus
Member
 
Registered: Aug 2008
Location: Engand
Distribution: None at present
Posts: 55

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by ronlau9 View Post
If you have installed Linux mint in a correct way than you will find the option : Windows 7 ( loader on dev sda1) on you're Grub menu .
Sda1 is place where windows standard is .
I was aware that the Windows was sda1 but the problem is it never worked. I couldn't find out the reason why. Even though I reloaded LM several times each time Windows failed to load, it went straight back to the grub menu. And that showed the Linux Mint and sda1 and sda2 Win7
 
Old 03-13-2013, 04:50 AM   #6
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
Than you're install goes wrong win7 could not be on sda2 ,
Windows will not run from sda2 .
May be it is a good idea to download gparted .
It is a live cd to find out how you're drive is really partitioned and post here .

Last edited by ronlau9; 03-13-2013 at 04:53 AM.
 
Old 03-13-2013, 10:18 AM   #7
yancek
Senior Member
 
Registered: Apr 2008
Distribution: PCLinux, Ubuntu, Slackware
Posts: 4,828

Rep: Reputation: 748Reputation: 748Reputation: 748Reputation: 748Reputation: 748Reputation: 748Reputation: 748
Just posting "neither of these windows would boot up" is to vague for anyone to assist. If you recalled specifics such as warning/error messages it might help someone to help you. When you had Mint installed, you could have looked at the /boot/grub/grub.cfg file to see what the entry was for windows. Might have been wrong for whatever reason. From Mint, running sudo os-prober and then sudo update-grub should have obtained correct entries.
 
Old 03-13-2013, 11:30 AM   #8
Tony_photoplus
Member
 
Registered: Aug 2008
Location: Engand
Distribution: None at present
Posts: 55

Original Poster
Rep: Reputation: 15
Okay, as I see it the only way is to retry and install LM again and assess it from there. WHen I have reinstalled LM I can then repost all the details. But I can't be without Windows for too long. THank you for all of your replies I am very grateful
 
Old 03-13-2013, 12:11 PM   #9
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,344

Rep: Reputation: 184Reputation: 184
windows 7 usually has a separate boot partition that you would point grub to.
 
Old 03-13-2013, 03:04 PM   #10
Tony_photoplus
Member
 
Registered: Aug 2008
Location: Engand
Distribution: None at present
Posts: 55

Original Poster
Rep: Reputation: 15
When I had established all my partitions in my installation I then chose Win7 sda1 for my boot. That is why I can't understand how it got to never work. The vagaries of computer technology baffle me
 
Old 03-13-2013, 03:16 PM   #11
ronlau9
Senior Member
 
Registered: Dec 2007
Location: In front of my LINUX OR MAC BOX
Distribution: Mandriva 2009 X86_64 suse 11.3 X86_64 Centos X86_64 Debian X86_64 Linux MInt 86_64 OS X
Posts: 2,369

Rep: Reputation: Disabled
Quote:
Originally Posted by Tony_photoplus View Post
When I had established all my partitions in my installation I then chose Win7 sda1 for my boot. That is why I can't understand how it got to never work. The vagaries of computer technology baffle me
Most linux distro has the option installing alongside other OS , a handy option if you are not sure how to install linux so that the other OS 'S stay untouched .
What do you mean by :
then I chose windows 7 sda1 for boot ?
If you mean GRUB than it should be sda
 
Old 03-13-2013, 04:15 PM   #12
yancek
Senior Member
 
Registered: Apr 2008
Distribution: PCLinux, Ubuntu, Slackware
Posts: 4,828

Rep: Reputation: 748Reputation: 748Reputation: 748Reputation: 748Reputation: 748Reputation: 748Reputation: 748
When you are creating your partitions in Mint, you should see in the lower left of that window "Device for bootloader installation". You can click the down arrow on the tab just below it to show options. It usually default to /dev/sda. That would install the Mint Grub bootloader to the master boot record of that hard drive. That would also overwrite the windows boot code in the mbr. Toward the end of the Mint installation, if you watch the progress bar at the bottom while the installation is finishing, you should see info on grub being installed and grub-update being run. This is where other operating sytems like windows are detected and entries are created in the grub boot menu.

Quote:
When I had established all my partitions in my installation I then chose Win7 sda1 for my boot
As indicated above, it should be sda. You should not select to install or do anything with sda1 if it has your windows boot or system files on it.

You would not need to re-install to get the information on partitions or files, you could just boot the Mint CD/DVD to do that. Use the fdisk command I suggested in my post above. Just guessing from the information you posted, you might have overwritten windows boot files??
 
Old 03-13-2013, 05:55 PM   #13
Tony_photoplus
Member
 
Registered: Aug 2008
Location: Engand
Distribution: None at present
Posts: 55

Original Poster
Rep: Reputation: 15
Ah that is something I hadn't been aware of. So don't choose anything with Win7 just sda? If that is the case then my problems are solved. I have completely destroyed the Mint so it isn't there. Will re-install. At present my Win boot as taken from a software is
Default: Windows 7 Ultimate
Name: Windows 7 Ultimate
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
 
Old 03-14-2013, 04:55 AM   #14
Tony_photoplus
Member
 
Registered: Aug 2008
Location: Engand
Distribution: None at present
Posts: 55

Original Poster
Rep: Reputation: 15
Thank you all for your assistance. I have managed to deal with my morphined stupidity!!!! I tell you, taking 300mg of morphine a day screws your brains up I can tell you. I was allocating sda1 Win7 ias the boot when I should have allocated /dev/sda Hitachi. Now up and running. Although I expect I shall be running into more trouble soon. Thank you again for your assistance

Tony
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
lost access to my windows7 drive(Dual-boot windows 7&Ubuntu) - Bootmgr is compressed fkayal Linux - Newbie 3 09-04-2012 08:55 AM
grub dual boot lost windows option BACTRATE Ubuntu 4 10-27-2008 09:39 AM
Dual Boot Problem - WinXP partition lost space? brianr747 Suse/Novell 1 09-26-2006 05:06 AM
Dual Boot-Lost Windows impeteperry Ubuntu 12 10-30-2005 08:41 AM
Reinstalled Windows 98 lost linux dual boot llefty Linux - Newbie 0 08-01-2003 12:23 AM


All times are GMT -5. The time now is 05:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration