LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Problem with dual boot - lost windows (http://www.linuxquestions.org/questions/linux-desktop-74/problem-with-dual-boot-lost-windows-4175453812/)

Tony_photoplus 03-12-2013 02:49 PM

Problem with dual boot - lost windows
 
I have had to reinstall Linux mint several times using this method http://forums.linuxmint.com/viewtopic.php?f=42&t=122276.
After I had gone into windows and deleted the partitions I made, I went back into LM and rebuilt them using the same method. I had the first ext4 as / @ 30gb. I then used 28gb as home. Then the remaining few GB's as swap (Using total 67GB). But then I reboot the comp and I can see that Linux works fine, then I reboot to see if I can gain access to Window7 and nothing. I tried both sda1 and sda2 to access Windows but can't. Is there another way I can ensure Windows works on dual boot. I can't allow LM to be alongside Windows as there is not enough space on the C drive. I did try the same method with Ubuntu and it did the same. As I have stated, I have tried to reinstall LM several times and it is always the same outcome. Any ideas on how to resolve this?

yancek 03-12-2013 08:48 PM

Quote:

I can't allow LM to be alongside Windows as there is not enough space on the C drive.
Do you already have windows 7 installed? If you created these partitions for Mint, where is windows? Can you see the windows files from Mint? If you can boot Mint, check the /boot/grub/grub.cfg file to see if there is an entry for windows. If not, run: sudo update-grub in a terminal.

You should probably post drive/partition information as the information you have posted isn't enough for anyone to do more than guess. Open a terminal in Mint and enter this command: sudo fdisk -l (Lower case Letter L in the command) and post the output.

Tony_photoplus 03-13-2013 04:19 AM

Quote:

Do you already have windows 7 installed?
Thank you for replying. I definitely have Win7, although I can't see why you would question that? But hey I am grateful for assistance. The LM is no longer installed so can't post anything now. I have 3 drives, of which one is partitioned and that is 1 terabyte. That is split in half, of which one is C drive, on the other is backup of all my photographs (keen amateur photographer, of which I would never use Linux to work with my photography or my games (but maybe one day I can)). When the LM was running it showed on the boot all the Linux boots and two windows, sda1 and sda2. Neither of these windows would boot up so I kept reloading the LM with no luck. Wasn't sure what to do so deleted LM after I regained my Windows back.

ronlau9 03-13-2013 05:36 AM

If you have installed Linux mint in a correct way than you will find the option : Windows 7 ( loader on dev sda1) on you're Grub menu .
By default windows is on sda1
Shotwell is the programm I use for showing photos in linux

Tony_photoplus 03-13-2013 05:39 AM

Quote:

Originally Posted by ronlau9 (Post 4910583)
If you have installed Linux mint in a correct way than you will find the option : Windows 7 ( loader on dev sda1) on you're Grub menu .
Sda1 is place where windows standard is .

I was aware that the Windows was sda1 but the problem is it never worked. I couldn't find out the reason why. Even though I reloaded LM several times each time Windows failed to load, it went straight back to the grub menu. And that showed the Linux Mint and sda1 and sda2 Win7

ronlau9 03-13-2013 05:50 AM

Than you're install goes wrong win7 could not be on sda2 ,
Windows will not run from sda2 .
May be it is a good idea to download gparted .
It is a live cd to find out how you're drive is really partitioned and post here .

yancek 03-13-2013 11:18 AM

Just posting "neither of these windows would boot up" is to vague for anyone to assist. If you recalled specifics such as warning/error messages it might help someone to help you. When you had Mint installed, you could have looked at the /boot/grub/grub.cfg file to see what the entry was for windows. Might have been wrong for whatever reason. From Mint, running sudo os-prober and then sudo update-grub should have obtained correct entries.

Tony_photoplus 03-13-2013 12:30 PM

Okay, as I see it the only way is to retry and install LM again and assess it from there. WHen I have reinstalled LM I can then repost all the details. But I can't be without Windows for too long. THank you for all of your replies I am very grateful

colorpurple21859 03-13-2013 01:11 PM

windows 7 usually has a separate boot partition that you would point grub to.

Tony_photoplus 03-13-2013 04:04 PM

When I had established all my partitions in my installation I then chose Win7 sda1 for my boot. That is why I can't understand how it got to never work. The vagaries of computer technology baffle me

ronlau9 03-13-2013 04:16 PM

Quote:

Originally Posted by Tony_photoplus (Post 4910972)
When I had established all my partitions in my installation I then chose Win7 sda1 for my boot. That is why I can't understand how it got to never work. The vagaries of computer technology baffle me

Most linux distro has the option installing alongside other OS , a handy option if you are not sure how to install linux so that the other OS 'S stay untouched .
What do you mean by :
then I chose windows 7 sda1 for boot ?
If you mean GRUB than it should be sda

yancek 03-13-2013 05:15 PM

When you are creating your partitions in Mint, you should see in the lower left of that window "Device for bootloader installation". You can click the down arrow on the tab just below it to show options. It usually default to /dev/sda. That would install the Mint Grub bootloader to the master boot record of that hard drive. That would also overwrite the windows boot code in the mbr. Toward the end of the Mint installation, if you watch the progress bar at the bottom while the installation is finishing, you should see info on grub being installed and grub-update being run. This is where other operating sytems like windows are detected and entries are created in the grub boot menu.

Quote:

When I had established all my partitions in my installation I then chose Win7 sda1 for my boot
As indicated above, it should be sda. You should not select to install or do anything with sda1 if it has your windows boot or system files on it.

You would not need to re-install to get the information on partitions or files, you could just boot the Mint CD/DVD to do that. Use the fdisk command I suggested in my post above. Just guessing from the information you posted, you might have overwritten windows boot files??

Tony_photoplus 03-13-2013 06:55 PM

Ah that is something I hadn't been aware of. So don't choose anything with Win7 just sda? If that is the case then my problems are solved. I have completely destroyed the Mint so it isn't there. Will re-install. At present my Win boot as taken from a software is
Default: Windows 7 Ultimate
Name: Windows 7 Ultimate
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Tony_photoplus 03-14-2013 05:55 AM

Thank you all for your assistance. I have managed to deal with my morphined stupidity!!!! I tell you, taking 300mg of morphine a day screws your brains up I can tell you. I was allocating sda1 Win7 ias the boot when I should have allocated /dev/sda Hitachi. Now up and running. Although I expect I shall be running into more trouble soon. Thank you again for your assistance

Tony


All times are GMT -5. The time now is 12:33 PM.