Go Job Hunting at the LQ Job Marketplace
Go Back > Forums > Linux Forums > Linux - Desktop
User Name
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.


  Search this Thread
Old 10-28-2006, 03:51 PM   #1
LQ Newbie
Registered: Aug 2004
Posts: 15

Rep: Reputation: 0
Problem updating kdebase

I am using Fedora Core 5 under the x86_64 architecture. I am trying to update the kdebase that originally came from the install.
However, when I try to use yum to update kdebase, I get hundreds of error messages like these after the transaction test:

file /usr/share/templates/linkFloppy.desktop from install of kdebase-3.5.4-0.5.fc5 conflicts with file from package kdebase-3.5.1-5
file /usr/share/templates/.source/DVDROM-Device.desktop from install of kdebase-3.5.4-0.5.fc5 conflicts with file from package kdebase-3.5.1-5
file /usr/share/wallpapers/KDE34.png.desktop from install of kdebase-3.5.4-0.5
.fc5 conflicts with file from package kdebase-3.5.1-5

How can I resolve the conflicts?
Old 10-28-2006, 04:45 PM   #2
LQ Addict
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,846

Rep: Reputation: 342Reputation: 342Reputation: 342Reputation: 342
If I'm not seriously mistaken, you are trying to update 64 bit apps from a 32 bit repository. Search for a 64 bit repo and direct yum to that instead.
Old 10-30-2006, 01:58 AM   #3
LQ Newbie
Registered: Aug 2004
Posts: 15

Original Poster
Rep: Reputation: 0
Well, accordiing to the output from YUM, it seems that yum is using the 64-bit version of kdebase.

[root@localhost yum.repos.d]# yum update kdebase.x86_64
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
livna [1/6]
flash [2/6]
jpackage-fedora [3/6]
core [4/6]
core 100% |=========================| 1.1 kB 00:00
extras [5/6]
extras 100% |=========================| 1.1 kB 00:00
updates [6/6]
updates 100% |=========================| 1.2 kB 00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 1.6 MB 00:26
extras : ################################################## 5368/5368
Added 366 new packages, deleted 395 old in 10.63 seconds
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kdebase.x86_64 6:3.5.4-0.5.fc5 set to be updated
--> Running transaction check

Dependencies Resolved

Package Arch Version Repository Size
kdebase x86_64 6:3.5.4-0.5.fc5 updates 29 M

Transaction Summary
Install 0 Package(s)
Update 1 Package(s)
Remove 0 Package(s)
Total download size: 29 M


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with X after installing kdebase-dev, using kanotix, and xfree86 4.x Kronoz Linux - Software 0 12-16-2005 03:23 AM
kdebase-3.3.0 still won't build. craigs1987 Linux - Software 1 10-02-2004 08:26 AM
Why won't kdebase-3.3.0 build? craigs1987 Linux - Software 1 10-01-2004 06:07 PM
Slackware and kdebase mikz Slackware - Installation 1 09-24-2004 11:46 PM
Apt and kdebase slewis1972 Linux - General 0 07-05-2003 12:13 PM

All times are GMT -5. The time now is 04:31 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration