-   Linux - Desktop (
-   -   Problem installing pygtk-2.9.0 (

tomhanks 08-27-2006 10:32 AM

Problem installing pygtk-2.9.0
I want to install this package on my fedora core 5 system.
It is a tar package. I untarred it.
Then now when I run the ./configure script, I get the following error.

checking pkg-config is at least version 0.9.0... yes
checking for PYGOBJECT... configure: error: Package requirements (pygobject-2.0 >= 2.10.0) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the PYGOBJECT_CFLAGS and PYGOBJECT_LIBS environment variables
to avoid the need to call pkg-config. See the pkg-config man page for
more details.

I had configured the pygobject from the source and its version was 2.10.0.
I'm new to linux and don't know how to set these variables.
Plz help.

ciotog 09-05-2006 12:06 AM

To set environment variables you use the "export" command - so for example since you installed pygobject from source it was likely installed in /usr/local, but PKG_CONFIG_PATH is only finding the ones in /usr. To set it properly, run the following in a terminal right before ./configure for pygtk:

export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/local/lib/pkgconfig

reddazz 09-05-2006 03:58 AM

How about just doing "yum install pygtk2".

All times are GMT -5. The time now is 06:59 AM.