LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 03-28-2013, 09:05 AM   #1
ines8989
Member
 
Registered: Mar 2013
Posts: 62

Rep: Reputation: Disabled
Problem in installing ns2.35 in ubuntu ( version linux mint ) in oracle virtualmachin


When im installing ns2.35 in my virtual machine (oracle virtual machine) with linux mint . I have this probleme
Can you help me please:
============================================================
* Build OTcl-1.14
============================================================

No .configure file found in current directory

Continuing with default options...

checking build system type... i686-pc-linux-gnu

checking host system type... i686-pc-linux-gnu

checking target system type... i686-pc-linux-gnu

checking for gcc... gcc

checking for C compiler default output file name... a.out

checking whether the C compiler works... yes

checking whether we are cross compiling... no

checking for suffix of executables...

checking for suffix of object files... o

checking whether we are using the GNU C compiler... yes

checking whether gcc accepts -g... yes

checking for gcc option to accept ISO C89... none needed

checking for g++...
no
checking for c++... no

checking for gpp... no

checking for aCC... no

checking for CC... no

checking for cxx... no

checking for cc++... no

checking for cl.exe... no

checking for FCC... no

checking for KCC... no

checking for RCC... no

checking for xlC_r... no

checking for xlC... no

checking whether we are using the GNU C++ compiler... no

checking whether g++ accepts -g... no

checking how to run the C preprocessor... gcc -E

checking for grep that handles long lines and -e... /bin/grep

checking for egrep... /bin/grep -E
checking for ANSI C header files... yes

checking for sys/types.h... yes

checking for sys/stat.h... yes

checking for stdlib.h... yes

checking for string.h... yes

checking for memory.h... yes

checking for strings.h... yes

checking for inttypes.h... yes

checking for stdint.h... yes

checking for unistd.h... yes

checking for string.h... (cached) yes

checking for main in -lXbsd... no

checking for socket in -lsocket... no

checking for gethostbyname in -lnsl... yes

checking for dcgettext in -lintl... no

checking for getnodebyname in -ldnet_stub... no

checking that g++ can handle -O2... no

checking standard STL is available... no

checking for tcl.h... -I../include

checking for tclInt.h... -I../include

checking for libtcl8.5... -L../lib -ltcl8.5

checking for init.tcl... ../lib/tcl8.5

checking for http.tcl... ../lib/tcl8.5/http1.0

checking Tcl http.tcl library... yes

checking for tclsh8.5.10... no

checking for tclsh8.5... ../bin/tclsh8.5

checking for tk.h... -I../include

checking for libtk8.5... -L../lib -ltk8.5

checking for tk.tcl... ../lib/tk8.5

checking for X11 header files
can't find X includes

otcl-1.14 configuration failed! Exiting ...

Please check http://www.isi.edu/nsnam/ns/ns-problems.html
for common problems and bug fixes.

When i type : yum install libX11-devel
i have : the program 'yum'is currently not installed
 
Old 03-28-2013, 01:03 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,665

Rep: Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544
Welcome to LQ.

Ubuntu / Mint do not use yum to install packages. 'apt' is used.

Prerequisites for ns2, Ubuntu / Mint : $ sudo apt-get install \
g++ g++-4.4 autoconf automake make libtool patch libxmu-dev xgraph

The install command for ns-allinone-2.35 is :
export CC=gcc-4.4 CXX=g++-4.4 && ./install

-
 
Old 03-28-2013, 02:19 PM   #3
273
Senior Member
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 3,377

Rep: Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782
Is there a reason you are installing from a downloaded file rather than Linux mint's repository?
 
Old 03-29-2013, 05:15 AM   #4
ines8989
Member
 
Registered: Mar 2013
Posts: 62

Original Poster
Rep: Reputation: Disabled
Problem in installing ns2.35 in ubuntu (version linux mint) in oracle virtual machin

Great thanks for your replys. would tell you that it is not the first way that i install
ns2.35 in my machine it has been installed but i had a problem that had obliged me to reinstall it . when i write this command : export CC=gcc-4.4 CXX=g++-4.4 && ./install
i have this :
============================================================
* Build tcl8.5.10
============================================================
rm -f *.a *.o libtcl* core errs *~ \#* TAGS *.E a.out \
errors tclsh tcltest lib.exp Tcl
cd dltest ; make clean
make[1]: Entering directory `/home/iness/ns-allinone-2.35/tcl8.5.10/unix/dltest'
rm -f *.o lib.exp ../dltest.marker
rm -f *.so
make[1]: Leaving directory `/home/iness/ns-allinone-2.35/tcl8.5.10/unix/dltest'
rm -rf Makefile config.status config.cache config.log tclConfig.sh \
SCRPtcl.* prototype tclConfig.h *.plist Tcl.framework
cd dltest ; make distclean
make[1]: Entering directory `/home/iness/ns-allinone-2.35/tcl8.5.10/unix/dltest'
rm -f *.o lib.exp ../dltest.marker
rm -f *.so
rm -f Makefile
make[1]: Leaving directory `/home/iness/ns-allinone-2.35/tcl8.5.10/unix/dltest'
configure: WARNING: unrecognized options: --enable-gcc
checking whether to use symlinks for manpages... no
checking whether to compress the manpages... no
checking whether to add a package name suffix for the manpages... no
checking for gcc... gcc-4.4
checking whether the C compiler works... no
configure: error: in `/home/iness/ns-allinone-2.35/tcl8.5.10/unix':
configure: error: C compiler cannot create executables
See `config.log' for more details
tcl8.5.10 configuration failed! Exiting ...
Tcl is not part of the ns project. Please see www.Scriptics.com
to see if they have a fix for your platform.
THans a lot for your help i'am in a great trouble i 'am obliged to have ns2.35 for my master
 
Old 03-29-2013, 06:00 AM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,665

Rep: Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544
# 4 .

! This is important :
$ sudo apt-get update && sudo apt-get install g++ g++-4.4

And if the compiler isn't working after the above, please do :
$ sudo apt-get install --reinstall \
g++ g++-4.4 gcc-4.4 cpp-4.4 libgcc1 libc6-dev linux-libc-dev

Also : You will have to check if the compilers really are installed :
$ gcc-4.4 -v
$ g++-4.4 -v

-
 
Old 03-29-2013, 06:34 AM   #6
ines8989
Member
 
Registered: Mar 2013
Posts: 62

Original Poster
Rep: Reputation: Disabled
Problem in installing ns2.35 in ubuntu (version linux mint) in oracle virtual machin

Thanks for your help . when i write this command sudo apt-get update && sudo apt-get install g++ g++-4.4 in my terminal i have this result in the end :


Dépaquetage de g++-4.4 (à partir de .../g++-4.4_4.4.6-11ubuntu2_i386.deb) ...
Traitement des actions différées («*triggers*») pour «*man-db*»...
Paramétrage de gcc-4.4-base (4.4.6-11ubuntu2) ...
Paramétrage de cpp-4.4 (4.4.6-11ubuntu2) ...
Paramétrage de gcc-4.4 (4.4.6-11ubuntu2) ...
Paramétrage de libstdc++6-4.6-dev (4.6.1-9ubuntu3) ...
Paramétrage de g++-4.4 (4.4.6-11ubuntu2) ...
Paramétrage de libstdc++6-4.4-dev (4.4.6-11ubuntu2) ...
Paramétrage de g++-4.6 (4.6.1-9ubuntu3) ...
Paramétrage de g++ (4:4.6.1-2ubuntu5) ...
update-alternatives: utilisation de «*/usr/bin/g++*» pour fournir «*/usr/bin/c++*» (c++) en mode automatique.
than i write this commands and i have this :
iness@iness-VirtualBox ~/ns-allinone-2.35 $ gcc-4.4 -v
Using built-in specs.
Target: i686-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu/Linaro 4.4.6-11ubuntu2' --with-bugurl=file:///usr/share/doc/gcc-4.4/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.4 --enable-shared --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.4 --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-objc-gc --enable-targets=all --disable-werror --with-arch-32=i686 --with-tune=generic --enable-checking=release --build=i686-linux-gnu --host=i686-linux-gnu --target=i686-linux-gnu
Thread model: posix
gcc version 4.4.6 (Ubuntu/Linaro 4.4.6-11ubuntu2)
iness@iness-VirtualBox ~/ns-allinone-2.35 $ g++-4.4 -v
Using built-in specs.
Target: i686-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu/Linaro 4.4.6-11ubuntu2' --with-bugurl=file:///usr/share/doc/gcc-4.4/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.4 --enable-shared --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.4 --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-objc-gc --enable-targets=all --disable-werror --with-arch-32=i686 --with-tune=generic --enable-checking=release --build=i686-linux-gnu --host=i686-linux-gnu --target=i686-linux-gnu
Thread model: posix
gcc version 4.4.6 (Ubuntu/Linaro 4.4.6-11ubuntu2)
what i should do than for installing ns2.35 , please
 
Old 03-29-2013, 06:49 AM   #7
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,665

Rep: Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544
# 6 .

Looks OK.
! But also indicates that no gcc-4.4/g++-4.4 was installed before you did the above !

Suggest : cd ns-allinone-2.35 && export CC=gcc-4.4 CXX=g++-4.4 && ./install


-
 
Old 03-29-2013, 07:14 AM   #8
ines8989
Member
 
Registered: Mar 2013
Posts: 62

Original Poster
Rep: Reputation: Disabled
Problem in installing ns2.35 in ubuntu (version linux mint) in oracle virtual machin

when i write your command i unfortunately have this again:
============================================================
* Build OTcl-1.14
============================================================
No .configure file found in current directory
Continuing with default options...
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for gcc... gcc-4.4
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc-4.4 accepts -g... yes
checking for gcc-4.4 option to accept ISO C89... none needed
checking whether we are using the GNU C++ compiler... yes
checking whether g++-4.4 accepts -g... yes
checking how to run the C preprocessor... gcc-4.4 -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for string.h... (cached) yes
checking for main in -lXbsd... no
checking for socket in -lsocket... no
checking for gethostbyname in -lnsl... yes
checking for dcgettext in -lintl... no
checking for getnodebyname in -ldnet_stub... no
checking standard STL is available... no
checking for tcl.h... -I../include
checking for tclInt.h... -I../include
checking for libtcl8.5... -L../lib -ltcl8.5
checking for init.tcl... ../lib/tcl8.5
checking for http.tcl... ../lib/tcl8.5/http1.0
checking Tcl http.tcl library... yes
checking for tclsh8.5.10... no
checking for tclsh8.5... ../bin/tclsh8.5
checking for tk.h... -I../include
checking for libtk8.5... -L../lib -ltk8.5
checking for tk.tcl... ../lib/tk8.5
checking for X11 header files
can't find X includes
otcl-1.14 configuration failed! Exiting ...
Please check http://www.isi.edu/nsnam/ns/ns-problems.html
for common problems and bug fixes.
Please help me
 
Old 03-29-2013, 08:51 AM   #9
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,665

Rep: Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544
# 8 .
Quote:
can't find X includes
What to say ? It never happened before that otcl can't find X includes,
when tcl8 and tk8 do OK.

Are you sure that libxmu-dev is installed ?
Please try : sudo apt-get install --reinstall libxmu-dev

-
 
Old 03-29-2013, 01:27 PM   #10
ines8989
Member
 
Registered: Mar 2013
Posts: 62

Original Poster
Rep: Reputation: Disabled
Problem in installing ns2.35 in ubuntu (version linux mint) in oracle virtual machin

I have this result :
iness@iness-VirtualBox ~/ns-allinone-2.35 $ sudo apt-get install --reinstall libxmu-dev
[sudo] password for iness:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Les paquets supplémentaires suivants seront installés*:
libxmu-headers libxt-dev
Les NOUVEAUX paquets suivants seront installés*:
libxmu-dev libxmu-headers libxt-dev
0 mis à jour, 3 nouvellement installés, 0 à enlever et 480 non mis à jour.
Il est nécessaire de prendre 587 ko dans les archives.
Après cette opération, 1 925 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n]*? o
Réception de*: 1 http://archive.ubuntu.com/ubuntu/ oneiric/main libxt-dev i386 1:1.1.1-2 [472 kB]
Réception de*: 2 http://archive.ubuntu.com/ubuntu/ oneiric/main libxmu-headers all 2:1.1.0-2 [56,4 kB]
Réception de*: 3 http://archive.ubuntu.com/ubuntu/ oneiric/main libxmu-dev i386 2:1.1.0-2 [58,2 kB]
587 ko réceptionnés en 4s (129 ko/s)
Sélection du paquet libxt-dev précédemment désélectionné.
(Lecture de la base de données... 160176 fichiers et répertoires déjà installés.)
Dépaquetage de libxt-dev (à partir de .../libxt-dev_1%3a1.1.1-2_i386.deb) ...
Sélection du paquet libxmu-headers précédemment désélectionné.
Dépaquetage de libxmu-headers (à partir de .../libxmu-headers_2%3a1.1.0-2_all.deb) ...
Sélection du paquet libxmu-dev précédemment désélectionné.
Dépaquetage de libxmu-dev (à partir de .../libxmu-dev_2%3a1.1.0-2_i386.deb) ...
Traitement des actions différées («*triggers*») pour «*man-db*»...
Paramétrage de libxt-dev (1:1.1.1-2) ...
Paramétrage de libxmu-headers (2:1.1.0-2) ...
Paramétrage de libxmu-dev (2:1.1.0-2) ...
 
Old 03-29-2013, 01:54 PM   #11
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,665

Rep: Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544
# 10 .
Quote:
Les NOUVEAUX paquets suivants seront installés
Well, may be you should explain why you didn't install
all the packages, when you were told in post # 2 ?
I.e. g++ g++-4.4 libxmu-dev, etc.


-

Last edited by knudfl; 03-29-2013 at 02:01 PM.
 
Old 03-29-2013, 02:16 PM   #12
ines8989
Member
 
Registered: Mar 2013
Posts: 62

Original Poster
Rep: Reputation: Disabled
Problem in installing ns2.35 in ubuntu (version linux mint) in oracle virtual machin

Thanks for you .
In the first way to install ns2.35 i have done this steps:
tar -xzf ns-allinone-2.35.tar.1.gz

cd ns-allinone-2.35

./install

That's way i didn't have the source of the problem and i have suited you by your suggestions. At the last step given by you did i say that ns2.35 is installed please ?after installing sudo apt-get install --reinstall libxmu-dev . If not what schoud i do so ?
 
Old 03-30-2013, 05:15 AM   #13
ines8989
Member
 
Registered: Mar 2013
Posts: 62

Original Poster
Rep: Reputation: Disabled
Problem in installing ns2.35 in ubuntu (version linux mint) in oracle virtualmachin

What schoud i do after this please reply me .thanks for you
 
Old 04-08-2013, 10:52 AM   #14
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,665

Rep: Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544Reputation: 2544
# 12.

cd ns-allinone-2.35
./install
.... is wrong.

The right install command is still ( see #7 ) :
cd ns-allinone-2.35/ && export CC=gcc-4.4 CXX=g++-4.4 && ./install

-
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem in installing ns2.35 in ubuntu 11.10 ANIRBAN KANUNGOE Linux - Newbie 1 05-07-2012 01:02 AM
installing software on linux mint version 10 Upendra Pratap Singh Linux - Newbie 6 05-29-2011 12:50 PM
Problem installing ns2 on Ubuntu Aden09 Linux - Newbie 7 04-18-2011 06:01 PM
[SOLVED] problem in installing ns2.33 in ubuntu 8.10 neeraj.dwivedi Linux - Newbie 18 09-12-2009 08:00 AM
Problem Installing NS2 in Ubuntu 7.10 smetya Linux - Software 5 04-27-2008 08:27 AM


All times are GMT -5. The time now is 03:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration