LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 12-29-2011, 02:59 PM   #1
dh37
LQ Newbie
 
Registered: Dec 2011
Posts: 2

Rep: Reputation: Disabled
prevent windows from crossing workspaces


I'm using RHEL 5.7, which appears to be running GNOME 2.16.0.

I use a particular software package (it happens to be a graphical matlab app), and sometimes I want to run multiple instances of it. If I run them all in the same workspace, I get confused by all the clutter. So I want to run each instance in a different workspace.

Unfortunately, when running a job in this package, particular windows in the app recieve focus and then switch workspaces, which completely breaks my "put them in different workspaces" solution.

Is there a way to change some property so that the windows are not allowed to cross workspaces?
 
Old 01-02-2012, 11:08 AM   #2
SecretCode
Member
 
Registered: Apr 2011
Location: UK
Distribution: Kubuntu 11.10
Posts: 562

Rep: Reputation: 102Reputation: 102
The only way I can think of would be to run separate X sessions. That is probably overkill for what you need.

I suspect what is happening is that the app launches its executable, which determines that it already has a window open, and switches to it. Unfortunately you're at the mercy of how the developer has supported multiple windows (let alone multiple virtual desktops which some people seem not even to be aware of).

I doubt there is a system setting that could prevent this - if the app decides you want to display a window it has already opened, the most the OS can do is stop switching to that window. But you still wouldn't see your document / tab.
 
Old 01-12-2012, 02:32 PM   #3
dh37
LQ Newbie
 
Registered: Dec 2011
Posts: 2

Original Poster
Rep: Reputation: Disabled
I found a pretty good solution at http://bertrandbenoit.blogspot.com/2...ent-focus.html after a lot of searching:

Quote:
Under Gnome:
  • check 'focus new windows' configuration (it is defined to 'smart' by default):
    • gconftool-2 --get /apps/metacity/general/focus_new_windows
  • change 'focus new windows' from 'smart' to 'strict':
    • gconftool-2 --set /apps/metacity/general/focus_new_windows --type string strict
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
prevent windows notification balloon Berhanie General 2 01-05-2011 10:30 AM
Prevent windows from auto-raising? flourish Linux - General 2 01-22-2008 02:27 PM
Does Lilo prevent Windows from updating? snurfle Linux - General 2 07-15-2006 10:23 AM
crossing over KezzerDrix MEPIS 5 06-10-2005 05:50 PM
how to prevent 'start here' windows from starting ? netkepala Linux - Software 4 04-30-2003 12:08 AM


All times are GMT -5. The time now is 04:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration