LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 12-28-2011, 03:52 PM   #1
suicidal_orange
LQ Newbie
 
Registered: Jun 2004
Distribution: kubuntu 11.10
Posts: 11

Rep: Reputation: 0
Phonon one test works the other doesn't, no sound in apps.


I've recently installed kubuntu for a test of KDE (version 4.7.3) and it seems ok except for sound not working. In the phonon configuration thing on the "audio hardware setup" tab I can choose my sound card (it's a USB one, not the HDMI it defaults to) and the test works but if I press apply then go to the "device preference" tab the test there does not work and nor does sound in any program that uses phonon.

I've tried with and without ~/.asoundrc defaulting to the USB card but it makes no difference. Can anyone tell me what I'm missing? I've been a Linux user for years and this is my first time trying to use a gui config thing and it has me stumped

Thanks in advance!

Last edited by suicidal_orange; 12-30-2011 at 12:57 PM. Reason: Problem solved!
 
Old 12-29-2011, 05:17 PM   #2
eSelix
Senior Member
 
Registered: Oct 2009
Location: Wroclaw, Poland
Distribution: Arch, Kubuntu
Posts: 1,211

Rep: Reputation: 306Reputation: 306Reputation: 306Reputation: 306
On "device preference" you probably have some devices on the list, did you tested all?
 
Old 12-29-2011, 06:51 PM   #3
mecelec415
Member
 
Registered: Jan 2008
Location: Noble Park ,Victoria, Australia
Distribution: Mageia
Posts: 183
Blog Entries: 2

Rep: Reputation: 23
does kunbuntu use the alsa mixer and pulse audio?
If yes is your sound muted in the alsa mixer?
open the konsole and type alsamixer .
 
Old 12-30-2011, 08:31 AM   #4
suicidal_orange
LQ Newbie
 
Registered: Jun 2004
Distribution: kubuntu 11.10
Posts: 11

Original Poster
Rep: Reputation: 0
Thanks guys

There is only one option in the "device preferences" tab and that is "PulseAudio sound server". The card is unmuted and works fine from audacious which allows me to manually choose a device and phonon config plays the "front left/right" sounds so it's definitely not muted.

Surely PulseAudio should just lock on to the default soundcard, but adding a .asoundrc doesn't work... Was so much easier writing a huge .asoundrc and using dmix before they tried to make if friendly!

Last edited by suicidal_orange; 12-30-2011 at 08:48 AM.
 
Old 12-30-2011, 11:01 AM   #5
suicidal_orange
LQ Newbie
 
Registered: Jun 2004
Distribution: kubuntu 11.10
Posts: 11

Original Poster
Rep: Reputation: 0
Ok I'm sorted - for whatever reason I need to run

start-pulseaudio-kde

to get a list of devices instead of it just saying "PulseAudio sound server". Very intuitive and newbie friendly...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 11.3/i586 Sound Config test works, multimedia test + flash silent? brianpbarnes Linux - Software 3 12-19-2010 12:43 PM
Sound only works following speaker-test Jetgunner Linux - Hardware 1 10-31-2008 07:46 AM
Sound not working in GNOME but sound card test works saravkrish Linux - Hardware 3 02-08-2006 11:03 AM
sound works for desktop but not other apps dauphinfay Linux - Newbie 9 11-10-2004 12:45 AM
FC3T3 printing: test page works but can't print from apps Kropotkin Fedora 0 11-03-2004 05:46 AM


All times are GMT -5. The time now is 02:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration