LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
LinkBack Search this Thread
Old 10-15-2006, 12:01 AM   #1
CeremCem
LQ Newbie
 
Registered: Oct 2006
Posts: 3

Rep: Reputation: 0
auto mount problem, char. encoding, missing desktop icon (Solved: 1 of 3 problems)


Hello all,

First of all, I do not know where may I post the topic so if I am wrong, sorry...

I still have to use Windows, but mostly booting from Linux Ubuntu (Dapper Drake) and I sometimes format Windows or may be Linux (This is the sign that I am really newby); that's why I needed a backup partition that can be accessible both Linux and Windows. There only one partition type as I want is Fat32. I partitioned my disk as:

13GB NTFS (sda1)
+40GB Fat32 (sda5) (extended)
+1.3GB swap (sda6) (extended)
20GB Ext3 (sda2)

There was no read or write problem to the common partition (sda5).

I drag and drop (with cutting) the folder C:\Documents and Settings\user\Desktop in D:\hede. This got my Desktop to D:\hede\Desktop so if there is a boot failure, I can format C: (sda1) safely.

Then while thinking on this, there is an idea light on my head: "if I made myDesktop move to the common partition, then I can make it
same for Linux".

There is no way to make it possible in Linux... Someone said that this errors (chown 644 /media/sda5/hede can not be done) are getting because of the partition type of the common partition, Fat32. There is no way to attribute user access rights if it is a Fat32 partition, he said.

Then I backup my all data, deleted the partition Fat32, made a new partiton with the id ext3; while doing these I used PartitionManager. Then I restored my data. In windows, I installed a driver from the site fs-driver.org and with the same methode, I set my windows_desktop folder to sda5 which is now ext3. There is NO PROBLEM in windows although it is a linux partition.

When I boot with linux, there is no harddrive icon named sda5 mounted on my desktop. It was normal, so I modified fstab like this:
Code:
ceremcem@Zeytin:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/sda2       /               ext3    defaults,errors=remount-ro 0       0
/dev/sda1       /media/sda1     ntfs    defaults,nls=utf8,umask=007,gid=46 0       0
#/dev/sda1       /media/sda1     ntfs-3g    defaults,gid=46,umask=000,locate=tr_TR.utf8 0       0
/dev/sda5       /media/sda5     ext3    defaults,user,auto,rw,locate=tr_TR.utf8 0       0
/dev/sda6       none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
ceremcem@Zeytin:~$ sudo mount -a
mount: dosya sistemi türü yanlış, seçenek yanlış, /dev/sda5 üzerinde superblok
       hatalı, karakter kümesi eksik, ya da başka bir hata olabilir
       Bazı durumlarda syslog'da bulunan bilgiler yararlıdır.
       dmesg | tail  gibi birşeyler deneyin

ceremcem@Zeytin:~$
The mount error is in Turkish (which is my own language) and Its original must be:

mount: wrong filetype, wrong option, superblock error on /dev/sda5, missing characterset or there is another error


I can mount /dev/sda5 which is ext3 manually by typing
Code:
sudo mount /dev/sda5 /media/sda5
but it's not mounted automatically with the fstab entry. This is my first problem. (and also it is not working the command: sudo mount /dev/sda5 >>> causes>>> mount: error: wrong filetype in fstab)


While in Linux, I can access my files on sda5 when mounted it manually,I can listen my musics, read my documents on sda5 but their filenames are incorrect which are including Turkish characters as ı,ö,ü,ş,ç,ğ. There is no problem with the filenames which are containing the same characters in sda1 (still looking from Linux). And also when I am in windows, there is no problem with the characters on sda5 (ext3 now), but same issue (wrong encoding) on sda2 (ext3). sda5 and sda2 has the same partition type; why the characters is normally decoded on sda5 but not sda2 by Windows? (this is my second problem)

If I make the ntfs-3 line active in fstab and ntfs line inactive, sda1 is mounted correctly on /media/sda1 but there is no desktop icon. How can I fix this problem? (This is my third and the last problem)

Thanks for your attention

Last edited by CeremCem; 10-17-2006 at 07:27 AM. Reason: spell correction, header correction
 
Old 10-16-2006, 10:43 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Change the /etc/fstab entry to look like your entry for the other linux partition, maybe something like;

Code:
/dev/sda5       /media/sda5     ext3    users,auto,rw,errors=remount-ro 0       0
Be sure and give users (as root) read/write permissions on the unmounted directory /media/sda5 also, for example; chmod 0777 /media/sda5
 
Old 10-17-2006, 07:37 AM   #3
CeremCem
LQ Newbie
 
Registered: Oct 2006
Posts: 3

Original Poster
Rep: Reputation: 0
Hello,

My first (and the biggest) problem has solved by editing fstab as:

Code:
/dev/sda5    /media/sda5    ext3    defaults,user,auto,rw    0    0
Now, while in windows, wrong encoding with the filenames on sda2 (ext3) but true encoding on sda5 (ext3) and vice versa became the biggest problem. The last is missing desktop icon, but it is not a problem at all... (I don't care while character encoding problem is persisting)

Thank you for reply
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Partition added in Windows caused kernel panic Rohan_mk1 Linux - Hardware 11 09-04-2006 10:36 AM
Change partition dyrer Suse/Novell 3 06-22-2005 02:36 PM
how to mount fat32 partition automaticly? lom Linux - Newbie 3 12-09-2003 09:06 PM
Data loss on a FAT partition. What caused it? correro Linux - General 3 03-10-2003 08:42 PM
Having troubles with partition...caused by wine? Grim Reaper Linux - Software 5 12-16-2002 02:10 AM


All times are GMT -5. The time now is 02:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration