LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
LinkBack Search this Thread
Old 12-21-2011, 01:59 PM   #1
the dsc
Member
 
Registered: May 2009
Distribution: Debian testing
Posts: 115
Blog Entries: 44

Rep: Reputation: 27
Openbox runs lots of stuff (not set on autostart) at startup after the last upgrade


Openbox 3.5.0, from Debian testing.

I think these stuff are from Gnome environment, which I have I guess, but I never use it (the DE, not the stuff, which I use sometimes, I only don't want them starting at the startup).

"Autostart" had an environment variable of "DE=KDE" or something like that though, so I'm not sure, I know only that all the stuff that started or most of it is GTK. I removed it and it did not have ant effect though.

The new "environment" config file is the default, just "blank"/commented.



Anyone knows what's going on?



I thought I had found the answer, there was a ~/.config/autostart folder, with .desktop files on it, I've removed the folder, but the apps are still being run by something.



OK, I think now I've found it, sort of. There is a similar folder on /etc/xdg/autostart, which sets autostart apps for all DEs. Apparently I have to either delete the entire folder or set only the things I want to always autostart in any time, any DE. I wish one could just have something like "GLOBALAUTOSTART=0/false/off" set on my on home folder...




edit: I've faced the same trouble and I knew I had made a topic on it once, I didn't remember if I had solved it through the topic the first time, but anyway, samuvuo's solution works, thanks!


A quick trick if you do not want anything there but don't want to delete the files either:

for i in *.desktop ; do echo "Hidden=true" >> $i ; done

Last edited by the dsc; 04-07-2012 at 11:11 AM. Reason: solved, thanks to samuvuo
 
Old 01-03-2012, 05:14 PM   #2
samuvuo
LQ Newbie
 
Registered: Aug 2011
Location: Finland
Distribution: Arch
Posts: 1

Rep: Reputation: Disabled
The files in /etc/xdg/autostart are executed on login to your DE/WM. To disable, edit the /etc/xdg/autostart/*.desktop file and set Hidden=true (so it won't autostart) OR delete the file, if you are never going to autostart it via XDG.

You can also set the visibility of the desktop file, so it shows only in certain DEs, ie. OnlyShowIn=XFCE;

But yes, a "global override" would be nice.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Openbox autostart.sh and setting alias on openbox start Jelloir Linux - Desktop 1 07-03-2011 03:56 AM
[SOLVED] Question, Openbox autostart on second desktop TobiSGD Linux - Desktop 1 09-15-2010 08:36 PM
[openbox] My autostart.sh file is not restoring things Removed44 Linux - Newbie 4 06-14-2010 09:31 PM
Item in ~/.kde/Autostart runs twice hand of fate Linux - Software 1 04-29-2005 11:53 PM
autostart karamba stuff CamelofCamelot Linux - Software 1 01-02-2004 02:41 AM


All times are GMT -5. The time now is 04:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration