LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Openbox runs lots of stuff (not set on autostart) at startup after the last upgrade (http://www.linuxquestions.org/questions/linux-desktop-74/openbox-runs-lots-of-stuff-not-set-on-autostart-at-startup-after-the-last-upgrade-919860/)

the dsc 12-21-2011 02:59 PM

Openbox runs lots of stuff (not set on autostart) at startup after the last upgrade
 
Openbox 3.5.0, from Debian testing.

I think these stuff are from Gnome environment, which I have I guess, but I never use it (the DE, not the stuff, which I use sometimes, I only don't want them starting at the startup).

"Autostart" had an environment variable of "DE=KDE" or something like that though, so I'm not sure, I know only that all the stuff that started or most of it is GTK. I removed it and it did not have ant effect though.

The new "environment" config file is the default, just "blank"/commented.



Anyone knows what's going on?



I thought I had found the answer, there was a ~/.config/autostart folder, with .desktop files on it, I've removed the folder, but the apps are still being run by something.



OK, I think now I've found it, sort of. There is a similar folder on /etc/xdg/autostart, which sets autostart apps for all DEs. Apparently I have to either delete the entire folder or set only the things I want to always autostart in any time, any DE. I wish one could just have something like "GLOBALAUTOSTART=0/false/off" set on my on home folder...




edit: I've faced the same trouble and I knew I had made a topic on it once, I didn't remember if I had solved it through the topic the first time, but anyway, samuvuo's solution works, thanks!


A quick trick if you do not want anything there but don't want to delete the files either:

for i in *.desktop ; do echo "Hidden=true" >> $i ; done

samuvuo 01-03-2012 06:14 PM

The files in /etc/xdg/autostart are executed on login to your DE/WM. To disable, edit the /etc/xdg/autostart/*.desktop file and set Hidden=true (so it won't autostart) OR delete the file, if you are never going to autostart it via XDG.

You can also set the visibility of the desktop file, so it shows only in certain DEs, ie. OnlyShowIn=XFCE;

But yes, a "global override" would be nice.


All times are GMT -5. The time now is 12:41 AM.