LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 11-22-2007, 12:38 AM   #1
justanothersteve
Member
 
Registered: Aug 2005
Location: Missouri, USA
Distribution: Gentoo
Posts: 161

Rep: Reputation: 30
No System Sounds in KDE


Hello, I have having problem getting system sounds to play (startup sound, minimize sound, etc...) in KDE. I have ALSA configured correctly, I can play MP3 through the command line AND through a media player within KDE. The problem is getting the system sounds to play. I *THINK* it may be a problem with ogg. I am using gentoo and have the ogg and vorbis USE flags on. When I try to play the .ogg sound files through a player, they will not play either. Any idea?
 
Old 11-22-2007, 07:19 PM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,830

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
I had to get artd running in order to play system sounds. I'm using Mandriva, and I can start the arts deamon through MCC. I'm not sure how you would start it on Gentoo.

I had to install libvorbis.so to get ogg files to play through XMMS. I don't know what audio player you are using, but see if you can find the plugin and install it. I have ripped several audio CD's to ogg format, they play and sound as good as the original CD.

Hope this helps.
 
Old 11-24-2007, 01:14 AM   #3
justanothersteve
Member
 
Registered: Aug 2005
Location: Missouri, USA
Distribution: Gentoo
Posts: 161

Original Poster
Rep: Reputation: 30
***solved****

I post this solution so that it may help others.

The problem was with Akode. I am using Gentoo and did not originally have the 'vorbis' USE flag set. I added it in and recompiled many things with the new USE flag during my trial-and-error attempts at fixing this. I overlooked Akode. I ran emerge -pv akode and saw it wanted to rebuild with the newly set vorbis USE flag. I rebuilt akode with the vorbis use flag and voila, ogg system sounds.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No KDE System Notification Sounds MQMan Slackware 3 03-01-2007 06:33 PM
kde system sounds don't work RoaCh Of DisCor Linux - Software 0 12-11-2004 12:49 AM
KDE system sounds won't play gbj Linux - Software 4 10-28-2004 06:12 PM
KDE system sounds problem (arts) conn-fused Linux - Software 0 10-28-2004 12:21 PM
KDE: How to turn system notification sounds off ? startail Linux - Newbie 2 07-25-2003 06:17 AM


All times are GMT -5. The time now is 03:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration