LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices



Reply
 
Search this Thread
Old 11-30-2007, 08:46 AM   #1
winterfire
LQ Newbie
 
Registered: Mar 2007
Location: Georgia
Distribution: Ubuntu 6.10 , Puppy
Posts: 18

Rep: Reputation: 0
Unhappy My Linux computers have stopped connecting to the web


I've been using linux for about 6 months with very few problems (all of which were solved by this forum), now I've developed a new one. When I booted my Ubuntu box and tried to go to the web, I get the web page unavailable page. I checked the settings and tried it again, still nothing. I've tried Puppy and Damn Small Linux and even a friends Xubuntu box. Nothing works. My two Windows machines can access the web normally and the linux machines will access the web from internet hotspots around town, just not at home. I've made no changes to my settings at home and no changes to my computer.
Has anyone else had this problem, and how do I solve it.Thanks for your help.
 
Old 11-30-2007, 10:02 AM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
You need to fill in more details.

Can you ping back and forth between your windows hosts and the Linux host.

Look at your /etc/resolv.conf file. Are your ISP's nameservers listed?

Does filesharing work or ssh work with the linux boxes?

Are you using wireless at home? Did you change the PSK in the router?

Look at the output of "ifconfig" and the "route" commands. Is your IP in the same subnet as your router? Is the router's IP listed as the default gateway?

Try the host command, as in "host www.linuxquestions.org" to check dns.

Check the "host.conf" file. Does it contain
Code:
order hosts, bind
#
# The following options are used by the resolver library:
#
multi on
Check the /etc/nsswitch.conf file.
Code:
hosts:          files mdns4_minimal [NOTFOUND=return] dns
networks:       files dns
These two lines are important. The hosts: line should correspond with the host.conf line.

Good Luck!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
connecting two computers. kponenation Linux - Networking 2 09-30-2005 07:28 PM
linux stopped browseing web pages ziox Linux - Networking 2 12-02-2004 07:27 PM
Connecting to other computers xnihilo Linux - Software 1 06-04-2004 10:09 AM
Problem connecting 2 Linux computers gmichel Linux - Networking 0 08-21-2003 07:09 AM
Connecting 2 computers prowzen Linux - Networking 2 05-11-2001 11:40 PM


All times are GMT -5. The time now is 07:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration