LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   my files opening in vlc (http://www.linuxquestions.org/questions/linux-desktop-74/my-files-opening-in-vlc-4175428061/)

Cyb3r.Kn!ght 09-19-2012 06:00 PM

my files opening in vlc
 
Here is my issue, I cant think of the name to describe what is going on, but I can give examples of what the issue is: When I open my 'start' menu, I will select my 'documents' folder, when i click on that it seems to open the vlc player and 'plays' all the files .... I never selected VLC for any project or to 'play' any file... Im not sure what is going on

JaseP 09-19-2012 06:30 PM

It's probably the user environment settings set to launch VLC when you select that directory. In top of that, VLC might be just playing its entire playlist when (incorrectly launched). What DE are you using? Gnome, KDE, XFCE?

Anyway, right click on the directory, look for something like Properties and see if there is anything set "wrong" such as a file association...

Also,... you might be double clicking in an environment set to respond to single clicks...

John VV 09-19-2012 11:40 PM

"Start" and then " my documents"

this sounds like a Microsoft Windows issue
and not a Linux one

on Windows use the VLC installer "vlc-2.0.3.xpi" or "vlc-2.0.3-win32.exe"
http://sourceforge.net/projects/vlc/files/2.0.3/win32/

EDDY1 09-20-2012 12:31 AM

I agree with JaseP somehow you changed all your documents to "Open With>>VLC"
I don't know of any 1 command to change all of your links from "Open With>>VLC" but you can go to properties of each doc or odt & yu will be able to see what application is set as default under "Open With" tab. For .odt & .doc my "Open With" is linked to OpenOffice or Libre Office.

@John VV
the OP wrote as "my 'documents' folder" which to me suggests linux OS, although I may be wrong. My apologies if I am.

Cyb3r.Kn!ght 09-20-2012 04:20 AM

Quote:

Originally Posted by EDDY1 (Post 4784753)
I agree with JaseP somehow you changed all your documents to "Open With>>VLC"
I don't know of any 1 command to change all of your links from "Open With>>VLC" but you can go to properties of each doc or odt & yu will be able to see what application is set as default under "Open With" tab. For .odt & .doc my "Open With" is linked to OpenOffice or Libre Office.

@John VV
the OP wrote as "my 'documents' folder" which to me suggests linux OS, although I may be wrong. My apologies if I am.

its not a single 'command' and Im using SolusOS Acer 500GB HDD 4GB DDR3...

When my sisters fiancee took a look at it the first time i believe this is one of the commands he used: 'update-alternatives --all'

EDDY1 09-20-2012 12:02 PM

Quote:

Originally Posted by Cyb3r.Kn!ght (Post 4784904)
its not a single 'command' and Im using SolusOS Acer 500GB HDD 4GB DDR3...

When my sisters fiancee took a look at it the first time i believe this is one of the commands he used: 'update-alternatives --all'

Well you can always right-click o each document go to Properties & select document viewer or Open-Office to open docs & set as default.

JaseP 09-20-2012 01:01 PM

I'm pretty sure that Nautilus has a setting to define the default app for opening a particular type of file... But if he set the properties for the folder to be opened with VLC, it might just set to launching all the files in there with VLC. VLC would ignore the files it can't read.

Another place where this could have been done is in the media settings for the desktop environment. It might be set to open all media files with the appropriate default app when the file os opened or removable media attached (like the default action in some setups for when a flash drives with picture is inserted). Normally, this is only for removable storage, but it may have been set incorrectly to do the same with all directories that are opened...

Cyb3r.Kn!ght 09-20-2012 06:53 PM

Quote:

Originally Posted by JaseP (Post 4785283)
I'm pretty sure that Nautilus has a setting to define the default app for opening a particular type of file... But if he set the properties for the folder to be opened with VLC, it might just set to launching all the files in there with VLC. VLC would ignore the files it can't read.

Another place where this could have been done is in the media settings for the desktop environment. It might be set to open all media files with the appropriate default app when the file os opened or removable media attached (like the default action in some setups for when a flash drives with picture is inserted). Normally, this is only for removable storage, but it may have been set incorrectly to do the same with all directories that are opened...

JaseP, your description sounds accurate, how do I change it... Im very little aware of Nautilus, I do know it is a 'file manager', what I am unsure of is How did I get it up & how do I change it back to the original setting.

TobiSGD 09-21-2012 07:44 AM

Moved: This thread is more suitable in <Linux - Desktop> and has been moved accordingly to help your thread/question get the exposure it deserves.

Cyb3r.Kn!ght 09-21-2012 06:49 PM

Quote:

Originally Posted by TobiSGD (Post 4785776)
Moved: This thread is more suitable in <Linux - Desktop> and has been moved accordingly to help your thread/question get the exposure it deserves.

Thank You, I wasnt sure where to post this 'thread'

JaseP 09-24-2012 09:59 AM

Quote:

Originally Posted by Cyb3r.Kn!ght (Post 4785439)
JaseP, your description sounds accurate, how do I change it... Im very little aware of Nautilus, I do know it is a 'file manager', what I am unsure of is How did I get it up & how do I change it back to the original setting.

Nautilus does a bit more than just be a file manager. Under the "original" Gnome configuration (meaning version 2.X), it is also responsible for drawing the desktop screen (unless the --no-desktop command line switch is used). So, it is more pervasive than a simple file manager.


Your best bet in terms of resetting it are as follows;
1) Right click and look at the properties of the highest level of whatever you are looking to fix (entire directory, versus single files) & change the settings appropriately, including making them recursive (changing all contents as well),
2) Create a new user, and migrate your data, if all else fails (& don't forget to give that user sudo authority, research tutorials on how to do this).

If you screw up a user account too bad, you can always start fresh with a new account. That's one of the beauties of Linux distributions.


All times are GMT -5. The time now is 03:02 PM.