LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Multisector ISO image, old game (http://www.linuxquestions.org/questions/linux-desktop-74/multisector-iso-image-old-game-837227/)

AlvaroG 10-10-2010 12:42 PM

Multisector ISO image, old game
 
Hi All,
I have an old original CD for a DOS game, Fantasy General. But the CD is so old and nice looking ;-) that I prefer using a cd image to play.
The thing is, this CD is a dual audio/data cd, and the music for the game is in the audio part. I can play the game with the sound effects, on my FreeDOS VirtualBox, but no music comes out.

I need to know how to make a full image of the disk. I first started with dd and some tools to create cd images, but all of them are only making an image of the data sector.
Then I tried cdrdao, and it created an image of 440 MB (versus the 108MB I get from the other tools), so I think that is a complete image. However, it is in toc/bin format, and VirtualBox won't mount it as a virtual drive.
AcetoneISO says it can't mount a multisector ISO, or convert my bin file to ISO.
Tried iat, but the conversion of the 440 MB file led to a 110 MB iso (makes me think it just stripped the audio part)

Any other ideas?

Thanks in advance!

mf93 10-11-2010 01:27 AM

audio is just data on the cd so when you create a mirror it is mirroring all of it- there is no special 'audio' section. look in the game and see if the options are properly configured for music to play

AlvaroG 10-11-2010 09:47 AM

That's my understanding, but then how is it possible that the iso image is 4 times smaller than the bin, if both are supposed to be a mirror of the content?
I am still trying some stuff, so I can't say for sure if all data is there on the generated ISO or not.

Facts:
- cdrdao does recognize the cd to be a dual data/audio disc
- it took a long time for cdrdao to read everything, after some time it started spitting "Weird mode" messages
- the bin image has everything (as per the toc file generated by cdrdao)
- the iso is 4 times smaller, and took a very long time for iat to create it from the bin
- dd /dev/sr0 generates a 110 MB file

Too bad that the game does not work under Windows XP. I wish I had a real working machine to try the game, it may be my own CD that is broken. However, the message from AcetoneISO made me wonder about the issue being a limitation of the format or something like that.

once I'm back at home, I will try playing the original cd as an audio disc. If I'm successful, I'll try the iso image (btw, is there any audio player that lets me play an iso as an audio disc?)

mf93 10-11-2010 11:56 AM

iso and bin are different formats, bin being a literal bit-by-bit representation of the cd and the iso representing the information as mathematical expressions. read the manual for the tool you are using. You should be able to extract the .bin into its constituent files and play it from there without having to mount it as a virtual disk or anything. Then you will be able to see all the files and see if the music audio files are present or not.

AlvaroG 10-11-2010 03:50 PM

I know the music data is there in the bin (at least that is what the TOC file says), what I don't know is if it is present in the ISO also.
I need to mount it because I need to make it available to VirtualBox so the game can see it.

But as I wrote before, I need to do some more tests to be sure.

Thanks for your comments so far :)

mf93 10-11-2010 11:31 PM

you should be able to copy the .bin into the virtual box hard drive- go look up some tutorials on how to do that then you will be able to access it on the virtualized machine without having to go through a mounted .iso file

AlvaroG 10-12-2010 08:53 AM

I guess I'm missing something, because I quite don't get how having the .bin file in the hard drive will work for what I want. The game will still look for a cdrom, and will not find it

mf93 10-12-2010 01:38 PM

if you can move the .bin into the virtualbox hard drive you can extrace it and directly run the .exe file without having to mount it as a cd first. i would recommend uploading the .bin on some filesharing site and the redownloading it from DOS onto the virtualbox HDD

AlvaroG 10-13-2010 11:31 PM

Again, I think I am missing something.
Either I don't get what you mean, or you have misunderstood the problem.

How can I extract the .bin image of the cd and use it? from DOS? Copying to the hard drive is not a problem: I can use mkisofs and mount an iso containing the bin image in virtualbox, then copy the bin to the virtual hard drive. But why would I want to do that? Please remember that I was trying to get an image of a dual data/audio cd, and I'm not interested on files that may be present on the data part

Thanks again,
Regards

mf93 10-14-2010 12:23 AM

you can then run the .exe file directly and play it

AlvaroG 10-14-2010 09:06 AM

But I am currently able to play the game, using the ISO image I created first. My problem (not so much of a problem actually, just an annoyance) is that I hear no music from the game.

Anyway, I've doing some research and I think what I want is not possible. I can't even find a cd player that plays the audio part of the cd, so it may be damaged after all this years (or maybe it is not possible to play a dual cd as audio?).

Xenphor 06-27-2013 11:59 PM

Use these commands, taken from here: http://www.dosbox.com/wiki/Cuesheet

> cdrdao read-cd --datafile image.bin --driver generic-mmc:0x20000 --device /dev/cdrom --read-raw image.toc

> toc2cue image.toc image.cue

Replace "image.bin" and "image.toc" to whatever you want. Also, make sure you point to the right device file for "/dev/cdrom" for whatever it is on your system. Now I know you said you couldn't mount a toc, well that's what the second command is for. It will convert a toc to a cue. Then you can mount the cue as a cue/bin.

AlvaroG 06-28-2013 10:40 AM

Hey, thanks for the advice, although of course this thread is 3 years old ;)

At the time I was trying to get the game working in VirtualBox, after researching I found that VBox could not use CUE/BIN images, and understood that an ISO image does not copy the audio tracks.
My game CD was just fine (even now it probably is, although I don't even open the case anymore), so once in a while I launch DOSBox to play the game, and it works flawlessly.


Regards


All times are GMT -5. The time now is 02:37 PM.