LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Mouse sensitivity too high in fullscreen (http://www.linuxquestions.org/questions/linux-desktop-74/mouse-sensitivity-too-high-in-fullscreen-928988/)

splintercdo 02-12-2012 12:18 PM

Mouse sensitivity too high in fullscreen
 
Hi

The problem is that mouse sensitivity is too high when for example scummvm or many other applications are launched in fullscreen.

Even if lower mouse sensitivity in keyboard and mouse settings, after switching in fullscreen and back sensitivity is switched back to default settings!

WSmart 02-20-2012 08:18 PM

driver change
 
Greetings,

Try a different driver.


Thanks for posting and thanks all.

Be real, be sober.

narindersingh 02-22-2012 12:44 AM

I am sorry.

lemonslol 02-22-2012 07:46 PM

Quote:

Originally Posted by splintercdo (Post 4600628)
Hi

The problem is that mouse sensitivity is too high when for example scummvm or many other applications are launched in fullscreen.

Even if lower mouse sensitivity in keyboard and mouse settings, after switching in fullscreen and back sensitivity is switched back to default settings!

It would help to know what kind of mouse you have, as some like Razer mice have to have the drivers installed

jmccue 02-25-2012 12:39 PM

Hi

see "man xset"

For example I use
xset m 6 2

but it is easy enough to play around with the settings

John

QuasarDonkey 03-13-2013 05:31 PM

I just ran into this exact same problem, with mouse sensitivity being insanely high in programs like ScummVM in fullscreen mode, but fine in windowed mode.

It appears to be a bug with SDL fullscreen when used with a touchpad.

Workaround - type this in your shell before running the program:
Code:

export SDL_MOUSE_RELATIVE=0
Mouse speed will be normal again. To make this change permanent, put it in your .bashrc file.

(BTW I'm using Slackware 14.0 on a MacBook Pro, with SDL-1.2.14).


All times are GMT -5. The time now is 03:01 PM.