LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   mounting drives in nautilus places bar (http://www.linuxquestions.org/questions/linux-desktop-74/mounting-drives-in-nautilus-places-bar-810657/)

ktm_kannan 05-28-2010 05:25 AM

mounting drives in nautilus places bar
 
2 Attachment(s)
hi all
i am using Mnadriva 2010. but i am experiencing this problem in 2009.1 also. i have attached two images in which u can see the nautilus places bar and the error message i am getting when i click on a drive to mount or access it. actually i have edited /etc/fstab and added permission for users to mount and access the disks.

please help me.
now i have make bookmarks of the mounted drives and now using it to access the drives.

i have used UUID, /dev/sdaX and Label referencing in the fstab file. but same result. i can access the drives when i goto /mnt/<mount> but not from places bar.

Simon Bridge 05-30-2010 09:42 PM

The screenshots don't actually show me anything - what am I supposed to be looking at?

I see a folder icon called acessd but I don't see what it is supposed to represent or what was done to get it to appear or what has been done since. The error message is just "unable to mount device" but I cannot see what you tried to mount, how, or under what cirumstances. There is a tab to display more information about the error which you chose not to expand - the extra info is probably important, but I cannot tell.

If I understand you correctly, you have some mountpoints in /mnt which have file-systems mounted on them somehow involving fstab. Do the file-systems mount at boot, or does a user mount them later? What are the fstab entries?

We don't normally want users to mount and unmount things. We'd normally get root to do this, giving the user access where that is needed. Does your user have access to root-mounted partitions?

Continuing from what you said - it looks like you attempt to access a mounted fs from its icon as it appears in the places menu - but when you try, the system insists that the filesystem is not mounted and that it is unable to mount it. You subsequently browse to the mount-point in a file manager, and discover the filesystem mounted there. Is that correct?

ktm_kannan 05-31-2010 01:03 AM

1 Attachment(s)
Quote:

Originally Posted by Simon Bridge (Post 3986896)
The screenshots don't actually show me anything - what am I supposed to be looking at?

I see a folder icon called acessd but I don't see what it is supposed to represent or what was done to get it to appear or what has been done since. The error message is just "unable to mount device" but I cannot see what you tried to mount, how, or under what cirumstances. There is a tab to display more information about the error which you chose not to expand - the extra info is probably important, but I cannot tell.

i have attached another screenshot expanding the details. it was empty that's why i did not post it. i know that the details could fetch more information.

Quote:

Originally Posted by Simon Bridge (Post 3986896)
If I understand you correctly, you have some mountpoints in /mnt which have file-systems mounted on them somehow involving fstab. Do the file-systems mount at boot, or does a user mount them later? What are the fstab entries?

We don't normally want users to mount and unmount things. We'd normally get root to do this, giving the user access where that is needed. Does your user have access to root-mounted partitions?

Continuing from what you said - it looks like you attempt to access a mounted fs from its icon as it appears in the places menu - but when you try, the system insists that the filesystem is not mounted and that it is unable to mount it. You subsequently browse to the mount-point in a file manager, and discover the filesystem mounted there. Is that correct?

i am the sole user of my machine. i want the drives to be mounted at startup and have given users permission to mount the drives. they are NTFS and ext3 partitions and needed to be accessed frequently. in earlier versions namely Mandriva 2008.1 i was using KDE and this type of access from Konqueror worked fine. but now this time the Nautilus fails.

below is my fstab
Quote:

# Entry for /dev/sda2 :
LABEL=Mandriva / ext3 relatime 1 1
# Entry for /dev/sda6 :
LABEL=Mand_home /home ext3 relatime 1 2
/dev/cdrom /media/cdrom auto umask=0,users,iocharset=utf8,noauto,ro,exec 0 0
# Entry for /dev/sda8 :
UUID=53B0F56E4D87B0C3 /mnt/data ntfs-3g umask=000,user,dev,suid,exec 0 0
# Entry for /dev/sda7 :
LABEL=lin_data /mnt/lin ext3 user,dev,relatime,suid,exec 1 2
# Entry for /dev/sda1 :
UUID=075335834A973E7A /mnt/windows ntfs-3g umask=000,user,dev,suid,exec 0 0
none /proc proc defaults 0 0
# Entry for /dev/sda5 :
UUID=89f6bf8d-51c7-4f85-abd5-e587c2b68d00 swap swap defaults 0 0

i have tried UUID, /dev/sdax reference and finally the LABEL..

but i think it will be interesting for u to know that the installation is the FREE version of Mandriva a DVD. there is another version the ONE which is a CD and LIVE and contains Drivers for nVIDIA and ATI etc. in that the Nautilus mounts the drives.

also in 2008.1 i was able to use Knoqueror or Nautilus as root browser (launch them from a root terminal) to copy files. but in these versions it says (only parts of a very long message)

Quote:

(nautilus:27888): EggSMClient-WARNING **: Failed to connect to the session manager: None of the authentication protocols specified are supported
.
.
.
.
.
.
.
.

.
.
.

long messgae
(nautilus:27888): Eel-WARNING **: GConf error:
Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
.
.
.
.
.
.
(nautilus:27888): Unique-DBus-WARNING **: Unable to open a connection to the session bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(nautilus:27888): Unique-DBus-WARNING **: Unable to connect to the running instance, aborting.


please guide me

Simon Bridge 06-01-2010 02:58 AM

You want the partitions mounted at boot, with ordinary user access ... this is fine. You do not need the mount options to allow the user to mount and unmount the drive because you are automounting anyway (unless there is some reason you want to unmount the drive after boot but before log-out?)

In the fstab file - try changing the mountpoints to /media instead of /mnt

# Entry for /dev/sda1 :
UUID=075335834A973E7A /media/windows ntfs-3g defaults,umask=0000,auto 0 0

alan99 06-01-2010 03:20 AM

Does the system has policy manager installed? If, so you might have to figure out how to configure it as it will restrict certain activities such as mounting drives.

ktm_kannan 06-01-2010 08:44 AM

Quote:

Originally Posted by Simon Bridge (Post 3988267)
In the fstab file - try changing the mountpoints to /media instead of /mnt

pardon but what is the difference of using /media than /mnt?

alan99 06-02-2010 07:44 AM

Technically, no difference, except /media is normally used to mount removable drives.

ktm_kannan 06-02-2010 09:09 AM

Quote:

Originally Posted by alan99 (Post 3989946)
Technically, no difference, except /media is normally used to mount removable drives.

but mine is not removable. it is fixed disk that's why i chose /mnt

ktm_kannan 06-05-2010 11:51 PM

i would like to add another information...
i have mentioned that i cannot run Nautilus as root user to copy files. i use "pcmanfm" for tis purpose. in the pcman fm there is a places bar. and when i click onthe drives listed there it automatically mount and i can access it. both as root user and normal user.

so i guess it is aproblem with nautilus. can any one please tell me how can i edit the places bar in nautilus.so that i can try changing a few parameters there

Simon Bridge 06-08-2010 01:07 AM

Quote:

Originally Posted by ktm_kannan (Post 3990023)
but mine is not removable. it is fixed disk that's why i chose /mnt

Is there anything wrong with trying it?

What about the rest of the suggested fstab line if you want to flat refuse to use /media just put in /mnt it its place!

It used to be that file systems mounted in /media would show up in places while those mounted elsewhere would not. It is faster to try it out than read through the documentation to confirm it.

[edit] but see below ...

Simon Bridge 06-08-2010 01:28 AM

Try this:

Browse to the /mnt menu in a nautilus browser window - make sure the side-pane is open.
Drag the folder corresponding to the mountpoint to the side-pane and drop it where you want it. (If this does not work, open the mount-point and go to bookmarks > add bookmark or drag the button in the address bar... there are probably others too.)

note: you should be able to browse as root in nautilus by (a) logging in as root, or (b) using gksudo nautilus from the terminal.

dahweeds 03-05-2011 06:37 AM

I just met this situation with nautilus after upgrading a different linux to the latest release. The error happens on that system because my root user shell was not su -.

so like this you will get the error:
Code:

me@computer:~$ su
computer:/home/me#
computer:/home/me# nautilus /var/log
...
(nautilus:6552): Unique-DBus-WARNING **: Unable to connect to the running instance, aborting.
....


Then I exit the root shell and try again like this:
Code:

me@computer:~$ su -
computer:~#
computer:~# nautilus /var/log
Initializing nautilus-gdu extension

and the nautilus window popped up with root privilidge. :doh:


All times are GMT -5. The time now is 03:36 PM.