LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 08-12-2012, 02:53 PM   #1
kox444
Member
 
Registered: Aug 2012
Posts: 110

Rep: Reputation: Disabled
mount permissions


Every time when I want to mount a partition in nautilus I get prompted to enter password. This is kinda annoying. I use Debian with Gnome2 (like it matters anyway).How do I give myself permissions to mount whatever I want without authorization?
 
Old 08-12-2012, 04:08 PM   #2
honeybadger
Member
 
Registered: Aug 2007
Location: India
Distribution: Slackware (mainly) and then a lot of others...
Posts: 847

Rep: Reputation: Disabled
This is a secutrity feature of Debian - it will by default not mount any other partition.
To do so you woill have to manually edit the /etc/fstab file. Make a backup of the orignal file before you edit the file.
Hope this helps.
 
Old 08-12-2012, 05:10 PM   #3
kox444
Member
 
Registered: Aug 2012
Posts: 110

Original Poster
Rep: Reputation: Disabled
I added
UUID=13237583-ec59-4f95-8083-460f4b3a515f /media/newfilesystem ext4 defaults 0 0
line to it, and it doesn't mount automatically, instead when I try to mount it shows error: mount: only root can mount /dev/sda6 on /media/newfilesystem

I just want to not be prompted when I mount a filesystem, mounting automatically at startup would be a good thing too.
 
Old 08-12-2012, 06:07 PM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Add the "user" mount option. I always add the user_xattr and acl options to add these features.

If this is an external drive, use either the "noauto" or "nofail" options. If the drive isn't plugged in, you don't want booting to fail. The noauto will not mount it during boot. The nofail option will try to mount it at boot, but not drop you into the rescue shell if it fails.

You should really read through the mount man page to familiar yourself with the booting options.

Last edited by jschiwal; 08-12-2012 at 06:10 PM.
 
Old 08-16-2012, 04:10 PM   #5
kox444
Member
 
Registered: Aug 2012
Posts: 110

Original Poster
Rep: Reputation: Disabled
They are internal HDD partitions. Detected automatically. I added user option and everything is almost perfect. What's wrong is that I have new devices that are mountpoints I gave. When I click them, it mounts the device + it's taking time to mount the same device again and it returns access error. This entries are just unnecessary, they take up the space. I just have 2 devices for same partition.
 
Old 09-23-2012, 07:52 AM   #6
Xeratul
Senior Member
 
Registered: Jun 2006
Location: Debian Land
Posts: 1,323

Rep: Reputation: 83
Quote:
Originally Posted by kox444 View Post
Every time when I want to mount a partition in nautilus I get prompted to enter password. This is kinda annoying. I use Debian with Gnome2 (like it matters anyway).How do I give myself permissions to mount whatever I want without authorization?
you could allow everyone to use it, as it, into your /etc/fstab:


Code:
/dev/sdi1       /media/usbpen     vfat    rw,users,noauto  0       0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount permissions for hd* and sd* Vincent_Vega Linux - General 2 08-07-2006 02:30 PM
Mount permissions scouture Linux - Hardware 5 03-06-2005 01:48 PM
mount permissions chrismiceli Linux - General 1 06-13-2004 08:50 PM
mount permissions RTT Linux - Newbie 5 03-08-2004 11:13 AM
Mount Permissions Odd_Bloke Linux - Newbie 2 08-26-2003 12:00 PM


All times are GMT -5. The time now is 02:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration