LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Monitor turns off at live boot, any linux distro (http://www.linuxquestions.org/questions/linux-desktop-74/monitor-turns-off-at-live-boot-any-linux-distro-4175416321/)

Silverman50 07-12-2012 05:38 AM

Monitor turns off at live boot, any linux distro
 
Hello All,
Having been a linux user for some years, I am trying to introduce it to my eldest son. Using the easiest method - Unetbootin - from USB - tried several different linux flavours (Zorin - being windows like which is sometimes a helpful step on the road to full blown linux use, Ultimate edition 2.6 LTS, ONYX 64) in each case the monitor goes into standby mode after the seconds elapse and live boot begins. With no output to view, it is impossible to tell what is going wrong. The specs of the pc in question are as below

System Model: GA-A55M-S2V
BIOS: Award Modular BIOS v6.00PG
Processsor: AMD A6-3500 APU with Radeon(tm) HD Graphics(3CPUs),~2.1GHz
Memory: 4096 RAM
AMD Radeon HD 6530D
Chip type ATI display adapter (0x964A)
DAC Type: Internal DAC(400MHz)
Approx. Total Memory: 2036MB
Monitor: Generic PnP Monitor (this is a DELL Model E156FPC)

I suspect this could be a graphics problem - any help would be greatly appreciated.

Thanks one and all in advance.

Silverman50

TobiSGD 07-12-2012 08:54 AM

The monitor turning of is almost always a problem with kernel mode setting (KMS). When you are in the boot menu try to add the option nomodeset to the kernel line.
That should do the trick. After the installation you may have to do that also on the installed system to be able to install the proprietary AMD driver, which will solve the problem.

Silverman50 07-12-2012 02:43 PM

Hi TobiSGD,
Thanks for your reply, unfortunately adding nomodesetdid not work. Tried linuxMint 13 live - pressed tab on default entry - added the nomodeset at the end of the subsequent lines (these ended in a --) entered it after that (is this correct or should it go elsewhere?)

Thanks again and regards,

Silverman50

TobiSGD 07-12-2012 02:48 PM

Quote:

Originally Posted by Silverman50 (Post 4726324)
Hi TobiSGD,
Thanks for your reply, unfortunately adding nomodesetdid not work. Tried linuxMint 13 live - pressed tab on default entry - added the nomodeset at the end of the subsequent lines (these ended in a --) entered it after that (is this correct or should it go elsewhere?)

Thanks again and regards,

Silverman50

The -- is a kind of ending sign. No option after that will be parsed by the kernel, try to set the option before the --.

Silverman50 07-15-2012 07:56 AM

Hi TobiSGD,
Thanks for your reply...apologies for delay in response...this did work...managed to boot the live system...will be getting to install his system shortly...am I correct in thinking that after install from USB I will need to edit the menu.1st file (i have done this when working with puppy linux but not sure if this is the same file required to be edited)...by adding the 'nomodeset' to one of the lines (again I think this would be the same line as in the live mode and after 'quiet splash' is this correct?)

Thanks a million for your help, it is greatly appreciated

Regards,
silverman50

TobiSGD 07-15-2012 08:05 AM

It depends on the distribution you use. Most modern distros use Grub2, which doesn't have a menu.lst. But you can add nomodeset at boot time. Since setting the nomodeset option disables any acceleration on most open source drivers I would recommend to install the proprietary drivers after you have installed the system, so that you don't need that option anymore.

Silverman50 07-15-2012 09:23 AM

Thanks for that...will install when he is ready...and look to install the required drivers straight after...will let you know the outcome...

Might be a short break in comms....he is in the middle of something at the moment...

Regards,
silverman50


All times are GMT -5. The time now is 05:03 PM.