LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 11-07-2012, 07:13 AM   #1
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Sabayon, Mint, Puppy, Mageia, Slackware
Posts: 348

Rep: Reputation: 34
Mint 13 / MATE - jumpy touchpad


I installed Mint13 / MATE onto my Thinkpad T42.

Everything else seems to work fine except the touch pad (Synaptics PS/2 Touchpad).
Even Wi-Fi works fine.

The touchpad irregularities are pretty annoying.
The mouse pointer is jumpy especially when one tries to point onto the "scroll-arrow" or other relatively small item.
The pointer jumps about half a centimeter around seemingly randomly.
Sometimes the pad seems to think that a "button is pressed" even if finger glides on the pad quite smoothly.
That often happens when you use scroll-bar and then move the cursor onto the page itself - the scrolling tends to continue.

Any idea what's going on and how to fix it?
On T400 the touchpad works fine (64-bit installed, 64-bit live CD and 32-bit live CD).

I think the jumpiness might be caused by me having my fingers too close to the touchpad. I checked with evtest that holding my finger a couple of millimeters above the touchpad causes a stream of events.

I wonder if my touchpad is too sensitive?
If it is, what could I do about it?
 
Old 11-08-2012, 03:51 PM   #2
SteveThePirate87
Member
 
Registered: Jul 2012
Location: Glasgow, UK
Distribution: Mint 16 and Open Suse 13.1
Posts: 64

Rep: Reputation: Disabled
Hi,

Try going to menu > preferences > mouse/touchpad and messing with the settings there to see if you can get the touchpad sensitivity the way you want.

Steve
 
Old 11-09-2012, 01:40 AM   #3
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Sabayon, Mint, Puppy, Mageia, Slackware
Posts: 348

Original Poster
Rep: Reputation: 34
Didn't find any settings that could affect the sensitivity in the mouse preferences.
This is Mint 13 / MATE.

I know there is synclient, but I don't know what the parameters are for, what to change
and to which value.
Like, what are:
FingerLow = 25
FingerHigh = 30
FingerPress = 256
CornerCoasting = 0
AccelFactor = 0.0398089
TrackstickSpeed = 40
EdgeMotionMinZ = 30
EdgeMotionMaxZ = 160
CoastingSpeed = 20
CoastingFriction = 50
PressureMotionMinZ = 30
PressureMotionMaxZ = 160
PressureMotionMinFactor = 1
PressureMotionMaxFactor = 1
ResolutionDetect = 1
and do any of those affect the sensitivity?
 
Old 11-11-2012, 06:33 AM   #4
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Sabayon, Mint, Puppy, Mageia, Slackware
Posts: 348

Original Poster
Rep: Reputation: 34
Is this more of HW-stuff?

With my finger almost touching the pad:
$ synclient -m 10
time x y z f w l r u d m multi gl gm gr gdx gdy
0.000 5435 4000 0 0 0 0 0 0 0 0 00000000
13.455 3572 3409 9 1 4 0 0 0 0 0 00000000
13.490 3627 3464 5 1 4 0 0 0 0 0 00000000
13.500 3592 3421 4 1 4 0 0 0 0 0 00000000
13.553 3619 3700 3 1 4 0 0 0 0 0 00000000
13.589 3631 3696 2 1 4 0 0 0 0 0 00000000
13.599 3631 3696 0 0 0 0 0 0 0 0 00000000

If one finger is on the pad and another finger gets close,
the pointer moves about 3-4 cm.

Last edited by turboscrew; 11-11-2012 at 06:39 AM.
 
Old 11-11-2012, 09:21 AM   #5
SteveThePirate87
Member
 
Registered: Jul 2012
Location: Glasgow, UK
Distribution: Mint 16 and Open Suse 13.1
Posts: 64

Rep: Reputation: Disabled
The only other way i can think of is by opening up the configuration editor from the menu and scrolling down the tree as follows - Desktop > MATE > Peripherals > Mouse and adjusting the motion acceleration and threshold (you can fine tune it better in here). Also go to touchpad and makesure your scrolling is not two finger scrolling which might be causing the issue with the sensetivity also.

Also if this doesn't work install gsynaptics from the software manager. This will edit the synclient using a graphic interface.

Good Luck

Steve
 
Old 11-11-2012, 11:08 AM   #6
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Sabayon, Mint, Puppy, Mageia, Slackware
Posts: 348

Original Poster
Rep: Reputation: 34
motion_acceleration and motion_threshold are both -1.
What does that mean?
Any suggestions for the values?

Touchpad visible settings are:
disable_while_typing (selected)
horiz_scroll_enabled
scroll_method 0
tap_to_click
touchpad_enabled (selected)

There are no other options on the touchpad page.
 
Old 11-11-2012, 03:47 PM   #7
SteveThePirate87
Member
 
Registered: Jul 2012
Location: Glasgow, UK
Distribution: Mint 16 and Open Suse 13.1
Posts: 64

Rep: Reputation: Disabled
Hmmm - numbers equals less/slower + numbers more/faster. Mess around with them within a 10 point radius -5 to 5 and see if it makes a difference. My touchpad settings are similar except i have acceleration -4 and threshold 5 and works a treat. Not sure why yours is so sensitive other than a need to adjust these settings.
 
Old 11-12-2012, 01:59 AM   #8
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Sabayon, Mint, Puppy, Mageia, Slackware
Posts: 348

Original Poster
Rep: Reputation: 34
Thanks, it helped a bit. The sensitivity for another finger is, however, still there.
 
Old 11-12-2012, 02:19 AM   #9
SteveThePirate87
Member
 
Registered: Jul 2012
Location: Glasgow, UK
Distribution: Mint 16 and Open Suse 13.1
Posts: 64

Rep: Reputation: Disabled
I'm thinking then its something to do with the finger press option in synclient. Have ypou tried installing gsynaptics in order to edit the settings. If not you'll have to manually edit a file (the name escapes me atm)
 
Old 11-12-2012, 01:58 PM   #10
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Sabayon, Mint, Puppy, Mageia, Slackware
Posts: 348

Original Poster
Rep: Reputation: 34
I guess I'll try that gsynaptics...
 
Old 11-13-2012, 01:23 AM   #11
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Sabayon, Mint, Puppy, Mageia, Slackware
Posts: 348

Original Poster
Rep: Reputation: 34
I istalled gsynaptics from synaptic package manager, but:
Quote:
$ gsynaptics
gsynaptics: command not found
Also tried gpointing-device-settings, but there were no such options.

tpconfig doesn't seem to be of help either.
 
Old 11-13-2012, 01:39 AM   #12
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Sabayon, Mint, Puppy, Mageia, Slackware
Posts: 348

Original Poster
Rep: Reputation: 34
Aha:
Quote:
Package to ease upgrading from gsynaptics to gpointing-device-settings. reason for this is that gsynaptics is not compatible with recent xservers and upstream now develops gpointing-device-settings instead.
 
Old 11-13-2012, 01:52 AM   #13
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Sabayon, Mint, Puppy, Mageia, Slackware
Posts: 348

Original Poster
Rep: Reputation: 34
Quote:
Originally Posted by SteveThePirate87 View Post
Hmmm - numbers equals less/slower + numbers more/faster. Mess around with them within a 10 point radius -5 to 5 and see if it makes a difference. My touchpad settings are similar except i have acceleration -4 and threshold 5 and works a treat. Not sure why yours is so sensitive other than a need to adjust these settings.
My touchpad doesn't seem to be any more sensitive than other Thinkpad T42 touchpads.
The question has been asked here and there, but usually those questions are left unanswered.

I wonder what numbers I should use with synclient...

Parameter settings:
LeftEdge = 1752
RightEdge = 5192
TopEdge = 1620
BottomEdge = 4236
FingerLow = 25
FingerHigh = 30
FingerPress = 256
...
EmulateTwoFingerMinZ = 282
EmulateTwoFingerMinW = 7
...
MinSpeed = 1
MaxSpeed = 1.75
AccelFactor = 0.0398089
...
 
Old 11-17-2012, 10:09 AM   #14
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Sabayon, Mint, Puppy, Mageia, Slackware
Posts: 348

Original Poster
Rep: Reputation: 34
Aha, xserver-xorg-input-synaptics 1.5.99.902-0ubuntu5
seemed to tame the touchpad a lot.
It's still not perfect, but much more usable.

Last edited by turboscrew; 11-17-2012 at 10:35 AM.
 
Old 11-18-2012, 06:57 AM   #15
SteveThePirate87
Member
 
Registered: Jul 2012
Location: Glasgow, UK
Distribution: Mint 16 and Open Suse 13.1
Posts: 64

Rep: Reputation: Disabled
Good good, glad you got to the bottom of that problem. Just out of curiosity, did you ever try the touchpad with another distribution or just Linux Mint?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't use touchpad in KDE like I do in Gnome and MATE, what settings control it? k3lt01 Debian 14 11-08-2012 02:19 AM
mint 13 mate usmclenny Linux - Newbie 1 08-09-2012 01:38 AM
Jumpy/laggy touchpad and suspend idiosyncrasies. tonyisnt Linux - Laptop and Netbook 2 08-11-2009 04:56 PM
touchpad jumpy with 2.6.6 tjal Linux - Laptop and Netbook 8 06-09-2004 10:39 AM
Can someone help me with a jumpy mouse/touchpad that moves on its own? Kramer Linux - Laptop and Netbook 2 02-20-2004 11:08 PM


All times are GMT -5. The time now is 11:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration