LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Making "undetected resolutions" stick ??? (http://www.linuxquestions.org/questions/linux-desktop-74/making-undetected-resolutions-stick-4175470399/)

krax 07-21-2013 01:12 PM

Making "undetected resolutions" stick ???
 
After installing Xorg-X11 i found out that my Monitor resolution [1600*900 60] wasn't there. After searching and asking in irc channel i found this way:

Code:

creating with cvt
cvt 1600 900

1600x900 59.95 Hz (CVT 1.44M9) hsync: 55.99 kHz; pclk: 118.25 MHz
Modeline "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync

Code:

making
 xrandr --newmode "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync

Code:

Adding

xrandr --addmode VGA1 "1600x900_60.00"

Code:

Changing

 xrandr --output VGA1 --mode "1600x900_60.00"

Note: after restart all of the above procedures will lost.

in the arch linux wiki https://wiki.archlinux.org/index.php...ges_persistent says a way to make it stick and i did it is my /etc/X11/xorg.conf

Code:

Section "Device"
  Identifier  "Intel Xeon"
  Option      "Monitor-VGA1" "VGA screen"
EndSection
Section "Monitor"
  Identifier  "VGA screen"
  Modeline          "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -Hsync +Vsync
  Option      "PreferredMode" "1600x900"
EndSection
Section "Screen"
    Identifier      "Primary Screen"
    Device          "Intel Xeon"
    DefaultDepth    24
    SubSection "Display"
        Depth          24
        Modes  "1600x900"
    EndSubSection
EndSection

But there is no use after all this work. the restart will undo all the work. even the 1600*900 will disappear from the xrandr command output.
How could i make it Persistent


also here is My xorg log: http://paste.ubuntu.com/5897707/

mlslk31 07-23-2013 08:54 PM

Judging by the link you gave, you might change the PreferredMode option to "1600x900_60.00" and try again.

Otherwise, give an idea of what you're trying, and maybe somebody can help. The procedure for doing this has changed a little bit over the years. Last time I had to do this, I made a Modes section "ModesToUse" with all of the Modelines I wanted to use, then specified in the Monitor section something like UseModes "ModesToUse". Don't try this idea quite yet.

Xorg won't use a mode if it thinks your monitor can't handle it. If you can find the horizontal sync and vertical refresh ranges of your monitor and specify them in the Monitor section, it will increase your chances of being able to use certain modes. Sometimes, that can be found by runing `Xorg -configure`, starting X once, then looking at your Xorg.0.log file. Really, though, if you can find the book or PDF that goes with your monitor, the numbers are most convenient to get from there.

mlslk31 07-23-2013 09:03 PM

Oh, I forgot a couple of things. First, make sure your Xorg.conf is in the correct place (on Slackware, it's /etc/X11/xorg.conf). Second, to see what resolutions are being recognized, you can fire up xvidtune and click the Next and Prev buttons to iterate through the modes. Sometimes, you have to specify the modes to use in the Display section, and it's best to start with the mode you want to use first, then lower resolutions in descending order.


All times are GMT -5. The time now is 10:00 PM.