LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 02-21-2009, 01:12 PM   #1
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,557
Blog Entries: 28

Rep: Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178
Make ggcalctool start in Eng(ineering) mode?


Hello :smile:

Is it possible to make gcalctool (5.22.3) start in Eng(ineering) mode?

Best

Charles
 
Old 02-21-2009, 03:45 PM   #2
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,153

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
The gcalctool should restart in whatever view mode was selected when you last closed it.
 
Old 02-22-2009, 07:48 AM   #3
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,557
Blog Entries: 28

Original Poster
Rep: Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178
Thanks P

Helpful to know how it should behave and the behaviour you describe would be nice. Several other settings are remembered from the last session, including X and Y positions. What system(s) are you on? I'm on ubuntu 8.04.2.

There is a ~/.gconf/apps/gcalctool/%gconf.xml file which included
Code:
<entry name="display" mtime="1235300629" type="string">
        <stringvalue>FIX</stringvalue>
</entry>
Setting that to ENG did not change gcalctool's initial mode. vim unexpectedly reported that %gconf.xml had changed when trying to save an edit; this when gcalctool was not running. ???

Wnen gconf-editor->apps->gcalctool was used to set display it was persistent; after quitting gconf-editor and restarting, the value was the same but was not written to %gconf.xml and did change gcalctool's initial mode.

Perhaps gcalctool in the 5.22.3-0ubuntu0.1 package has been built to ignore the usual display configuration but the full configuration utilities are left in place, with the display part ineffective. This would be consistent with the "dumbing down" design philosophy of ubuntu/GNOME.

I started to install gcalctool-5.24.3.1 direct from http://ftp.gnome.org/pub/GNOME/sourc...24.3.1.tar.bz2 but gave up because it required a later version of intltool and I was worried that might cause breakage. Was I being over cautious?

The following is probably a red herring (hence the colour!) but is included for completeness.

Wnen gconf-editor->apps->gcalctool was used to set display to ENG as the default it gave error message "The application "gconf-editor" attempted to change an aspect of your configuration that your system administrator or operating system vendor does not allow you to change. Some of the settings you have selected may not take effect, or may not be restored next time you use the application." with details "No database available to save your configuration: Unable to store a value at key '/apps/gcalctool/display', as the configuration server has no writable databases. There are some common causes of this problem: 1) your configuration path file /etc/gconf/2/path doesn't contain any databases or wasn't found 2) somehow we mistakenly created two gconfd processes 3) your operating system is misconfigured so NFS file locking doesn't work in your home directory or 4) your NFS client machine crashed and didn't properly notify the server on reboot that file locks should be dropped. If you have two gconfd processes (or had two at the time the second was launched), logging out, killing all copies of gconfd, and logging back in may help. If you have stale locks, remove ~/.gconf*/*lock. Perhaps the problem is that you attempted to use GConf from two machines at once, and ORBit still has its default configuration that prevents remote CORBA connections - put "ORBIIOPIPv4=1" in /etc/orbitrc. As always, check the user.* syslog for details on problems gconfd encountered. There can only be one gconfd per home directory, and it must own a lockfile in ~/.gconfd and also lockfiles in individual storage locations such as ~/.gconf"

I worked my way through all that lot but didn't identify any problem causes.


Best

Charles
 
Old 02-22-2009, 09:34 AM   #4
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,153

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Well, I was on Fedora 10 at the time, which has version 2.24.3. That version, on Fedora, offers a "Scientific" mode, but no "Engineering" mode. (Running KDE, not GNOME, by the way.)

I'm on Fedora 10 right now, so I'll edit this post when I log in to Ubuntu. (I don't have the old 8.04 release, but I'll try it on 8.10 and 9.04.)
 
Old 02-22-2009, 10:13 AM   #5
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,557
Blog Entries: 28

Original Poster
Rep: Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178
Quote:
Originally Posted by PTrenholme View Post
Well, I was on Fedora 10 at the time, which has version 2.24.3. That version, on Fedora, offers a "Scientific" mode, but no "Engineering" mode. (Running KDE, not GNOME, by the way.)
Thanks some more

5.22.3 has a Scientific view (along with Basic, Advanced and Financial) available on the View drop down menu) and Eng, Fix and Sci display modes, available on radio buttons. It starts in the last selected view OK, just not in the last selected display mode.

Best

Charles
 
Old 02-22-2009, 01:21 PM   #6
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,153

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Quote:
Originally Posted by catkin View Post
Thanks some more

5.22.3 has a Scientific view (along with Basic, Advanced and Financial) available on the View drop down menu) and Eng, Fix and Sci display modes, available on radio buttons. It starts in the last selected view OK, just not in the last selected display mode.

Best

Charles
Sorry, I misunderstood the problem.

So, now I'm on Ubuntu 9.04 in GNOME, with gcalctool 5.25.91, and it has exactly the same behaviour as you describe for 5.22.3.

Let me see if I can change the XML file . . .

Weird! I tried this script to no avail:
Code:
#!/bin/bash
dbg=yes
xml=~/.gconf/apps/gcalctool/%gconf.xml
[ -n $dbg ] && ls -l $xml && grep -A 1 display $xml
cat $xml | sed 's/>FIX</>ENG</' > $xml
[ -n $dbg ] && echo && ls -l $xml && grep -A 1 display $xml
gcalctool &
disown
Clearly gcalctool "fixes" the FIX when it starts.

I reported the problem to the Ubuntu maintainers, but I suspect it's a "feature" of the tool, not a "bug."

<edit>
O.K., back on Fedora 10, and I see the same behavior. That, I think, increases the likelihood that it's a "feature"of gcalctool.

Sorry. Perhaps you could patch the source code you've got and submit it as a bug fix.
</edit>

Last edited by PTrenholme; 02-22-2009 at 01:34 PM.
 
Old 02-23-2009, 01:33 PM   #7
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,557
Blog Entries: 28

Original Poster
Rep: Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178
Quote:
Originally Posted by PTrenholme View Post
Sorry, I misunderstood the problem.
[snip]
Perhaps you could patch the source code you've got and submit it as a bug fix.
</edit>
No problem, P . Thanks for working with me on this.

I looked at the code as you suggested but it was too complex for my aged C knowledge so I submitted a bug report, 572880, about "display" being present in the configuration mechanisms but ineffective and an enhancement request, 572881, to have the "display" setting made persistent and configurable.

Best

Charles
 
  


Reply

Tags
gcalctool, mode


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to make the cursor in normal mode and insert mode look defferent? tianlijian Linux - Newbie 4 04-07-2009 04:36 AM
xine eng installation muvva_srikanthreddy Suse/Novell 0 07-16-2007 12:37 PM
Dictionary (English-Danish) dict-freedict-dan-eng TroelsSmit Linux - Newbie 0 06-02-2004 05:40 PM
eng to eng dictionary is in need~!~!~! demmylls Linux - General 0 10-11-2003 03:16 PM


All times are GMT -5. The time now is 08:22 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration