LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices



Reply
 
Search this Thread
Old 04-24-2013, 02:26 PM   #1
Foxblood
LQ Newbie
 
Registered: Apr 2005
Location: Dublin, Ireland
Distribution: Arch, Sabayon
Posts: 9

Rep: Reputation: 0
Lua with Conky gives unwanted background color


I've Googled and ransacked the forum looking for an answer. I have Conky with lua on Arch KDE4 and I cannot run both together without creating an unwanted background. After getting sidetracked with KDE4 transparency considerations, I discovered that if I start Conky without Lua, I can get proper transparency. If I start Conky with Lua enabled I get a background color. The Lua script doesn't seem to have any background settings. I'm not sure what files are relevant to post, the conkyrc and or the Lua script, which is quite large. I'm reasonably au fait with Conky but this is the first Conky I cannot get to function correctly. My basic question is how to use Lua without starting a background color. Here is where I got the original files http://www.linuxandlife.com/2012/06/get -your.html . Of course, I can post the relevant Lua file if necessary but, as I mentioned, it is quite large and I'm not clear on forum rules regarding posting large files of this type. Here's how Conky starts Lua:

lua_load ~/.conky/avi9526_conky.lua
lua_draw_hook_pre Widgets

Thanks for your time.
 
Old 04-26-2013, 10:27 AM   #2
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Undecided
Posts: 3,618
Blog Entries: 1

Rep: Reputation: Disabled
Code:
conky -v
output please.
You can post large'ish files using [code][/code] markups (The "#" in editor.) or just click the link under "Code:" for valid examples.

definitely post the conkyrc using [code][/code] and attach the .lua if it's that large (rename it to .txt before uploading).

Last edited by Habitual; 04-26-2013 at 10:29 AM.
 
Old 04-28-2013, 10:10 AM   #3
Foxblood
LQ Newbie
 
Registered: Apr 2005
Location: Dublin, Ireland
Distribution: Arch, Sabayon
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks for your interest but I managed to solve this with assistance from another forum. Changing line 1236 of the Lua script to cairo_set_source_rgba(CairoContext, 0.6, 0.61, 0.62, 0.0) did the trick. Thanks again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Howto change black background colour in conky with transparency color in slackware 14 imanulyaqin Linux - Desktop 2 12-19-2012 12:52 AM
Add Battery % to Conky lua? TheAtheistReverend Linux - Newbie 2 11-10-2012 12:15 PM
LXer: Configure conky-Lua in Ubuntu (11.10 & 12.04), Fedora, debian and LinuxMint | Howto Conky LXer Syndicated Linux News 0 03-06-2012 01:40 PM
Conky + lua flyinggeorge Linux - Software 6 03-05-2012 09:47 PM
Trying to get Lua to work with Conky AbsoluteZ3r0 Linux - Software 0 08-17-2011 11:01 AM


All times are GMT -5. The time now is 01:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration