LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 08-30-2013, 07:37 AM   #1
\/4A
Member
 
Registered: Aug 2012
Posts: 112

Rep: Reputation: Disabled
Logging in with Openbox issues


Hello,

I' ve just installed Fedore 19 LXDE and while I can log into my user a/c using LXDE with no problem, selecting Openbox as the desktop does bring issues: it just gives a blank screen.

Would really appreciate some guidance on how I can go about slving this pls.
 
Old 08-31-2013, 01:42 AM   #2
descendant_command
Member
 
Registered: Mar 2012
Posts: 761

Rep: Reputation: 159Reputation: 159
That's openbox
What were you expecting?
 
Old 08-31-2013, 07:37 AM   #3
\/4A
Member
 
Registered: Aug 2012
Posts: 112

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by descendant_command View Post
That's openbox
What were you expecting?
HUH?? Openbox is just a blank black screen with no icons or panels? Well then is it used for troubleshooting or something?
 
Old 08-31-2013, 09:07 AM   #4
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu
Posts: 1,210

Rep: Reputation: 238Reputation: 238Reputation: 238
No, openbox is just a window manager - it doesn't put icons on the screen, it doesn't come with panels. That's why pcmanfm and lapanel are included in LXDE
 
1 members found this post helpful.
Old 09-01-2013, 04:45 PM   #5
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware
Posts: 264

Rep: Reputation: 1
Quote:
Originally Posted by RockDoctor View Post
No, openbox is just a window manager - it doesn't put icons on the screen, it doesn't come with panels. That's why pcmanfm and lapanel are included in LXDE
That's actually the brilliant part of openbox. You can set it up to start your panel, and your compositing, and everything in the "autostart" file. I'm currently using it on slackware 14 and it's going well, except...

My issue is that nothing in my autostart is actually being called. I set it up according to the openbox wiki:

Code:
##Programs that will run after OB starts
#set wallpaper
hsetroot ~/pictures/my_wallpaper.jpg &

#everyone needs compositing!
xcompmgr -c -t-5 -l-5 -r-5 -o.55 -f &

#latin characters aren't enough!
scim -d &

#a simple panel
tint2 &
Not sure why it isn't working.
 
Old 09-02-2013, 06:49 AM   #6
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu
Posts: 1,210

Rep: Reputation: 238Reputation: 238Reputation: 238
I'm not sure either, so I booted up Fedora 19 :
1. modified my .xinitrc to start openbox (and a terminal, just-in-case) instead of LXDE:
Code:
~$ cat .xinitrc
#!/bin/sh
#exec startlxde
lxterminal &
exec openbox-session
2. created a simple .config/openbox/autostart file and made it executable:
Code:
~$ cat .config/openbox/autostart 
# test of autostart
lxpanel -p LXDE &
The above setup works for me (F19 booting to the CLI; then running startx).
HTH
 
Old 09-02-2013, 09:17 AM   #7
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware
Posts: 264

Rep: Reputation: 1
Quote:
Originally Posted by RockDoctor View Post
I'm not sure either, so I booted up Fedora 19 :
1. modified my .xinitrc to start openbox (and a terminal, just-in-case) instead of LXDE:

2. created a simple .config/openbox/autostart file and made it executable:

The above setup works for me (F19 booting to the CLI; then running startx).
HTH
I boot to cli and run startx as well. Haven't gotten my initial configurations done to the point where I feel comfortable enough booting right to a display manager.

That's a lot simpler than my .xinitrc: I have some settings regarding keymaps and resources at the top, then it had some code in the middle to create a default user dir and populate it if one didn't exist. I commented that out, and this block:
Code:
if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
  exec ck-launch-session dbus-launch --exit-with-session openbox
else
and it works perfectly well. Below that block is the exec openbox-session line.

Now I don't know which chunk messed up the autostart loading, any ideas?
 
Old 09-02-2013, 11:22 AM   #8
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu
Posts: 1,210

Rep: Reputation: 238Reputation: 238Reputation: 238
All I have is a guess. In your original, does changing
Code:
if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
  exec ck-launch-session dbus-launch --exit-with-session openbox
to
Code:
if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
  exec ck-launch-session dbus-launch --exit-with-session openbox-session
give you a working setup?
 
Old 09-03-2013, 07:39 PM   #9
slacker_
Member
 
Registered: Aug 2013
Distribution: Debian, Slackware
Posts: 264

Rep: Reputation: 1
Quote:
Originally Posted by RockDoctor View Post
All I have is a guess. In your original, does changing
Code:
if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
  exec ck-launch-session dbus-launch --exit-with-session openbox
to
Code:
if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
  exec ck-launch-session dbus-launch --exit-with-session openbox-session
give you a working setup?
I'll have to try that when my X is working again. I was doing some kernel configuration following the slackbook tutorial. In it it says to merge your root and user Xauthorities so that root can launch X apps when you're under su. Well, now my startx is failing and I don't know how to recover that. I have a thread regarding that issue though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] "Permission denied" when Openbox tries to execute autostart.sh in ~/.config/openbox alarazr Linux - Software 4 10-04-2012 03:50 PM
Openbox autostart.sh and setting alias on openbox start Jelloir Linux - Desktop 1 07-03-2011 03:56 AM
having issues logging into this site unix1adm Linux - Newbie 2 03-23-2010 02:02 PM
BIND logging issues - doesn't seem to want to log laggerific Linux - Software 2 10-23-2006 02:08 PM
BIND - logging issues thebee Linux - Software 0 06-23-2003 12:20 PM


All times are GMT -5. The time now is 05:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration