LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Linux Mint - After update network settings do not work (http://www.linuxquestions.org/questions/linux-desktop-74/linux-mint-after-update-network-settings-do-not-work-4175437341/)

themrrobert 11-15-2012 04:48 PM

Linux Mint - After update network settings do not work
 
In the control center, the only option under Internet and Network is network proxy, which is of no use to me.

Under System, there is a Network Tools option, and here I can see the connections available on my machine (lo, eth0 and wlan0)

I am trying to disable the wlan0 to save power and just keep it off, and I would like to be able to configure the eth0 connection... okay sounds easy enough right..?

Well clicking on configure after selecting a device opens the "Network Connections" dialog (same one from Other section of CC).

However: there are no connections available! Under wired, when trying to add a connection, all the options are greyed out. I am wondering if possibly running Network connections as root would help, but there is no way to run it elevated from the control center.


Am i doing something wrong?

Thanks!

(it seemed to work previously... however that was thru the gnome-panel->network option, it showed all of the wireless networks available and it was quite a pretty setup, but this dialog no longer works when running gnome, it says
"The system network services are not compatible with this version." but previously i could see both the wire and wireless connections, and modify the settings (although it wouldn't make changes permanent, i think because it was a user account)

mdlinuxwolf 11-18-2012 01:34 PM

Quote:

Originally Posted by themrrobert (Post 4830381)
In the control center, the only option under Internet and Network is network proxy, which is of no use to me.

Under System, there is a Network Tools option, and here I can see the connections available on my machine (lo, eth0 and wlan0)

I am trying to disable the wlan0 to save power and just keep it off, and I would like to be able to configure the eth0 connection... okay sounds easy enough right..?

Well clicking on configure after selecting a device opens the "Network Connections" dialog (same one from Other section of CC).

However: there are no connections available! Under wired, when trying to add a connection, all the options are greyed out. I am wondering if possibly running Network connections as root would help, but there is no way to run it elevated from the control center.


Am i doing something wrong?

Thanks!

(it seemed to work previously... however that was thru the gnome-panel->network option, it showed all of the wireless networks available and it was quite a pretty setup, but this dialog no longer works when running gnome, it says
"The system network services are not compatible with this version." but previously i could see both the wire and wireless connections, and modify the settings (although it wouldn't make changes permanent, i think because it was a user account)

Find the icon you are using for the network connections. Right click on it and find properties. You will see the actual exact command that is used to open that function.

Now open up a terminal and log in as root. Running as root, set up your network.

For example, this is my package manager's actual command. This is not for networking, just an example of what one looks like.

/usr/share/applications/synaptic.desktop /usr/sbin/synaptic

This is probably your network gui. This is wicd.

wicd-gtk --no-tray

You might, however, have another one. Now that you're running as root double check it and make sure that all users have the right to use that connection and that it connects automatically, remembering the password and so on.


All times are GMT -5. The time now is 11:48 AM.