LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices



Reply
 
Search this Thread
Old 03-27-2013, 08:40 AM   #1
blaubel
LQ Newbie
 
Registered: Mar 2013
Posts: 2

Rep: Reputation: Disabled
Linux freezes randomly


Hi all,

My linux desktop freezes randomly. I mean it stop all process, It doesn't response any key event, It even doesn't change the led from the keyboard when I press lock keys. I tried with and withoud NVIDIA official drivers. I remove 2 of four RAM modules, because I realized that It generate incompatibility problems, since then Windows 7, works fine, but linux don't.

I also tried Open Suse but the problem was that the system gets unresponsive from keyboard and mouse (this problem was different from previous because, in this case I could see the torrent downloading). I don't know if this issue can be related with the previous one.

Can anyone provide information about whit issue?
Thank you very much.
 
Old 03-27-2013, 08:52 AM   #2
Ion Silverbolt
Member
 
Registered: Sep 2004
Distribution: Gentoo/Xfce, Manjaro/Xfce, SolydXK
Posts: 194

Rep: Reputation: 36
Linux is very sensitive to memory problems, which I would bet is your problem. The first step you need to do is run memtest to make sure your memory is ok. You should be able to run it from your OpenSuse boot CD. Choose memtest from the boot menu and let memtest run to 100% through at least one pass. Twice maybe if you don't get errors on the first pass.

If you don't get any errors, post back. Right now, a memory problem is your prime suspect.

When you post back, also include your system specs including the amount of memory you have now. It could be you're hitting the swap file a lot if you're running with a low amount of memory because of the modules you removed.

Last edited by Ion Silverbolt; 03-27-2013 at 08:57 AM.
 
1 members found this post helpful.
Old 03-27-2013, 09:16 AM   #3
pan64
Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 5,169

Rep: Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364Reputation: 1364
yes, probably a memory issue. Please post your system spec as it was mentioned. Also try to check temp sensors and hard disks (especially your system drive). Try to boot from live CD
 
1 members found this post helpful.
Old 03-27-2013, 03:26 PM   #4
blaubel
LQ Newbie
 
Registered: Mar 2013
Posts: 2

Original Poster
Rep: Reputation: Disabled
Thank you for your responses

I ran the memtest with two differents couples of memory modules with the same result:

http://imageshack.us/photo/my-images...327201116.jpg/

The test failed for both couples on 44%. It is very strange that both couples have problems so It can be posible that it is a chipset issue?

And finally, why Windows run without troubles with the same memory?
 
Old 03-27-2013, 09:09 PM   #5
Ion Silverbolt
Member
 
Registered: Sep 2004
Distribution: Gentoo/Xfce, Manjaro/Xfce, SolydXK
Posts: 194

Rep: Reputation: 36
Linux uses memory differently than Windows, and for whatever reason, it is more sensitive to bad memory. I'm sure problems would eventually arise in Windows too. Maybe programs crashing or other anomalies. It's definitely a good idea to get the problem taken care of to be on the safe side.

Check your motherboard manual about memory arrangements. Some boards work best if certain dimm slots are occupied in a certain order. Also, look up CMOS settings. You may be able to get the memory stabilized by increasing the memory latency. This is especially necessary if you perhaps have your system overclocked. Sometimes memory can be detected at the wrong speed too. Increasing the latency can help with that. (For example, set memory to CAS Latency 3 if it is set to CL2).
 
Old 03-27-2013, 10:52 PM   #6
Ztcoracat
Senior Member
 
Registered: Dec 2011
Distribution: Slackware, Mint & CentOS
Posts: 3,435
Blog Entries: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by blaubel View Post
Hi all,

My linux desktop freezes randomly. I mean it stop all process, It doesn't response any key event, It even doesn't change the led from the keyboard when I press lock keys. I tried with and withoud NVIDIA official drivers. I remove 2 of four RAM modules, because I realized that It generate incompatibility problems, since then Windows 7, works fine, but linux don't.

I also tried Open Suse but the problem was that the system gets unresponsive from keyboard and mouse (this problem was different from previous because, in this case I could see the torrent downloading). I don't know if this issue can be related with the previous one.

Can anyone provide information about whit issue?
Thank you very much.
During the freeze try:
Ctrl+Alt+F2 that should get you to the log in screen.

If it continues to freeze it (could) be a dust issue or fan issue-

Is the side of the tower where the motherboard is warmer than usual?
If so, you can run this cmd and keep an eye on your systems temp:
Quote:
sensors -f | grep -i temp

Last edited by Ztcoracat; 03-27-2013 at 10:57 PM.
 
Old 03-28-2013, 04:50 AM   #7
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
One or more of the RAM sticks is bad. It's likely that just one of them is bad, so try one a time with memtest86+.
 
Old 04-02-2013, 05:37 PM   #8
Nbiser
Member
 
Registered: Oct 2012
Location: Maryland
Distribution: Fedora, Slackware, Debian, Ubuntu, Knoppix, Helix,
Posts: 290
Blog Entries: 7

Rep: Reputation: 43
A number of steps that you should try: (You may have already done some of them)

1. Run memtest

2. If RAM passes the test, go to step 4; if RAM doesn't pass go to 3.

3. Replace all RAM

4. Check Linux compatability with your PC. Some PCs just don't work that well with Linux!

And remember, google is your friend, research, research and more research!

Last edited by Nbiser; 04-02-2013 at 05:38 PM. Reason: clarity
 
Old 04-03-2013, 07:18 PM   #9
Ztcoracat
Senior Member
 
Registered: Dec 2011
Distribution: Slackware, Mint & CentOS
Posts: 3,435
Blog Entries: 1

Rep: Reputation: Disabled
RAM is not as expensive as it used to be.
I was just at this store yesterday and they have good products.

http://www.microcenter.com/product/2..._Memory_Module
http://www.microcenter.com/product/3..._Memory_Module

You mentioned:
Quote:
I tried with and withoud NVIDIA official drivers
If it were my computer I would purchase a card other than Nvidia-

Maybe the new Radeon (just a suggestion)
http://www.microcenter.com/product/4...x16_Video_Card

Good Luck!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Computer freezes randomly odiseo77 Linux - Hardware 30 03-18-2012 10:20 PM
Linux randomly freezes. So does Pacman, occasionally. lupusarcanus Linux - Software 5 05-01-2011 01:58 AM
System Freezes Randomly Woodsman Linux - Hardware 5 04-17-2011 10:37 AM
OpenSUSE 11.0 randomly freezes VonMagnum Suse/Novell 1 10-16-2008 12:00 AM
Suse 10.1 freezes randomly preeth26 Linux - Software 20 11-13-2006 03:56 AM


All times are GMT -5. The time now is 01:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration