LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
LinkBack Search this Thread
Old 08-01-2008, 11:36 AM   #16
mostlyharmless
Senior Member
 
Registered: Jan 2008
Distribution: Slackware 14.1 (multilib) with kernel 3.13.2
Posts: 1,467
Blog Entries: 10

Rep: Reputation: 142Reputation: 142

I did some poking around in google but couldn't find a bios manual for your specific model. Doesn't look like Gateway keeps those things on record for their legacy products. However, I'm surprised that there isn't a LBA/auto option anywhere in the bios, as the Intel site seemed to indicate that it was an option. Boards of this era (mine is of similar vintage) typically did not support LBA2 out of the box. For Windows, typically a driver from Intel or Microsoft (XP SP1 and after) provided support > 128 G. Of course, once you get past BIOS and boot the system, slackware, like Windows, will have no problem supporting the hardware. You might try some lilo options like "lba32" or "linear" if you want to go back to lilo, I'm not sure about the relevant options for grub.

Last edited by mostlyharmless; 08-01-2008 at 12:00 PM.
 
Old 08-02-2008, 01:01 AM   #17
MafiaTux
LQ Newbie
 
Registered: Aug 2008
Location: Portland, Oregon United States
Distribution: Mandriva, Ubuntu, Goblinx, and linux xp
Posts: 20

Rep: Reputation: 0
Sounds like some kind of windows problem
 
Old 08-02-2008, 02:26 AM   #18
DragonM15
Member
 
Registered: Sep 2003
Location: USA
Distribution: Slackware (Multiple Versions)
Posts: 455

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by MafiaTux View Post
Sounds like some kind of windows problem
Umm. Not quite sure how you mean, considering windows isnt started up yet, nor have I started it in the last few days... Yes windows did take control when I "installed" lilo to the master boot record of hda, however after I installed grub it gave me another error message. So what exactly do you mean its a "windows problem"?

DragonM15
 
Old 08-02-2008, 06:32 AM   #19
Fadoksi
Member
 
Registered: Apr 2006
Location: Finland
Distribution: Ubuntu, Gentoo, Debian
Posts: 88

Rep: Reputation: 15
Quote:
Fadoksi, I am highly considering using grub. I will have to do some research on installing it. Have you had any experience installing grub from a system that originally comes with lilo?
When I had Slackware some time in the past, I replaced LILO with GRUB since I like it more. I had no problems with it. If the BIOS causes the problem maybe a BIOS upgrade would be a good idea.
 
Old 08-02-2008, 11:11 AM   #20
mostlyharmless
Senior Member
 
Registered: Jan 2008
Distribution: Slackware 14.1 (multilib) with kernel 3.13.2
Posts: 1,467
Blog Entries: 10

Rep: Reputation: 142Reputation: 142
I didn't see any support, including BIOS upgrade for his system on Gateway's site.
 
Old 08-02-2008, 04:21 PM   #21
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 6,697
Blog Entries: 51

Rep: Reputation: 1239Reputation: 1239Reputation: 1239Reputation: 1239Reputation: 1239Reputation: 1239Reputation: 1239Reputation: 1239Reputation: 1239
I am a dozy **** (as we say in Oldham), I should have noticed lba32 was missing from your lilo.conf, it's recommended to put it in the global options. Although I wouldn't have known whether that was causing the problem.
 
Old 08-08-2008, 11:41 AM   #22
DragonM15
Member
 
Registered: Sep 2003
Location: USA
Distribution: Slackware (Multiple Versions)
Posts: 455

Original Poster
Rep: Reputation: 31
I am not sure where to go from here. I have looked through the bios multiple times trying to find something that I didnt see the time before and have come up empty handed. I added lba32 to my lilo.conf and reloaded lilo, but it still gives me the "L 01 01 01" error. My lilo.conf now looks like this:
Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
# Append any additional kernel parameters:
append=" vt.default_utf8=0"
boot = /dev/hda

# Boot BMP Image.
# Bitmap in BMP format: 640x480x8
  bitmap = /boot/slack.bmp
# Menu colors (foreground, background, shadow, highlighted
# foreground, highlighted background, highlighted shadow):
  bmp-colors = 255,0,255,0,255,0
# Location of the option table: location x, location y, number of
# columns, lines per column (max 15), "spill" (this is how many
# entries must be in the first column before the next begins to
# be used.  We don't specify it here, as there's just one column.
  bmp-table = 60,6,1,16
# Timer location x, timer location y, foreground color,
# background color, shadow color.
  bmp-timer = 65,27,0,255

# Standard menu.
# Or, you can comment out the bitmap menu above and
# use a boot message with the standard menu:
#message = /boot/boot_message.txt

# Wait until the timeout to boot (if commented out, boot the
# first entry immediately):
prompt
# Timeout before the first entry boots.
# This is given in tenths of a second, so 600 for every minute:
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
lba32
change-rules
  reset
# VESA framebuffer console @ 1024x768x256
# vga = 773
# Normal VGA console
vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Windows bootable partition config begins
other = /dev/hda1
  label = Windows
  table = /dev/hda
# Windows bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/hda3
  label = Linux
  read-only
# Linux bootable partition config ends
Should the lba32 option be put somewhere else, or is it fine where it is at?

Thanks,
DragonM15
 
Old 08-08-2008, 02:03 PM   #23
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 6,697
Blog Entries: 51

Rep: Reputation: 1239Reputation: 1239Reputation: 1239Reputation: 1239Reputation: 1239Reputation: 1239Reputation: 1239Reputation: 1239Reputation: 1239
I put it just after reset, before all the framebuffer entries. Not sure if it matters, as long as it's in the global options.
 
Old 08-08-2008, 03:19 PM   #24
mostlyharmless
Senior Member
 
Registered: Jan 2008
Distribution: Slackware 14.1 (multilib) with kernel 3.13.2
Posts: 1,467
Blog Entries: 10

Rep: Reputation: 142Reputation: 142
Did you try "linear"?
 
Old 08-13-2008, 01:58 PM   #25
DragonM15
Member
 
Registered: Sep 2003
Location: USA
Distribution: Slackware (Multiple Versions)
Posts: 455

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by mostlyharmless View Post
Did you try "linear"?
I tried linear, lba32, and I also moved it up to in between the framebuffer entries and reset. All no no avail. I still receive the
L 01 01 01 01.... error.

I am convinced at this point that the problem exists in the bios, but I have looked and looked and can't find anything that looks wrong. I find it kinda wierd that I have never had this problem on ANY other computer I have installed linux on. Anyways, I will take another look through the bios for the heck of it and hope I can see something.

DragonM15
 
Old 08-13-2008, 02:12 PM   #26
mostlyharmless
Senior Member
 
Registered: Jan 2008
Distribution: Slackware 14.1 (multilib) with kernel 3.13.2
Posts: 1,467
Blog Entries: 10

Rep: Reputation: 142Reputation: 142
grub again?

Just an idea, since nothing else is working..

Going back to Grub, I wonder whether the problem is at Stage 1.5 or 2; rather than try grubconfig (which I've had problems with), try making a grub boot floppy or use SuperGrub (http://www.supergrubdisk.org )and install grub straight from the grub prompt. If nothing else, the grub shell commands about the geometry might be helpful or illuminating.
 
Old 08-15-2008, 05:52 PM   #27
bashyow
Member
 
Registered: Jun 2008
Location: uk
Distribution: Slackware 12.1, AND IM LOVIN EVERY MINUTE OF IT, JERRY! :D
Posts: 122

Rep: Reputation: 15
I had this problem a while back. I think its an MBR problem, I just cant remember what I did to fix it

but I dont think its logical to install grub (and you say you have done that, and it still wont work) lilo works perfectly well, somethings just gone a bit wrong in this case.

as a last resort I think if you re-installed slackware it would probably solve the problem.

I think that may have been what I did in the end.

Last edited by bashyow; 08-15-2008 at 05:58 PM.
 
Old 10-11-2008, 11:01 PM   #28
BillyGalbreath
Member
 
Registered: Nov 2005
Location: Houston Texas
Distribution: Debian Sid
Posts: 379

Rep: Reputation: 31
I have no experience with LILO, but seeing as you received a GRUB error 17 i know what the problem is. Your hard drive order is all screwey (or not). I've come across this many many times and the solution is almost always the same. It's rather difficult to explain this, but here's my attempt:

BIOS is reporting your hard drives to GRUB as:

hd0
hd1
hd2

GRUB sees these drives in the same manor, which is why GRUB started to load (the MBR for the correct drive was obviously found). However, the GRUB menu.lst config file reports the drives as they're /dev name:

hda
hdb
hdc

Here's the neat part that angers me. Not always does hda = hd0 etc etc. This is when errors start to happen. GRUB from MBR is looking for /boot in the wrong place because the naming scheme got all whack somewhere during installation/probing. Solution: Manually locate /boot and re-establish GRUB's understanding of its location.

Here's how:

As stated before, make a GRUB boot floppy disk and boot up the computer with this floppy (if no floppy drive is available i think a USB flashdrive might work, but i haven't tried it). You will be presented with the GRUB prompt.

From the GRUB prompt you need to determine which drive is what (hd0, hd1, etc) including their partitions (hd0,0 hd0,1 etc). You need to get a clear understanding and pin point your /boot directory (it's in / partition unless you gave /boot its own partition) and you also need to pinpoint which drive's MBR contains GRUB.

Now, let's tell GRUB which partition contains /boot. Example:

root (hd0,1)

Now lets re-setup GRUB in the MBR. Example:

setup (hd0)

That should be it. If you've correctly identified the correct drives & partitions when you reboot GRUB should load. If not, try try again.

Last edited by BillyGalbreath; 10-11-2008 at 11:02 PM.
 
Old 10-12-2008, 02:06 PM   #29
ghost333
LQ Newbie
 
Registered: Oct 2008
Posts: 22

Rep: Reputation: 15
i had the same problem and i remember what i did , since it happen recently
i had the hda1 (with the mbr ofc ) on the primary IDE as a SLAVE
it seems that there was some confusion with the entries and identifications of hda1 since it searched it as Master
so i opened the case and switched from SLAVE TO MASTER the hd and the dvd-r on primary IDE
hope it hlps
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
lilo says, "L 01 01 01" and fdisk says, "Unable to seek on /dev/hda1" clausawits Linux - General 3 12-31-2007 09:33 PM
Displaying "Subscribed Threads" -> new folder "All Folders" JZL240I-U LQ Suggestions & Feedback 5 06-15-2007 06:36 AM
LXer: Displaying "MyComputer", "Trash", "Network Servers" Icons On A GNOME Desktop LXer Syndicated Linux News 0 04-02-2007 08:31 AM
uninstall boot loader "Lilo" install "Grub" sethis Linux - Newbie 6 11-30-2006 09:32 AM
error "Nautilus has no installed viewer capable of displaying directory" fedora_user Linux - Software 9 03-02-2006 04:15 PM


All times are GMT -5. The time now is 07:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration