LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 11-14-2010, 02:22 PM   #1
xp_newbie
Member
 
Registered: Nov 2006
Posts: 86

Rep: Reputation: 16
Question LCD monitor doesn't enter Standby on Lock Screen


When my Ubuntu 8.04 system used to be connected to a CRT monitor, 'Lock Screen' would make the CRT enter Standby after some delay.

This is no longer the case when the same system is connected to a new LCD screen.

I would have thought that this is the monitor's problem, not a Linux one, but when the system boots and waits at the Login screen (GUI), the monitor does enter Standby after a few minutes of inactivity.

To me this suggests a GNOME Desktop issue.

Is there any way to set GNOME to put the monitor into Standby?
 
Old 11-14-2010, 02:44 PM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
It could be a setting in your monitor. However, the Gnome Power Management Manual says this:
Quote:
8.3. 
My monitor is broken and treats DPMS standby and off states as
'no-signal' which leaves the monitor powered on.

You have to change the DPMS suspend mode GNOME Power Manager uses.
Open gconf-editor, and then change the keys
/apps/gnome-power-manager/backlight/dpms_method_ac and
/apps/gnome-power-manager/backlight/dpms_method_battery
to one of the modes that work, e.g. standby, suspend or off.
I found this by clicking on System -> Help and Support, then entering DPMS in a search box. It is not your exact question but the answer may be correct for your question.

Last edited by stress_junkie; 11-14-2010 at 02:46 PM.
 
Old 11-15-2010, 09:57 AM   #3
xp_newbie
Member
 
Registered: Nov 2006
Posts: 86

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by stress_junkie View Post
It is not your exact question but the answer may be correct for your question.
Thank you. As you suspected, modifying these settings didn't really help. I tried:
Code:
sudo gconf-editor
 > apps
   > gnome-power-manager
     > backlight
       > dpms_method_ac:  from 'default' to 'off'
       > idle_brightness: from '30 to '0'
       > idle_dim_time:   from '30 to '1'
But that didn't change a thing. Perhaps additional settings need to be modified.
 
  


Reply

Tags
gnomescreensaver, lcd, screensaver, standby


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg.conf wide screen lcd monitor vishalkhialani Linux - Newbie 3 08-05-2009 01:36 AM
blank screen when set to correct LCD monitor in CentOs5 ufmale Linux - Hardware 1 04-28-2008 04:48 AM
samsung 226bw lcd wide screen monitor on linux tirtildim Linux - Hardware 1 03-16-2007 10:30 AM
analog lcd monitor not working after installing a digital lcd monitor nishlq Linux - Hardware 6 08-18-2006 02:18 PM
SOLVED: picture slighly off-screen on LCD Monitor Ed-MtnBiker Fedora 1 03-27-2004 03:12 PM


All times are GMT -5. The time now is 09:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration