LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Konsole always give SuperUser Konsole - can't get regular shell (http://www.linuxquestions.org/questions/linux-desktop-74/konsole-always-give-superuser-konsole-cant-get-regular-shell-660616/)

checkmate3001 08-05-2008 09:06 AM

Konsole always give SuperUser Konsole - can't get regular shell
 
Hello guys and gals!
Let me give you a little background:
I've got Debian 4 with a KDE Desktop installed.
(Fresh install I might add)

I went into the menu to start up a root konsole (there is typically a regular user shell konsole and a super user konsole selection). I changed some fonts, visible bell, background color, foreground color, and "Save as Default".

Now, even when I try to open just a regular user shell konsole I always get a super user konsole.

It's not a huge problem because I use root a lot to do stuff (setting up, etc) but it bugs the you-know-what out of me. I want to be able to just hit the konsole icon and start typing away as the regular user.

Anyone had this problem? I was looking for a file I could alter to change it all back to normal so I don't have to re-install just for that.

I looked all through the /usr/share/apps/konsole/* files and nothing special there. I may have missed something tho. I tried apt-get remove --purge konsole, and re-installing konsole to see if all the config files would get re-written, but that didn't change a thing.

Any pointers?
Thanks.

David the H. 08-05-2008 09:31 AM

Well, default means default. So set up a regular user profile ("session > new linux console" should give you a regular user console) and then save that as default. Then set up the options you want for the root user separately in the "configure konsole > session" preferences. Finally, when you want to open up a root console, call it up from the Session menu or hold down the new tab button until a similar selection menu pops up.

checkmate3001 08-05-2008 09:48 AM

Yeah, I thought of that too. I opened up konsole (got the super user one) opened a new session and did a "save default". I closed konsole and restarted it. Got the super user konsole again.

What I don't get is that to run konsole as super user the command is:
Code:

konsole --type su
but even if I hit alt+F2 to run a program and just type:
Code:

konsole
I get a super user konsole... wtf?

checkmate3001 08-05-2008 10:00 AM

I just man-handled it. I went into menu editor and forced it to change the type it starts as.
Code:

konsole --type linux
forces konsole to start in a linux console. So now it isn't a super user. HA!
Makes me wish I could smack the thing.

I guess that's also the way to get it to "save default" as a linux console instead of super user konsole. Once I ran "konsole --type linux" and did a "save default" all is back to normal.

stupid user.


All times are GMT -5. The time now is 07:11 PM.