LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices



Reply
 
Search this Thread
Old 08-05-2008, 10:06 AM   #1
checkmate3001
Member
 
Registered: Sep 2007
Location: Folsom, California
Distribution: Debian 4.0 (Etch), Debian 5.0 (Lenny), Ubuntu 8.04
Posts: 301

Rep: Reputation: 32
Konsole always give SuperUser Konsole - can't get regular shell


Hello guys and gals!
Let me give you a little background:
I've got Debian 4 with a KDE Desktop installed.
(Fresh install I might add)

I went into the menu to start up a root konsole (there is typically a regular user shell konsole and a super user konsole selection). I changed some fonts, visible bell, background color, foreground color, and "Save as Default".

Now, even when I try to open just a regular user shell konsole I always get a super user konsole.

It's not a huge problem because I use root a lot to do stuff (setting up, etc) but it bugs the you-know-what out of me. I want to be able to just hit the konsole icon and start typing away as the regular user.

Anyone had this problem? I was looking for a file I could alter to change it all back to normal so I don't have to re-install just for that.

I looked all through the /usr/share/apps/konsole/* files and nothing special there. I may have missed something tho. I tried apt-get remove --purge konsole, and re-installing konsole to see if all the config files would get re-written, but that didn't change a thing.

Any pointers?
Thanks.

Last edited by checkmate3001; 08-05-2008 at 10:08 AM. Reason: typos
 
Old 08-05-2008, 10:31 AM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950
Well, default means default. So set up a regular user profile ("session > new linux console" should give you a regular user console) and then save that as default. Then set up the options you want for the root user separately in the "configure konsole > session" preferences. Finally, when you want to open up a root console, call it up from the Session menu or hold down the new tab button until a similar selection menu pops up.
 
Old 08-05-2008, 10:48 AM   #3
checkmate3001
Member
 
Registered: Sep 2007
Location: Folsom, California
Distribution: Debian 4.0 (Etch), Debian 5.0 (Lenny), Ubuntu 8.04
Posts: 301

Original Poster
Rep: Reputation: 32
Yeah, I thought of that too. I opened up konsole (got the super user one) opened a new session and did a "save default". I closed konsole and restarted it. Got the super user konsole again.

What I don't get is that to run konsole as super user the command is:
Code:
konsole --type su
but even if I hit alt+F2 to run a program and just type:
Code:
konsole
I get a super user konsole... wtf?
 
Old 08-05-2008, 11:00 AM   #4
checkmate3001
Member
 
Registered: Sep 2007
Location: Folsom, California
Distribution: Debian 4.0 (Etch), Debian 5.0 (Lenny), Ubuntu 8.04
Posts: 301

Original Poster
Rep: Reputation: 32
I just man-handled it. I went into menu editor and forced it to change the type it starts as.
Code:
konsole --type linux
forces konsole to start in a linux console. So now it isn't a super user. HA!
Makes me wish I could smack the thing.

I guess that's also the way to get it to "save default" as a linux console instead of super user konsole. Once I ran "konsole --type linux" and did a "save default" all is back to normal.

stupid user.
 
  


Reply

Tags
konsole, root, schema, super, user


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Animating and Customizing the Shell Konsole? oktet Linux - General 2 08-02-2008 03:34 AM
shell konsole prob unixshell101 Linux - Newbie 2 12-25-2007 03:41 AM
Konsole showing regular and bold fonts as the same mcpchandra Fedora 0 09-13-2006 03:24 PM
shell konsole error computer Linux - Newbie 1 08-28-2006 07:42 PM
Konsole... HELP! need to revert to regular text. Slyder42 Fedora 3 08-13-2004 11:15 AM


All times are GMT -5. The time now is 03:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration