LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 06-17-2009, 12:39 AM   #1
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
Question Konqueror: 'Removable Media' icons have changed to 'Hard Disk icons. Why? How to Fix?


Maybe it's late and my thought process isn't quite right, but I can't figure out why this is..

The only things I have edited lately, in relation to the various media devices I have connected, are my udev rules, and the fstab file.

This is Slackware 11, kernel=2.6.30, KDE-3.5.4

Where this started: I have had a little Kingston USB flash thingy for some time (many months), and ever since having gotten it configured with a udev rule to always give it the same device node, and an fstab line to go along with it, it has worked great (and still *works* great) and it has always been shown in Konquerors 'Storage Media' page as a little removable media icon, complete with 'Safely Remove blah blah..' and it mounts, unmounts, etc..

I have updated my kernel a few times along the way from then till now, but I don't recall the kernel ever influencing how my devices are shown in Konqueror. (LOL, maybe it just did!?)

What's happened since: I connected/installed a usb-based card-reader about a week or so ago, and so that got me delving back into the udev rules, and needing to make some more entries in fstab, for the card-reader slots (there are four).

While adding the card-reader rules to 11-usb-media.rules, I tidied up/adjusted the older rule for the Kingston gadget, and also added a couple other udev rules for a Verbatim USB hard drive I have, as well as a Duracell 16Gib flash gadget.

All the devices mount and unmount correctly, and they each have their same proper /dev node with each boot. However, somewhere along the line here, not only did the Kingston gadget change its icon to a hard disk icon, but ALL these things are now shown in Konqueror as Hard disks


It's not a huge deal, since they all work properly, however, there are 21 items in my 'Media:/' list, and 16 of them have hard disk icons! I would prefer if the flash/usb gadgets appeared as 'removable media' icons, as it would make selecting the right device a tiny bit easier, as I could zero in on the icons easier


FWIW, here's the udev stuff:

Code:
# Verbatim USB HDD 160 Gib -- see note above; same applies for this drive re: RUN+
ATTRS{modalias}=="usb:v18A5p0214d0112dc00dsc00dp00ic08isc06ip50",NAME{all_partitions}="usb-verbatim-hdd",GROUP="disk"

# kingston datatraveller 1G usb device: -- see note above; same applies for this drive re: RUN+
SUBSYSTEMS=="usb",ATTRS{manufacturer}=="Kingston",ATTRS{product}=="DataTraveler 2.0",NAME{all_partitions}="usb-kingston",GROUP="plugdev"

# Duracell 16Gib USB flash stick: -- see note above; same applies for this drive re: RUN+
SUBSYSTEMS=="usb",ATTRS{idVendor}=="0930",ATTRS{idProduct}=="6545",NAME{all_partitions}="usb-duracell",GROUP="plugdev"

# the HP 4-slot 15-in-1 card reader I have now installed in my machine.
SUBSYSTEMS=="scsi",ATTRS{vendor}=="Generic ",ATTRS{model}=="USB SD Reader   ",ATTRS{rev}=="1.00",NAME{all_partitions}="card-reader-SD",GROUP="plugdev"
SUBSYSTEMS=="scsi",ATTRS{vendor}=="Generic ",ATTRS{model}=="USB CF Reader   ",ATTRS{rev}=="1.01",NAME{all_partitions}="card-reader-CF",GROUP="plugdev"
SUBSYSTEMS=="scsi",ATTRS{vendor}=="Generic ",ATTRS{model}=="USB SM Reader   ",ATTRS{rev}=="1.02",NAME{all_partitions}="card-reader-SM",GROUP="plugdev"
SUBSYSTEMS=="scsi",ATTRS{vendor}=="Generic ",ATTRS{model}=="USB MS Reader   ",ATTRS{rev}=="1.03",NAME{all_partitions}="card-reader-MS",GROUP="plugdev"
and here's the fstab file:

Code:
/dev/hdb1		swap			swap		defaults,noatime			0 0
proc			/proc			proc		defaults				0 0
devpts			/dev/pts		devpts		gid=5,mode=620				0 0
/dev/hda3		/media/easys_hda3	ext2		defaults,noauto,noatime			0 0
/dev/hda5		/			ext2		defaults				1 1
/dev/hda7		/home			ext2		defaults				1 2
/dev/hda8		/var/log		ext2		defaults				1 2
/dev/hda9		/media/storage_hda9	ext2 		defaults,nodev,noauto			1 2
/dev/hda10		/media/SSI_backup_hda10	ext2		defaults,noauto,noatime,nodev		1 2
/dev/hda11		/media/BW64_hda11	ext2		defaults,noauto,noatime			0 0
/dev/hda12		/media/FlightGear	ext2		defaults,user,noauto			0 0
/dev/hdb2		/media/storage_hdb2	ext2 		defaults,noauto,nodev			1 2
/dev/hdc		/media/CD		udf,iso9660	defaults,users,noauto,ro		0 0
/dev/pktcdvd/udf_cdrw	/media/CD		udf,iso9660	defaults,noauto,noatime			0 0
/dev/sr0		/media/DVD		udf,iso9660	defaults,users,noauto,ro		0 0
/dev/pktcdvd/udf_dvdrw	/media/DVD		udf,iso9660	defaults,noauto,noatime			0 0
/dev/fd0		/media/floppy		auto		defaults,users,noauto			0 0
/dev/usb-kingston1	/media/USB-Kingston	auto		defaults,users,noauto,noatime		0 0
/dev/usb-duracell1	/media/USB-Duracell	auto		defaults,users,noauto,noatime		0 0
/dev/usb-verbatim-hdd1	/media/USB-Verbatim-HDD	auto		defaults,users,noauto,noatime		0 0
/dev/card-reader-SD1	/media/CardReader/SD	auto		defaults,users,noauto,ro		0 0
/dev/card-reader-CF1	/media/CardReader/CF	auto		defaults,users,noauto,ro		0 0
/dev/card-reader-SM1	/media/CardReader/SM	auto		defaults,users,noauto,ro		0 0
/dev/card-reader-MS1	/media/CardReader/MS	auto		defaults,users,noauto,ro		0 0
Now, some folks (as well as documentation here and there) suggest NOT using fstab entries for removable (usb) media devices, but since I have had no trouble in the past with it, and it makes everything mount where it should when I mount it, I plan to keep the fstab entries.
I do not currently automount ANY of the usb thingies.

I just want my 'removable media' icons back

I've searched, of course, LQ and Google, the Gentoo wiki, and can't find anything that refers to or fixes this.

Thanks for reading, and for any hints you may have.

Sasha
 
Old 06-18-2009, 09:26 AM   #2
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,310

Rep: Reputation: 139Reputation: 139
I don't have an answer to your problem but an alternative suggestion to using fstab entries for removable media. I used to use fstab entries for removable media like you do and for the same reason; I wanted a consistent mount point. However, I now use partition labels on all my removable media and they consistently mount on /media/<Label> in all he distros I've tried. A partition label can be set with many partitioning tools but I tend to like gparted with the livecd, Parted Magic.
 
  


Reply

Tags
fstab, icons, kde, media, removable, udev


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandriva Flash, KDE desktop - problem getting removable media icons to appear . WSCC Mandriva 2 10-29-2007 12:20 AM
removable usb device (no icons created) retiem Ubuntu 3 10-18-2005 04:46 PM
Need to get Removable Drive Icons on Desktop barneyt Mandriva 10 05-18-2005 06:38 AM
Don't get rid of hard disk icons micder Debian 2 01-11-2005 12:26 PM
What / how to use Hard Disk icons on desktop The Director Linux - Newbie 3 05-09-2004 04:14 AM


All times are GMT -5. The time now is 01:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration