LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   Kmail stability (http://www.linuxquestions.org/questions/linux-desktop-74/kmail-stability-4175461788/)

propofol 05-13-2013 02:08 PM

Kmail stability
 
I have had the occasional kmail crash under Debian Squeeze however it was rare and easily fixed with:

Code:

rm -rf ~/.kde/share/apps/nepomuk
rm -rf ~/.config/akonadi/
rm -rf ~/.local/share akonadi/                                         
rm -rf ~/.kde/share/config/akonadi-firstrunrc

Followed by a restart. With the recent update to Wheezy things seems to have gotten worse with much more frequent failures to start. When I start kmail from the command line I get:

Code:

QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
KGlobal::locale::Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work
"/usr/bin/kmail(12706)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(12706)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(12706)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(12706)" Soprano: "QLocalSocket::connectToServer: Invalid name"
"/usr/bin/kmail(12706)" Soprano: "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
"/usr/bin/kmail(12706)" Soprano: "QLocalSocket::connectToServer: Invalid name"

I am not sure if this is just some problem with my system or if this is a known problem with kmail. I would appreciate any advice on how to fix this since I generally like kmail.

This is the version:
Package: kmail
Source: kdepim (4:4.4.11.1+l10n-3)
Version: 4:4.4.11.1+l10n-3+b1
Installed-Size: 28804

Regards,
Stefan

amani 05-17-2013 10:24 AM

Run it in gdb or some other debugger and file a bug at bugs.kde.org with backtrace.

Do you have a problem if the other-hardly-useful-services are disabled via system settings

propofol 05-18-2013 04:05 PM

Thanks for the reply. By other services, do you mean nepomuk? Can this be disabled without causing any problems in the kde desktop?

Regards,
Stefan

bill_from_tampa 05-18-2013 08:16 PM

I've had problems with neopmuk, and I turned it off in system settings -> desktop search, and have had no problems with KDE that I can detect. (with neopmuk running, occasionally it would get locked in a loop and peg one of the processors to 100% forever until killed - since turning it off that has not happened. It is a known bug).

propofol 05-19-2013 05:44 PM

Thanks, I will try that and see if it makes a difference.

Stefan

propofol 07-02-2013 01:21 AM

Just a follow up - since I have turned off Nepomuk I have not had problems. I have also found that it is a good idea to start kmail before other programs.


All times are GMT -5. The time now is 09:00 PM.