LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 12-04-2010, 03:17 AM   #1
Lord_Grave
LQ Newbie
 
Registered: Aug 2005
Posts: 27

Rep: Reputation: 15
Question Keyboard layouts in XFCE


Is there a GUI tool to change keyboard layouts in XFCE? So far, I haven't been able to find one. I'm using setxkbmap in console to change the layout. If there is no graphical tool, is there any way to make the setxkbmap change permanent so that XFCE uses the desired keyboard layout on startup?
 
Old 12-04-2010, 04:58 AM   #2
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,502

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883
You can edit your xorg.conf file
Quote:
Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "be"
EndSection
Kind regards
 
Old 12-04-2010, 05:28 AM   #3
Lord_Grave
LQ Newbie
 
Registered: Aug 2005
Posts: 27

Original Poster
Rep: Reputation: 15
Thanks for the response, repo. My xorg.conf now contains this:

Code:
Section "InputDevice"
  Identifier "Keyboard 0"
  Driver "kbd"
  Option "XkbModel" "pc105"
  Option "XkbLayout" "rs"
  Option "XkbVariant" "latinyz"
EndSection
After reboot, I still get the default US layout.
 
Old 12-04-2010, 05:35 AM   #4
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,502

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883
Did you tried using yast?
Perhaps you can use the xfce4-xkb-plugin
http://goodies.xfce.org/projects/pan...ce4-xkb-plugin

Kind regards
 
Old 12-04-2010, 06:29 AM   #5
Lord_Grave
LQ Newbie
 
Registered: Aug 2005
Posts: 27

Original Poster
Rep: Reputation: 15
YaST keyboard settings are completely ignored in XFCE. I've found out that the new versions of xorg use hot-plugging for input devices, ignoring the InputDevice sections of xorg.conf. For my needs, I had to use:

Section "InputClass"
Identifier "Keyboard Defaults"
MatchIsKeyboard "yes"
Option "XkbModel" "pc105"
Option "XkbLayout" "rs"
Option "XkbVariant" "latinyz"
EndSection

Thanks for suggesting the plugin. I just installed it and will test is asap.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to add keyboard layouts in xfce? harakanvarpaita Linux - Desktop 0 11-23-2007 01:26 PM
bewildered keyboard layouts in xfce harakanvarpaita Linux - Desktop 0 11-13-2007 12:51 AM
available keyboard layouts sinister035 Linux - Newbie 4 07-02-2007 04:11 AM
Keyboard layouts and languages in Xfce okok Linux - Newbie 1 05-04-2006 04:04 PM
keyboard layouts misulo Fedora 0 08-17-2004 01:29 PM


All times are GMT -5. The time now is 02:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration