LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 10-14-2010, 02:46 PM   #1
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 337

Rep: Reputation: 18
kde4 refuses to retain the screen resolution that I choose.


I am currently using kde4 in Debian (Squeeze). I need to use a lower resolution than the one selected by kde4. Every time I change it to suit my needs, after rebooting in kde4, the resolution changes and the highest one supported by the GPU is automatically selected.

Please note, that I was never comfortable with native resolutions. More often that not, I change to one that is lower. I am using kde4 screen resize module that temporarily succeeded to change the screen resolution to that which I need.

I also tried to create an empty xorg.conf file with file permissions that allow everyone to write to it without success. The screen resolution applet, only changes the screen resolution for the current session, without bothering to save the changes so that they can be used by the successive boots.

Is there a way out of this labyrinth?
 
Old 10-14-2010, 03:16 PM   #2
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Are you trying to make this change as the root user? You'll likely have to do it as root.
 
Old 10-14-2010, 04:07 PM   #3
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 337

Original Poster
Rep: Reputation: 18
Quote:
Originally Posted by vectordrake View Post
Are you trying to make this change as the root user? You'll likely have to do it as root.
I tried to run the screen resize applet with root privileges but it failed to initialize itself and exited gracefully informing me that it couldn't initialize itself. Here is the error message:

Code:
root@edbarx-pc2:/home/edbarx# krandrtray
display-randr(2145): KUniqueApplication: Cannot find the D-Bus session server:  "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." 

display-randr(2144): KUniqueApplication: Pipe closed unexpectedly.

Last edited by edbarx; 10-14-2010 at 04:09 PM. Reason: Code tags improperly placed.
 
Old 10-16-2010, 02:27 PM   #4
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 337

Original Poster
Rep: Reputation: 18
An alternative to reducing the resolution is to use more readable fonts i.e. bolder although not bold as real bold characters. This used to happen when I used an NVIDIA GPU but now I am using an intel GPU. Is there a good document that I can consult to create a custom xml file to replace /home/myusername/.fonts.conf?

As a side note: I am not exactly a Linux beginner. I have been using Debian for the past five years or so. Please, give me a true kick start with my new laptop.

Thanks.

Last edited by edbarx; 10-16-2010 at 02:29 PM. Reason: To correct a grammatical error.
 
Old 10-16-2010, 02:37 PM   #5
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
This post on this Arch list seems to have an answer that might work for you.
 
Old 10-16-2010, 02:59 PM   #6
edbarx
Member
 
Registered: Sep 2010
Distribution: Used Debian since Sarge. (~2005)
Posts: 337

Original Poster
Rep: Reputation: 18
Thanks for the link. I read the linked thread for more information. It seems that it may work.

Thanks a lot.
 
Old 10-16-2010, 06:41 PM   #7
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
I hope that this is the most elegant solution, at least until they decide to incorporate a proper fix in the DE.
 
Old 10-17-2010, 05:52 PM   #8
mecelec415
Member
 
Registered: Jan 2008
Location: Noble Park ,Victoria, Australia
Distribution: Mageia
Posts: 183
Blog Entries: 2

Rep: Reputation: 23
gday I dont really know much so may be of no help any if your using KDE would that make xorg.confg the file config file for the grahic driver ?edit it and set the screen res there? its in etc/x11
after looking at my xorg.conf Have you tried the XFdrake to change the res ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE4 plasmoids won't retain position (or resize) corteplaneta Ubuntu 1 05-25-2010 02:14 PM
KDE4 forgets screen resolution after log out ekinakoglu Fedora 2 02-16-2010 11:27 AM
[SOLVED] Slackware 13: OpenOffice refuses to use GTK2/KDE4 themes. shonumi Slackware 3 09-14-2009 09:04 PM
nvidia screen resolution limited to 1024 in suse11.1 and KDE4.1 with 3d enabled ianio Suse/Novell 3 01-28-2009 03:11 AM
Can't retain my resolution or choose my graphic manager in Slackware 12.1 gregorian Linux - Newbie 10 05-27-2008 12:34 AM


All times are GMT -5. The time now is 07:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration