LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
Search this Thread
Old 04-07-2011, 03:17 AM   #1
Tribulation
Member
 
Registered: Jun 2008
Distribution: Slackware
Posts: 129

Rep: Reputation: 25
KDE4 desktop effects work in root but not in user account


I upgraded to Slackware -Current earlier after a fresh install of 13.1, bringing KDE up to version I'm using KDE 4.5.5. I logged in with my User account, configured stuff, installed stuff, the usual. I even logged out and rebooted a few times. Everything worked as expected. I logged into XFCE for a few hours while I transfered files (for some reason Dolphin wasn't reading the folder sizes correctly and wasn't transferring everything, I had no such problems in XFCE). When I logged back into KDE I found that desktop effects weren't active, even the work spaces on the left were arranged in a line rather than two by two. Also, Akonadi server doesn't start up when I log in anymore.

In Desktop Effects settings I am told that they are not available, though I am given no reasons why. I tried to restart them and got some error message about how another program was stopping them, and I could use a keyboard shortcut to activate them. I did so but nothing really happened. After a couple of restarts I no longer get that error and I do have basic effects like transparent panels and windows become transparent when I move them, but my All Effects tab is empty. For the sake of experimentation I logged in as root and everything was as it should be; Akonadi started up, workspaces were arranged two by two, my all effects tab was full and I could use any effect that I wanted... I'm not sure what is going on, I have very limited KDE experience, so any help would be appreciated.
 
Old 04-07-2011, 02:21 PM   #2
bluebox
Member
 
Registered: Jun 2004
Posts: 71

Rep: Reputation: 6
Quote:
Originally Posted by Tribulation View Post
After a couple of restarts I no longer get that error and I do have basic effects like transparent panels and windows become transparent when I move them, but my All Effects tab is empty. For the sake of experimentation I logged in as root and everything was as it should be;
"restarting" should not change anything, so you probably messed something up unwittingly. And you probably already have heard that starting a desktop as root may have strange side-effects.

But actually things do work, so this does not seem to be a hardware/driver problem. Create a new user and see whether your desktop behaves as expected when running as this new user.
 
Old 04-07-2011, 05:19 PM   #3
Tribulation
Member
 
Registered: Jun 2008
Distribution: Slackware
Posts: 129

Original Poster
Rep: Reputation: 25
Oddly enough, everything works fine on another account, even though the only things I changed that have anything to do with effects is that I ticked a couple of effects, never messed with anyone else, the only configuration files I really messed with was Lilo, fstab, and inittab. Well, after the effects stopped working I switched compositing type from OpenGL to XRender just to see what happens and nothing changes, but now I can't switch back to OpenGL, even with effects turned off, I get the message "Failed to activate desktop effects using the given configuration options."
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get desktop effects to work outside of root user mothergoose729 Slackware 17 11-23-2009 08:40 PM
How to configure kdm in KDE4 System Settings from non-root user account? integrale16 Slackware 2 09-12-2009 01:15 PM
Desktop Effects in KDE4 will not start daghenningsorbo Linux - Desktop 1 08-26-2009 04:10 PM
Desktop effects in KDE4 keep resetting vdemuth Slackware 7 02-13-2009 03:25 PM
I enabled 3d effects for kde4 and now I can't see the desktop. xiqtem Suse/Novell 4 01-19-2009 04:43 PM


All times are GMT -5. The time now is 11:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration