LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Desktop (http://www.linuxquestions.org/questions/linux-desktop-74/)
-   -   KDE Power Profile scripts : Command Line=YES System Settings=FAIL (http://www.linuxquestions.org/questions/linux-desktop-74/kde-power-profile-scripts-command-line%3Dyes-system-settings%3Dfail-940321/)

Bill Gates 666 04-17-2012 04:56 PM

KDE Power Profile scripts : Command Line=YES System Settings=FAIL
 
Hi

I was just messing about with my Linux-Mint KDE (Kubuntu 11.10) install. I've got KDE 4.8.2 installed from the backports. Running on my dual core 2.67Ghz Core 2 Duo laptop (which has CPU frequency steps of 800Mhz, 1600Mhz, 2130Mhz and 2670Mhz).

Anyway I've tried to add some simple scripts to my power profiles (basically these change the upper frequency limit for CPU scaling, for each core, with the on-demand governor):
Code:

/usr/local/sbin/ $  ls -Ahl
-rwxr-xr-x 1 root root 85 2012-04-17 21:52 cpufreq_highperformance.sh
-rwxr-xr-x 1 root root 82 2012-04-17 21:51 cpufreq_lowperformance.sh
-rwxr-xr-x 1 root root 82 2012-04-17 21:52 cpufreq_mediumperformance.sh
/usr/local/sbin/ $  cat cpufreq_lowperformance.sh
sudo /usr/bin/cpufreq-set -c 0 -u 1.6Ghz
sudo /usr/bin/cpufreq-set -c 1 -u 1.6Ghz
...

Following the ARCH wiki I've carefully added my user to a custom sudor's file to ensure that I can run /usr/bin/cpufreq-set with sudo - without needing a password.

On the command line I can type:
Code:

/usr/local/sbin/cpufreq_lowperformance.sh
which works - no sudo password required.

However adding this command to the script run box in KDE / System Settings / Power Management / Energy Saving Settings / On AC Power & On Battery Power does nothing very much at all. The cpufreq-info command shows the same upper CPU frequency (for each core) as before. The rest of the profile settings are loaded and I can see the tray notification for the change from AC power to battery...

Any thoughts? :study::doh::confused::banghead:
Mr Gates


All times are GMT -5. The time now is 03:11 PM.